Find the answer to your Linux question:
Results 1 to 4 of 4
Hi! my system: Slackware based x86_64 Linux. I set the TZ to "Europe/Berlin", but that doesn't change the way "date" prints it's date/time string. Code: $ date Sun Jun 22 ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! Rava's Avatar
    Join Date
    Jul 2007
    Location
    hacking 127.0.0.1
    Posts
    50

    Arrow Date/Time setting for thunderbird


    Hi!

    my system: Slackware based x86_64 Linux.

    I set the TZ to "Europe/Berlin", but that doesn't change the way "date" prints it's date/time string.

    Code:
    $ date
    Sun Jun 22 16:06:51 CEST 2014
    $ echo $TZ
    Europe/Berlin
    Now, my issue is: I run XFCe as X windows manager, and there seems to be no settings for time/date with its settings manager.

    I want in Thunderbird the date and time to be German / European, as in:

    DD.MM.YYYY (German speaking countries style) or DD-MM-YYYY (European style)) - and not like MM/DD/YYYY " (USA style)

    Also, the time in 24 hrs format, also known as "military time", and not as 12 hours am/pm style.

    Any ideas how to handle this?

    I have the right time and date set in the XFCe clock. But when I first installed Thunderbird, it was either the default (US) or the en_GB version, but now I switched to the German (de) version, since I installed its German localized calendar (aka Lightening), and I dislike part English and part german main menu... O_o

    Did I miss some settings I need to do in the console? Or do I miss something with XFCe?
    Or do I need to tell Thunderbird how it should handle my date/time listings?

  2. #2
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,737
    RTFM (man page) for the date command. It can do what you want. When you run it in default mode (there are environment variables to set which will change default output format) this is what you get. At least the time zone appears correct!
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  3. #3
    Penguin of trust elija's Avatar
    Join Date
    Jul 2004
    Location
    Either at home or at work or down the pub
    Posts
    3,649
    In Mint Xfce you can use System -> Time and Date which to be honest is not where I would have expected to find it
    "I used to be with it, then they changed what it was.
    Now what was it isn't it, and what is it is weird and scary to me.
    It'll happen to you too."

    Grandpa Simpson



    The Fifth Continent

  4. $spacer_open
    $spacer_close
  5. #4
    Linux User nihili's Avatar
    Join Date
    Dec 2013
    Posts
    346
    maybe your systems locale is not set to german?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •