Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 20
I'm using SUSE 7.3 with with KDE 3.0.5 and Xfree 4.11.0 and, after replacing my graphics card (an NVidia TNT2) with an indentical model (the original died), I lost the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2003
    Posts
    18

    Login Managers and Greeting Screens


    I'm using SUSE 7.3 with with KDE 3.0.5 and Xfree 4.11.0 and, after replacing my graphics card (an NVidia TNT2) with an indentical model (the original died), I lost the pretty kde login screen, the one with the nice icons for allowed users, and now have an plain, ugly, grey, text-based login screen?

    The kde login manager does not appear to work properly when applying changes (a known bug apparenty) and I have been through all the things I can think of. Strangely, the configuration in kdmrc appears to be identical to another machine where the nice, icon-based login screen does appear correctly. Here is the part that I believe matters.

    [X-*-Greeter]
    AntiAliasing=true
    DefaultUser=adabas
    EchoMode=NoEcho
    FailFont=Nimbus Sans l,12,-1,5,74,0,0,0,0,0
    FocusPasswd=false
    GUIStyle=Default
    GreetFont=Nimbus Sans l,20,-1,5,48,0,0,0,0,0
    GreetString=SuSE Linux 7.3.99 (%h)
    GreeterPosFixed=false
    GreeterPosX=100
    GreeterPosY=100
    HiddenUsers=nobody,root,
    Language=en_US
    LogoArea=Logo
    LogoPixmap=
    MaxShowUID=65535
    MinShowUID=100
    PreselectUser=Previous
    SelectedUsers=gee,guest,
    SessionTypes=kde,windowmaker,fvwm2,mwm,twm,failsaf e,
    ShowUsers=Selected
    SortUsers=true
    StdFont=Nimbus Sans l,12,-1,5,48,0,0,0,0,0

    Question is: which file determines what login/greeting screen is displayed and how can I force it to be read...

    Thanks in advance for any pointers

  2. #2
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Plain, ugly, grey, text-based? Doesn't sound like X at all to me. It seems rather more likely that it is your X server that refuses to run. Can you get it (the X server) started at all?

  3. #3
    Just Joined!
    Join Date
    Jun 2003
    Posts
    18

    Plain, ugly, grey, text-based?

    Sorry, my mistake - it always looks so clear and concise when you type it in, doesn't it? X starts, no problems and the system itself performs faultlessly otherwise. The grey screen I refer to is the GUI login/Welcome screen, where you fill in the users name/password by typing them in as text in order to fire up a KDE session - and, indeed this starts as normal. It is this initial "Login/Welcome" screen (I use the term "Welcome" only because this is the term used in the docu/man pages) that is the problem for me in that before I had to replace the dead graphics card (for an indentical nVidia TNT2 - 32MB), I had the nice KDE login screen with the users shown as ICONS and the SUSE background wallpaper. Whatever I seem to do now to the kdmrc file, either by means of YAST or directly in the file itself appears to make no difference.

    Don't get me wrong, this is about as far from a show stopper as you can get. But it would be nice to know how to fix it and so far a solution has eluded me...

    Thanks

    Gee

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    If it's grey, then it sounds more like xdm than kdm. I don't know why it would have changed, but it might have somehow.
    When it's displayed, go to a text mode terminal, log in and run "ps -A | grep .dm" to see what display manager is running.

  6. #5
    Just Joined!
    Join Date
    Jun 2003
    Posts
    18

    sounds more like xdm than kdm

    That was it! I did a find -exec grep of /etc and found that an instance of xdm in the rc.config. Perhaps it was always so and only became a problem after the graphic controller went kaboom, though I find this hard to believe. Whatever, I changed the setting to kdm, which was the setting in the SUSE 8.0 clients and the pretty-little welcome screen has been reincarnated. I think my confusion can be laid at the door of so much of /etc being change between SUSE 7.3 and 8.0 that I was not looking in the right places.

    Thanks anyway for pointing me in the right direction and keep up the good work.

    Gee

  7. #6
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    If I am to make an educated guess at why it changed to xdm, I'd say that the init scripts tried to fall back on xdm when kdm failed (since your X config might have been broken at least a while).

  8. #7
    Linux User Allblack's Avatar
    Join Date
    May 2003
    Location
    Godzone
    Posts
    416
    I have similar problems. It does not work at all. I just get the defailt username-password boxes. KDM or XDM does not work. What could be the problem?
    Here's kdmrc file
    Code:
    Desktop0]
    BackgroundMode=VerticalGradient
    BlendBalance=100
    BlendMode=NoBlending
    ChangeInterval=60
    Color1=138,148,198
    Color2=104,112,150
    CurrentWallpaper=0
    LastChange=0
    MinOptimizationDepth=1
    MultiWallpaperMode=NoMulti
    Pattern=
    Program=
    ReverseBlending=false
    UseSHM=false
    Wallpaper=/usr/share/backgrounds/images/default.png
    WallpaperList=
    WallpaperMode=Centred
    
    [General]
    PidFile=/var/run/kdm.pid
    Xservers=/usr/share/config/kdm/Xservers
    
    [Shutdown]
    HaltCmd=/sbin/poweroff
    LiloCmd=/sbin/lilo
    LiloMap=/boot/map
    RebootCmd=/sbin/reboot
    UseLilo=false
    
    [X-*-Core]
    AllowNullPasswd=true
    AllowRootLogin=true
    AllowShutdown=Root
    AutoReLogin=false
    Reset=/usr/share/config/kdm/Xreset
    Resources=/etc/X11/Xresources
    Session=/usr/share/config/kdm/Xsession
    Setup=/usr/share/config/kdm/Xsetup
    Startup=/usr/share/config/kdm/Xstartup
    
    [X-*-Greeter]
    AntiAliasing=true
    ColorScheme=Default
    DefaultUser=gpdefryn
    EchoMode=OneStar
    FaceSource=PreferAdmin
    FailFont=Sans,10,-1,5,75,0,0,0,0,0
    FocusPasswd=false
    GUIStyle=Bluecurve
    GreetFont=Sans,12,-1,5,75,0,0,0,0,0
    GreetString=Welcome to the Jungle
    GreeterPosFixed=false
    GreeterPosX=100
    GreeterPosY=100
    HiddenUsers=adm,alias,amanda,apache,bin,bind,daemon,exim,falken,ftp,games,gdm,gopher,halt,httpd,ident,ingres,kmem,lp,mail,mailnull,man,mta,mysql,named,news,nfsnobody,nobody,nscd,ntp,operator,pcap,pop,postfix,postgres,qmaild,qmaill,qmailp,qmailq,qmailr,qmails,radvd,reboot,rpc,rpcuser,rpm,sendmail,shutdown,squid,sympa,sync,tty,uucp,xfs,xten
    Language=en_US
    LogoArea=Clock
    LogoPixmap=
    MaxShowUID=65000
    MinShowUID=500
    PreselectUser=None
    SelectedUsers=myname
    SessionTypes=default,kde,failsafe,gnome,
    ShowUsers=Selected
    SortUsers=true
    StdFont=Sans,10,-1,5,50,0,0,0,0,0
    UseBackground=true
    
    [X-:*-Core]
    AllowNullPasswd=true
    AllowRootLogin=true
    AllowShutdown=All
    NoPassEnable=false
    NoPassUsers=
    
    [X-:0-Core]
    AutoLoginEnable=false
    AutoLoginUser=myname
    
    [Xdmcp]
    Enable=false
    Willing=/usr/share/config/kdm/Xwilling
    Xaccess=/usr/share/config/kdm/Xaccess
    any ideas
    I am on a journey to mastering Linux and I got a bloody long way to go!!!

  9. #8
    Linux User Allblack's Avatar
    Join Date
    May 2003
    Location
    Godzone
    Posts
    416
    Oops. Looks like kdm was not running.
    However, I am having problems configuring at runlevel 5

    Code:
    chkconfig --level 5 /usr/bin/kdm on
    error reading information on service /usr/bin/kdm: No such file or directory
    /usr/bin/kdm is returned when I do a which kdm
    and I was able to start it when I ran kdm -nodaemon from level 3
    I am on a journey to mastering Linux and I got a bloody long way to go!!!

  10. #9
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    What distro are you using?

  11. #10
    Linux User Allblack's Avatar
    Join Date
    May 2003
    Location
    Godzone
    Posts
    416
    I am using Redhat 9
    I am on a journey to mastering Linux and I got a bloody long way to go!!!

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •