Find the answer to your Linux question:
Results 1 to 3 of 3
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! Dingo001's Avatar
    Join Date
    Apr 2008
    Location
    Canada
    Posts
    10

    Debian 8 Jessie and Gnome and Tightvncserver


    I had Debian 7 (Whezzy) running on a dedicated server with Gnome and I could use tightvncserver to access it no problems.

    I updated the server to Debian 8 (Jessie) and tightvnc stopped working at all. I removed tightvncserver and gnome and re installed them.

    I can use tightvnc to access the server but all I see is the green screen. My /root/.vnc/xstartup looks like this:

    Code:
    #!/bin/sh
    
    # Uncomment the following two lines for normal desktop:
    # unset SESSION_MANAGER
    # exec /etc/X11/xinit/xinitrc
    
    [ -x /etc/vnc/xstartup ] && exec /etc/vnc/xstartup
    [ -r $HOME/.Xresources ] && xrdb $HOME/.Xresources
    xsetroot -solid grey
    #vncconfig -iconic &
    x-terminal-emulator -geometry 80x24+10+10 -ls -title "$VNCDESKTOP Desktop" &
    gnome-session &
    I use this to start the vnc server:

    tightvncserver -geometry 1920x1080 -depth 24 :1

    The log file for the start says this:

    cat /root/.vnc/dedicated server ip.log
    30/09/16 20:33:23 Xvnc version TightVNC-1.3.9
    30/09/16 20:33:23 Copyright (C) 2000-2007 TightVNC Group
    30/09/16 20:33:23 Copyright (C) 1999 AT&T Laboratories Cambridge
    30/09/16 20:33:23 All Rights Reserved.
    30/09/16 20:33:23 See had to take out the url for information on TightVNC
    30/09/16 20:33:23 Desktop name 'X' (my server name)
    30/09/16 20:33:23 Protocol versions supported: 3.3, 3.7, 3.8, 3.7t, 3.8t
    30/09/16 20:33:23 Listening for VNC connections on TCP port 5901
    Failed to parse arguments: Unknown option --login
    gnome-session-is-accelerated: No composite extension.
    gnome-session-check-accelerated: Helper exited with code 256

    I have tried a few versions of /root/.vnc/xstartup but they all give errors:

    1.
    Code:
    #!/bin/shxrdb $HOME/.Xresources
    xsetroot -solid grey
    x-terminal-emulator -geometry 80x24+10+10 -ls -title "$VNCDESKTOP Desktop" &
    # x-window-manager &
    gnome-session &
    gives this error

    30/09/16 20:37:23 Xvnc version TightVNC-1.3.9
    30/09/16 20:37:23 Copyright (C) 2000-2007 TightVNC Group
    30/09/16 20:37:23 Copyright (C) 1999 AT&T Laboratories Cambridge
    30/09/16 20:37:23 All Rights Reserved.
    30/09/16 20:37:23 See had to take out the url for information on TightVNC
    30/09/16 20:37:23 Desktop name 'X' (my server ip:1)
    30/09/16 20:37:23 Protocol versions supported: 3.3, 3.7, 3.8, 3.7t, 3.8t
    30/09/16 20:37:23 Listening for VNC connections on TCP port 5901
    sh: 1: /root/.vnc/xstartup: not found

    88888888888888888888888888888888

    it is there server:~# ls -l /root/.vnc/xstartup
    -rwxr-xr-x 1 root root 167 Sep 30 20:36 /root/.vnc/xstartup

    Any help would be appreciated.

    It does not need to be gnome but I need a GUI that I can start a browser in.

    Cheers

  2. #2
    Just Joined! Dingo001's Avatar
    Join Date
    Apr 2008
    Location
    Canada
    Posts
    10

    Debian 8 Jessie and Gnome and Tightvncserver

    Added an attachment screen shot
    Attached Images Attached Images

  3. #3
    Just Joined! Dingo001's Avatar
    Join Date
    Apr 2008
    Location
    Canada
    Posts
    10
    -->
    Fixed by

    1. removing gnome, tightvncserver, xfce4, xfce4-goodies, and gnome-icon-theme.
    2. Installed apt-get install x-window-system-core gdm3 tightvncserver
    3. vi /root/.vnc/xstartup to uncomment these two lines:

    unset SESSION_MANAGER
    exec /etc/X11/xinit/xinitrc

    started vncserver and with just the vncserver command NOT tightvncserver -geometry 1920x1080 -depth 24 :1


    and it works fine so far.

$spacer_open
$spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •