Find the answer to your Linux question:
Results 1 to 3 of 3
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    Xorg.0.log flooded with trivial messages; how to stop?


    Debian 8.6.0; kernel 3.16.36; twm; amd64; GTX750Ti; Nvidia 367.44 driver.
    When Xwindows goes to "standby", i.e. via -dpms when no key/mouse activity for 30 minutes, the following message is written to Xorg.0.log EVERY 2 SECONDS!

    [254278.921] (--) NVIDIA(GPU-0): HP 2009 (DFP-0): connected
    [254278.921] (--) NVIDIA(GPU-0): HP 2009 (DFP-0): Internal TMDS
    [254278.921] (--) NVIDIA(GPU-0): HP 2009 (DFP-0): 330.0 MHz maximum pixel clock

    A similar, but more detailed, message is written whenever I switch VC (virtual consoles). I don't mind that. But the repeating message builds the Xorg.0.log file to enormous size within a few days. It adds roughly 500K bytes every hour and I don't see any diagnostic value in it.

    Is there an Xorg option to turn it off? I can't find one. Where does that message come from? I'm willing to modity, and re-compile, the offending code if there is no user option to disable it.
    Since it is written to the Xorg log file I assume that's where it originates, or maybe triggered by an event from the monitor (in standby mode).

    Thanks for any ideas or leads.

  2. #2
    Linux Guru budman7's Avatar
    Join Date
    Oct 2004
    Location
    Knee deep in Grand Rapids, Michigan
    Posts
    3,901
    I am not positive, but, I think you can look in /etc/rsyslog.conf
    I have this in mine.


    # Filter duplicated messages
    $RepeatedMsgReduction on

    While in that file you will see other files you can look at.
    If you want to learn more about linux take a linux journey
    https://linuxjourney.com/
    Use CODE tags when posting output of commands. Thank you.
    https://www.linuxcounter.net/cert/608410.png

  3. #3
    Linux Guru
    Join Date
    Dec 2013
    Posts
    2,747
    -->
    not sure if you can disable these log messages (what do they mean? maybe not so trivial?).
    if, then you should tell the nvidia driver to stop spouting.
    but you can prevent logs from growing too big with logrotate (see debian wiki).

$spacer_open
$spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •