Find the answer to your Linux question:
Results 1 to 9 of 9
I got an NVIDIA card on my linux box a while back and had a few problems with it corrupting my console (thread here , if you're interested). That's partly ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Nov 2004
    Location
    New York
    Posts
    150

    NVIDIA driver overwrites xorg.conf at boot [solved]


    I got an NVIDIA card on my linux box a while back and had a few problems with it corrupting my console (thread here, if you're interested). That's partly solved now, but I've run into another wall. Every time I restart, my xorg.conf is overwritten with another file, in which the nvidia (as opposed to nv) driver is loaded. I can alter the .conf after I boot, and the changes will take effect for the rest of that session, but unless I uninstall the driver entirely it'll overwrite the file sometime in the shutdown process. Anyone know what could cause this, or what logs I should be looking at?
    \"Nifty News Fifty: When news breaks, we give you the pieces.\" - Sluggy Freelance

  2. #2
    Linux Enthusiast
    Join Date
    Jun 2004
    Location
    Windsor, CO
    Posts
    656
    I don't think it's the nvidia driver that's overwriting xorg.conf, because I've used it under two different distros, and nothing like that ever happened if you changed the driver setting.
    Emotions are the key to the soul.
    Registered Linux User #375050

  3. #3
    Linux Guru loft306's Avatar
    Join Date
    Oct 2003
    Location
    The DairyLand
    Posts
    1,666
    yeah it is not overwriting the xorg.conf are you shure you are editing the xorg.conf as root and are you going back into the editor or doing a
    Code:
    cat /etc/X11/xorg.conf
    to confirm that the changes were made to the file?

    er... and an edited xorg.conf the changes dont take effect unless you restart 'x'
    ~Mike ~~~ Forum Rules
    Testing? What's that? If it compiles, it is good, if it boots up, it is perfect. ~ Linus Torvalds
    http://loft306.org

  4. #4
    Linux Guru
    Join Date
    Mar 2003
    Location
    Wisconsin
    Posts
    1,907
    It could very well be MCC. If you've changed the value from nv to nvidia in MCC, then it could be over-writing your Xorg file. Both 10.1c and o have that over-write problem.

    /me curses MCC!
    Jeremy
    Registered Linux user #346571
    "All The Dude ever wanted was his rug back" - The Dude

  5. #5
    Linux Engineer
    Join Date
    Nov 2004
    Location
    Montreal, Canada
    Posts
    1,267
    also make sure (this could be it) that you set the right properly! if you changed rights to rwx to user, to be able to mod xorg.conf from user, this could permit some overwriting at boot... remove the write access of ever this is the case.
    \"Meditative mind\'s is like a vast ocean... whatever strikes the surface, the bottom stays calm\" - Dalai Lama
    \"Competition ultimatly comes down to one thing... a loser and a winner.\" - Ugo Deschamps

  6. #6
    Linux Newbie
    Join Date
    Nov 2004
    Location
    New York
    Posts
    150
    Thanks for the replies.

    Quote Originally Posted by Stormblazer
    I don't think it's the nvidia driver that's overwriting xorg.conf, because I've used it under two different distros, and nothing like that ever happened if you changed the driver setting.
    Well then I can only imagine something that the installer modified must be causing the problem.

    Quote Originally Posted by loft306
    yeah it is not overwriting the xorg.conf are you shure you are editing the xorg.conf as root and are you going back into the editor or doing a
    Code:
    cat /etc/X11/xorg.conf
    to confirm that the changes were made to the file?

    er... and an edited xorg.conf the changes dont take effect unless you restart 'x'
    I am editing it through a root tty, with mcedit. I confirmed the changes were made by going back into the editor, and also by seeing that I could disable or enable nvidia for the next time I restarted X without restarting the OS. I did a 'cat /etc/X11/xorg.conf | less' to be safe, and it confirmed that the file was in fact saved.

    I'm booting up into runlevel 5 without an initial GUI. To test X, I do a startx from my user account's tty, and then shut it down either by logging out of X or by doing ctrl+alt+backspace (is that bad?).


    Quote Originally Posted by jeremy1701
    It could very well be MCC. If you've changed the value from nv to nvidia in MCC, then it could be over-writing your Xorg file. Both 10.1c and o have that over-write problem.

    /me curses MCC!
    Jeremy
    I was thinking of that, but this happens whether or not I use the control center for the session - in fact, it happens whether or not I even boot into X at all.

    Quote Originally Posted by UgoDeschamps
    also make sure (this could be it) that you set the right properly! if you changed rights to rwx to user, to be able to mod xorg.conf from user, this could permit some overwriting at boot... remove the write access of ever this is the case.
    I tried disabling all permissions to ensure that a user process wasn't doing it, but to no avail. While I was at it, I also modified my inittab to boot to runlevel 3, but that did nothing.


    I guess it's worth mentioning that on my system (I'm not sure how many other distros do this), xorg.conf is a symbolic link to XF86Config. There is also an auto-generated XF86Config.old in the same directory, and I found that it possessed the changes I originally made to the first Config. So it's not so much overwriting as renaming and replacing.



    [edit] This just in! I've found that my /etc/inittab is modified as well. After changing the default runlevel to 3, it boots up in that state next time, but by then something has changed the file setting back to 5, so it boots up in 5 another power cycle later. This still happens when I uninstall nvidia. Also, wile nvidia is uninstalled, xorg is still replaced, it just doesn't have the nvidia line in the substitute file! I guess StormBlazer was right.


    So now I seem to be dealing with an evil of Mandrake rather than of nvidia.
    \"Nifty News Fifty: When news breaks, we give you the pieces.\" - Sluggy Freelance

  7. #7
    Linux Engineer
    Join Date
    Nov 2004
    Location
    Montreal, Canada
    Posts
    1,267
    I dont think the evilness as to do with it :P
    but this is interesting...
    whats the rights on inittab
    also, since xorg.conf is a ln -s to xf86config, are the rights properly set on xf86config? if not try that... try putting something like x-x-x restart X as normal user... and try debugging by adding rights one at the time, im sure youll end up getting the problem... sorry for not been of much help, but I never had a problem like this
    \"Meditative mind\'s is like a vast ocean... whatever strikes the surface, the bottom stays calm\" - Dalai Lama
    \"Competition ultimatly comes down to one thing... a loser and a winner.\" - Ugo Deschamps

  8. #8
    Linux Newbie
    Join Date
    Nov 2004
    Location
    New York
    Posts
    150
    It's XFdrake! I need to figure out how to disable it, and what affect if any doing so would have on my system.

    At the top of my xorg.conf file - which should've been the first place I looked, if I weren't such an idiot - is a message saying the file was generated by XFdrake. (Could it be any more obvious? Doh!). I searched /var/log/syslog for that program and found that it was called on bootup. I also saw that it recorded modifying inittab!

    So the question is, exactly what do I change/remove/tinker-with in /etc/rc.d to disable a program?
    \"Nifty News Fifty: When news breaks, we give you the pieces.\" - Sluggy Freelance

  9. #9
    Linux Newbie
    Join Date
    Nov 2004
    Location
    New York
    Posts
    150
    Problem solved - I asked about disabling XFdrake on mandrake's forums and it's as simple as turning off the Harddrake service. I was able to get hardware acceleration working minutes later. Thanks for helping me get this far.
    \"Nifty News Fifty: When news breaks, we give you the pieces.\" - Sluggy Freelance

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •