Find the answer to your Linux question:
Results 1 to 6 of 6
I'm having a slight problem with Nvidia's drivers that I thought one of you guys could help me out with. I tried installing the driver in Fedora Core 3 and ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2005
    Posts
    4

    Nvidia install errors


    I'm having a slight problem with Nvidia's drivers that I thought one of you guys could help me out with. I tried installing the driver in Fedora Core 3 and Mandrake 10.1. I had the same problem with both. I went through the install process perfectly (i think). I edited my /etc/X11/xorg.conf file appropriately. I know the Nvidia driver is loading and I get the splash screen. I had a problem with the splash screen not going away when it was supposed to but I fixed that by adding NvAGP "0" to the options in my xorg.conf file. The problem I have now is after the splash screen goes away and I login through gdm....no matter what GUI I go into the windows are all garbled (technical term) and it's not usable. I can go back to my old configuration of "nv" no prob and it works fine but I can't resolve the issue with the nvidia drivers. I want the nvidia drivers because I've read that xorg's composite shadows/transparancies will run faster if I have them installed, and I really like the look of this eye candy. I want to be able to show my M$ using friends just how great the linux desktop can look. Any help or advice would be appreciated. Thanks

  2. #2
    Linux Engineer
    Join Date
    Nov 2004
    Location
    Montreal, Canada
    Posts
    1,267
    when you meen getting back to your old NV config, do you meen you have a backup xorg, or you simply change the driver name?

    If the files are diferent, make sure the refresh rate and vertical are set properly
    \"Meditative mind\'s is like a vast ocean... whatever strikes the surface, the bottom stays calm\" - Dalai Lama
    \"Competition ultimatly comes down to one thing... a loser and a winner.\" - Ugo Deschamps

  3. #3
    Just Joined!
    Join Date
    Feb 2005
    Posts
    4

    nv and xorg

    Quote Originally Posted by UgoDeschamps
    when you meen getting back to your old NV config, do you meen you have a backup xorg, or you simply change the driver name?

    If the files are diferent, make sure the refresh rate and vertical are set properly
    I'm just changing the driver name. I have a backup but I'm just editting the main xorg.conf file not restoring from the xorg.backup file. I'm leaving the refresh and vertical the same as the with the nv driver when I use the nvidia. Do you think that could be the prob? I was thinking that the refresh and vertical were monitor specific not vid driver specific, so I haven't changed them. The screen doesn't look like a refresh rate problem though. Basically here's what the screen characteristics are when I try to use the nvidia drivers:

    The windows trail when I move or resize them.
    Text overlaps.
    The screen becomes unreadable after a few windows are opened.
    The screen distorts if I switch to tty1 and then back to X.
    Hope this description helps someone help me hehe
    thanks

  4. #4
    Just Joined!
    Join Date
    Feb 2005
    Posts
    4

    Fixed

    Well, I finally fixed the problem by installing Suse 9.2 and just using it instead. This week I've tried Fedora Core 3, Mandrake 10.1, and Mepis. I used to like Mandrake the best out of any linux distro, but now I think SUSE is the best, at least the newest version is anyway. Here's a few things that need to be addressed on the other distributions.

    Fedora Core 3 - Very nice distro other than the problem with the Nvidia drivers I was having and no out of the NTFS kernel support. The NTFS isn't hard to get working but there was a problem with normal users accessing NTFS partitions. There was also no mp3 support in XMMS but again this is easily fixed by searching the net for the patch.

    Mandrake 10.1 - Another very nice distro. This was the first version of Mandrake since like 7.2 that didn't get my monitor and graphics settings right with auto detect. Feels like its a step backward in a way. Also I couldn't get the Nvidia drivers to work right or get 3d acceleration. I really shouldn't blame this on the distribution because it was from my lack of config file knowledge but this is something SUSE nailed with no skill on my part.

    [b]SimplyMepis[b] - I like where this distro is trying to go. Its very simple to install. It's almost too simple. It seems to be made for a person who's never used a computer. Some of the dialogs and install options seem...well I don't know....uncommon? They just don't conform to the norms. I guess it could be called innovative. The main problem I had with this was my display's refresh rate. I prefer a 1024x768 @ 85hz display. I'm just picky about what my screen looks like during install and firsttime startup. This distro is nice though!

    I'm basically a Windows/DOS expert and linux newbie. I really want to learn everything I can about linux. The average Windows user though just wants to get on the computer and use it. They don't want to learn the in's and out's of linux like shell commands, shell scripts, ./configure, make, make install, fstab editing, cron, vi, etc etc... They just want to get on the computer and use it. I prefer Firefox over any other web browser. I couldn't even get the installer to work in Mandrake. That seemed strange. It worked fine in all the rest but for some reason it didn't like Mandrake. Most computers don't want to spend an hour or so searching the internet trying to find out why their favorite browser won't install in Mandrake.

    Enough with that though. The reason I wrote all that was because it took installing 4 different distributions to get my Nvidia drivers installed. This is after searching and searching the internet (in Windows mostly) trying to find someone saying they had the same trouble as me. I was hoping someone would be able to answer the question or at least point me in the right direction. At this time 67 people have viewed this thread and just one person has said anything. I think Linux should take over the PC market. It'd make things alot better. But we either need distros coming out that everything works in or we need more gurus to answer specific questions. Truth is though, gurus are probably too busy writing code or fixing their own box to worry about typing responses to a newbie like me. I was expecting someone to say "RTFM" or "man xorg" or something like that. Thanks to the one person that tried to help though. I'm going to look over the new xorg.conf in Suse and see what may have made the difference. If I find out I'll post so someone else may be able to work through the problem faster.

  5. #5
    Banned
    Join Date
    Jul 2004
    Posts
    947

  6. #6
    Just Joined!
    Join Date
    Feb 2005
    Posts
    4
    Quote Originally Posted by the_guy_dressed_in_black
    Thanks very much. I'll try that when I install Fedora again.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •