Find the answer to your Linux question:
Results 1 to 6 of 6
Hello everyone! I'm trying to install gDesklets on my Slackware 10 distro. I'm running enlightenment-0.16.7.2 (got it from the linuxpackages.net site) and I wanted to put those nice displays working. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    zzp
    zzp is offline
    Just Joined!
    Join Date
    Jan 2005
    Posts
    6

    gDesklets gnome.ui error


    Hello everyone!

    I'm trying to install gDesklets on my Slackware 10 distro.

    I'm running enlightenment-0.16.7.2 (got it from the linuxpackages.net site) and I wanted to put those nice displays working.

    Basically my problem occurs when I try to start the gdesklets daemon:

    # gdesklets start
    connecting to daemon [### ]Traceback (most recent call last):
    File "/usr/share/gdesklets/gdesklets-daemon", line 13, in ?
    import gnome.ui
    ImportError: No module named gnome.ui
    Cannot establish connection to daemon : timeout


    I went to get the necessary packages to run gDesklets from linuxpackages.net and installed them in the following order:

    pygtk-2.4.1
    pyorbit-2.0.1
    gnome-python-2.6.2
    swig-1.3.21
    gDesklets-0.30


    After a google search on the topic I also installed required gnome packages:

    libgnome-2.6.1.1
    libgtop-2.6.0
    libbonobo-2.6.2
    libbonoboui-2.6.1
    orbit2-2.10.2
    gconf-2.6.2
    gnome-vfs-2.6.1.1
    librsvg-2.6.5


    and also: (extra-gnome)

    python-2.3.4
    libxml2-2.6.9


    I've also tried to install from source but I get stuck with pyorbit compilation.

    I've read some related posts on the matter but none seemed to help me.

    I'm far from being a Linux expert, so can someone give me a hint to solve these problem? Is there some basic step that I'm missing? Thanks!

  2. #2
    Linux Guru
    Join Date
    Mar 2003
    Location
    Wisconsin
    Posts
    1,907
    There is a package called libgnomeui and libgnomeui-devel. You should install those.

    Jeremy
    Registered Linux user #346571
    "All The Dude ever wanted was his rug back" - The Dude

  3. #3
    zzp
    zzp is offline
    Just Joined!
    Join Date
    Jan 2005
    Posts
    6
    Thanks for your reply Jeremy.

    I installed libgnomeui from my Slack CD.

    I'm still trying to install libgnomeui-devel since it doesn't come with the distro. Actually I'm having a bit of a hard time to find the source.

    With libgnomeui only, the problem persists though. Does this smell good to you...?

    I'll let you know the outcome when I have libgnomeui-devel installed.

    Any more hints? Thanks

  4. #4
    Linux Enthusiast
    Join Date
    Dec 2004
    Location
    Rockin' in the USA!!!
    Posts
    603
    I'm not sure, but you may have to be running gnome to run gdesklets

  5. #5
    Linux Engineer
    Join Date
    Jul 2003
    Location
    Farnborough, UK
    Posts
    1,305
    I have them running on slack with fluxbox.

    I also have gnome installed though.
    Lansbury's Lido

    thekiadriver on #linuxforums - fleetingly

  6. #6
    zzp
    zzp is offline
    Just Joined!
    Join Date
    Jan 2005
    Posts
    6
    I'm really having a hard time trying to install gdesklets!

    First of all I couldn't manage to install libgnomeui-devel as jeremy1701 suggested. Only libgnomeui. Still the problem continued.

    So according to Smindinver and Chris H posts, I went for a full installation of the gnome desktop. Installed from my Slack distro all there is from gnome. (libs and so on...)

    But the problem persisted though. Even when I run gnome desktop. It gives exactly the same error as it did with enlightenment.

    # gdesklets start
    connecting to daemon [### ]Traceback (most recent call last):
    File "/usr/share/gdesklets/gdesklets-daemon", line 13, in ?
    import gnome.ui
    ImportError: No module named gnome.ui
    Cannot establish connection to daemon : timeout Confused


    I did a google search on the error above but solutions mentioned didn't help me

    I've also tryed to install the packages mentioned in my first post from source but I run into a lot of errors (specially with pyorbit and gnome-python)

    I'm not running a full installation of my Slackware distro. This means I add libraries and other stuff as needed. I want to keep it minimal as possible. And I don't have a clue if something else is missing... The error messages don't help much.

    At the moment I don't know what else to do. Any more help/tips would be great!

    Thanks!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •