Find the answer to your Linux question:
Results 1 to 8 of 8
I have difficulties getting up X... i have installed a gentoo dist and KDE. When i try to start X now i get follwing errormessages on the screen. Code: xsetroot: ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Engineer
    Join Date
    Apr 2003
    Location
    Sweden
    Posts
    796

    Cant start X using KDE on Gentoo!!


    I have difficulties getting up X... i have installed a gentoo dist and KDE. When i try to start X now i get follwing errormessages on the screen.

    Code:
    xsetroot:  unable to open display 'localhost:0.0'
    xset:  unable to open display "localhost:0.0"
    startkde: Starting up...
    startkde: Running kpersonalizer...
    kwin: cannot connect to X server localhost:0.0
    kpersonalizer: cannot connect to X server localhost:0.0
    - I have maked sure xfs are running..
    - Have tried X -configure and try to start on the new XF96config
    - Have tried to set the DISPLAY variable to :0 and to :0.0

    But no luck...i am not a X expert...have anybody any tip for me??

    Regards
    Regards

    Andutt

  2. #2
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    It almost seems as if the X server isn't started at all. Can you see it starting? What would happen if you started the X server manually, exported DISPLAY=:0 and tried to just run startkde?

  3. #3
    Linux Engineer
    Join Date
    Apr 2003
    Location
    Sweden
    Posts
    796
    How do i manually start the X-server, i have started

    - xfs
    - xdm

    And tried startkde and startx wit no luck. Here is my XFree log for people that can X better then me...I think i have read something here before when people get

    Fatal server error:
    no screens found

    like i get....


    Code:
    XFree86 Version 4.3.0
    Release Date: 27 February 2003
    X Protocol Version 11, Revision 0, Release 6.6
    Build Operating System: Linux 2.4.20-xfs-r2 i686 [ELF] 
    Build Date: 24 June 2003
    	Before reporting problems, check http://www.XFree86.Org/
    	to make sure that you have the latest version.
    Module Loader present
    Markers: (--) probed, (**) from config file, (==) default setting,
             (++) from command line, (!!) notice, (II) informational,
             (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (==) Log file: "/var/log/XFree86.0.log", Time: Fri Jun 27 11:52:01 2003
    (==) Using config file: "/etc/X11/XF86Config"
    (==) ServerLayout "Default Layout"
    (**) |-->Screen "Screen0" (0)
    (**) |   |-->Monitor "Monitor0"
    (**) |   |-->Device "Videocard0"
    (**) |-->Input Device "Mouse0"
    (**) |-->Input Device "Keyboard0"
    (**) Option "XkbRules" "xfree86"
    (**) XKB: rules: "xfree86"
    (**) Option "XkbModel" "pc105"
    (**) XKB: model: "pc105"
    (**) Option "XkbLayout" "se"
    (**) XKB: layout: "se"
    (==) Keyboard: CustomKeycode disabled
    (**) |-->Input Device "DevInputMice"
    (**) FontPath set to "unix/:7100"
    (**) RgbPath set to "/usr/X11R6/lib/X11/rgb"
    (==) ModulePath set to "/usr/X11R6/lib/modules"
    Using vt 7
    (--) using VT number 7
    
    (WW) Open APM failed (/dev/apm_bios) (No such file or directory)
    (II) Module ABI versions:
    	XFree86 ANSI C Emulation: 0.2
    	XFree86 Video Driver: 0.6
    	XFree86 XInput driver : 0.4
    	XFree86 Server Extension : 0.2
    	XFree86 Font Renderer : 0.4
    (II) Loader running on linux
    (II) LoadModule: "bitmap"
    (II) Loading /usr/X11R6/lib/modules/fonts/libbitmap.a
    (II) Module bitmap: vendor="The XFree86 Project"
    	compiled for 4.3.0, module version = 1.0.0
    	Module class: XFree86 Font Renderer
    	ABI class: XFree86 Font Renderer, version 0.4
    (II) Loading font Bitmap
    (II) LoadModule: "pcidata"
    (II) Loading /usr/X11R6/lib/modules/libpcidata.a
    (II) Module pcidata: vendor="The XFree86 Project"
    	compiled for 4.3.0, module version = 1.0.0
    	ABI class: XFree86 Video Driver, version 0.6
    (II) PCI: Probing config type using method 1
    (II) PCI: Config type is 1
    (II) PCI: stages = 0x03, oldVal1 = 0x00000000, mode1Res1 = 0x80000000
    (II) PCI: PCI scan (all values are in hex)
    (II) PCI: 00:00:0: chip 8086,7190 card 0000,0000 rev 03 class 06,00,00 hdr 00
    (II) PCI: 00:01:0: chip 8086,7191 card 0000,0000 rev 03 class 06,04,00 hdr 01
    (II) PCI: 00:04:0: chip 8086,7110 card 0000,0000 rev 02 class 06,01,00 hdr 80
    (II) PCI: 00:04:1: chip 8086,7111 card 0000,0000 rev 01 class 01,01,80 hdr 00
    (II) PCI: 00:04:2: chip 8086,7112 card 0000,0000 rev 01 class 0c,03,00 hdr 00
    (II) PCI: 00:04:3: chip 8086,7113 card 0000,0000 rev 02 class 06,80,00 hdr 00
    (II) PCI: 00:06:0: chip 1013,6003 card 1013,4280 rev 01 class 04,01,00 hdr 00
    (II) PCI: 00:0b:0: chip 10b7,9055 card 10b7,9055 rev 30 class 02,00,00 hdr 00
    (II) PCI: 01:00:0: chip 102b,0521 card 102b,ff00 rev 03 class 03,00,00 hdr 00
    (II) PCI: End of PCI scan
    (II) Host-to-PCI bridge:
    (II) Bus 0: bridge is at (0:0:0), (0,0,1), BCTRL: 0x0008 (VGA_EN is set)
    (II) Bus 0 I/O range:
    	[0] -1	0	0x00000000 - 0x0000ffff (0x10000) IX[B]
    (II) Bus 0 non-prefetchable memory range:
    	[0] -1	0	0x00000000 - 0xffffffff (0x0) MX[B]
    (II) Bus 0 prefetchable memory range:
    	[0] -1	0	0x00000000 - 0xffffffff (0x0) MX[B]
    (II) PCI-to-PCI bridge:
    (II) Bus 1: bridge is at (0:1:0), (0,1,1), BCTRL: 0x008c (VGA_EN is set)
    (II) Bus 1 non-prefetchable memory range:
    	[0] -1	0	0xf4200000 - 0xf4ffffff (0xe00000) MX[B]
    (II) Bus 1 prefetchable memory range:
    	[0] -1	0	0xf5000000 - 0xf5ffffff (0x1000000) MX[B]
    (II) PCI-to-ISA bridge:
    (II) Bus -1: bridge is at (0:4:0), (0,-1,-1), BCTRL: 0x0008 (VGA_EN is set)
    (--) PCI:*(1:0:0) Matrox Graphics, Inc. MGA G200 AGP rev 3, Mem @ 0xf5000000/24, 0xf4200000/14, 0xf4800000/23
    (II) Addressable bus resource ranges are
    	[0] -1	0	0x00000000 - 0xffffffff (0x0) MX[B]
    	[1] -1	0	0x00000000 - 0x0000ffff (0x10000) IX[B]
    (II) OS-reported resource ranges:
    	[0] -1	0	0xffe00000 - 0xffffffff (0x200000) MX[B](B)
    	[1] -1	0	0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
    	[2] -1	0	0x000f0000 - 0x000fffff (0x10000) MX[B]
    	[3] -1	0	0x000c0000 - 0x000effff (0x30000) MX[B]
    	[4] -1	0	0x00000000 - 0x0009ffff (0xa0000) MX[B]
    	[5] -1	0	0x0000ffff - 0x0000ffff (0x1) IX[B]
    	[6] -1	0	0x00000000 - 0x000000ff (0x100) IX[B]
    (II) PCI Memory resource overlap reduced 0xf8000000 from 0xfbffffff to 0xf7ffffff
    (II) Active PCI resource ranges:
    	[0] -1	0	0xf4101000 - 0xf410107f (0x80) MX[B]
    	[1] -1	0	0xf4000000 - 0xf40fffff (0x100000) MX[B]
    	[2] -1	0	0xf4100000 - 0xf4100fff (0x1000) MX[B]
    	[3] -1	0	0xf8000000 - 0xf7ffffff (0x0) MX[B]O
    	[4] -1	0	0xf4800000 - 0xf4ffffff (0x800000) MX[B](B)
    	[5] -1	0	0xf4200000 - 0xf4203fff (0x4000) MX[B](B)
    	[6] -1	0	0xf5000000 - 0xf5ffffff (0x1000000) MX[B](B)
    	[7] -1	0	0x00001080 - 0x000010ff (0x80) IX[B]
    	[8] -1	0	0x00001000 - 0x0000101f (0x20) IX[B]
    	[9] -1	0	0x00001020 - 0x0000102f (0x10) IX[B]
    (II) Active PCI resource ranges after removing overlaps:
    	[0] -1	0	0xf4101000 - 0xf410107f (0x80) MX[B]
    	[1] -1	0	0xf4000000 - 0xf40fffff (0x100000) MX[B]
    	[2] -1	0	0xf4100000 - 0xf4100fff (0x1000) MX[B]
    	[3] -1	0	0xf8000000 - 0xf7ffffff (0x0) MX[B]O
    	[4] -1	0	0xf4800000 - 0xf4ffffff (0x800000) MX[B](B)
    	[5] -1	0	0xf4200000 - 0xf4203fff (0x4000) MX[B](B)
    	[6] -1	0	0xf5000000 - 0xf5ffffff (0x1000000) MX[B](B)
    	[7] -1	0	0x00001080 - 0x000010ff (0x80) IX[B]
    	[8] -1	0	0x00001000 - 0x0000101f (0x20) IX[B]
    	[9] -1	0	0x00001020 - 0x0000102f (0x10) IX[B]
    (II) OS-reported resource ranges after removing overlaps with PCI:
    	[0] -1	0	0xffe00000 - 0xffffffff (0x200000) MX[B](B)
    	[1] -1	0	0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
    	[2] -1	0	0x000f0000 - 0x000fffff (0x10000) MX[B]
    	[3] -1	0	0x000c0000 - 0x000effff (0x30000) MX[B]
    	[4] -1	0	0x00000000 - 0x0009ffff (0xa0000) MX[B]
    	[5] -1	0	0x0000ffff - 0x0000ffff (0x1) IX[B]
    	[6] -1	0	0x00000000 - 0x000000ff (0x100) IX[B]
    (II) All system resource ranges:
    	[0] -1	0	0xffe00000 - 0xffffffff (0x200000) MX[B](B)
    	[1] -1	0	0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
    	[2] -1	0	0x000f0000 - 0x000fffff (0x10000) MX[B]
    	[3] -1	0	0x000c0000 - 0x000effff (0x30000) MX[B]
    	[4] -1	0	0x00000000 - 0x0009ffff (0xa0000) MX[B]
    	[5] -1	0	0xf4101000 - 0xf410107f (0x80) MX[B]
    	[6] -1	0	0xf4000000 - 0xf40fffff (0x100000) MX[B]
    	[7] -1	0	0xf4100000 - 0xf4100fff (0x1000) MX[B]
    	[8] -1	0	0xf8000000 - 0xf7ffffff (0x0) MX[B]O
    	[9] -1	0	0xf4800000 - 0xf4ffffff (0x800000) MX[B](B)
    	[10] -1	0	0xf4200000 - 0xf4203fff (0x4000) MX[B](B)
    	[11] -1	0	0xf5000000 - 0xf5ffffff (0x1000000) MX[B](B)
    	[12] -1	0	0x0000ffff - 0x0000ffff (0x1) IX[B]
    	[13] -1	0	0x00000000 - 0x000000ff (0x100) IX[B]
    	[14] -1	0	0x00001080 - 0x000010ff (0x80) IX[B]
    	[15] -1	0	0x00001000 - 0x0000101f (0x20) IX[B]
    	[16] -1	0	0x00001020 - 0x0000102f (0x10) IX[B]
    (II) LoadModule: "dbe"
    (II) Loading /usr/X11R6/lib/modules/extensions/libdbe.a
    (II) Module dbe: vendor="The XFree86 Project"
    	compiled for 4.3.0, module version = 1.0.0
    	Module class: XFree86 Server Extension
    	ABI class: XFree86 Server Extension, version 0.2
    (II) Loading extension DOUBLE-BUFFER
    (II) LoadModule: "extmod"
    (II) Loading /usr/X11R6/lib/modules/extensions/libextmod.a
    (II) Module extmod: vendor="The XFree86 Project"
    	compiled for 4.3.0, module version = 1.0.0
    	Module class: XFree86 Server Extension
    	ABI class: XFree86 Server Extension, version 0.2
    (II) Loading extension SHAPE
    (II) Loading extension MIT-SUNDRY-NONSTANDARD
    (II) Loading extension BIG-REQUESTS
    (II) Loading extension SYNC
    (II) Loading extension MIT-SCREEN-SAVER
    (II) Loading extension XC-MISC
    (II) Loading extension XFree86-VidModeExtension
    (II) Loading extension XFree86-Misc
    (II) Loading extension XFree86-DGA
    (II) Loading extension DPMS
    (II) Loading extension FontCache
    (II) Loading extension TOG-CUP
    (II) Loading extension Extended-Visual-Information
    (II) Loading extension XVideo
    (II) Loading extension XVideo-MotionCompensation
    (II) Loading extension X-Resource
    (II) LoadModule: "fbdevhw"
    (II) Loading /usr/X11R6/lib/modules/linux/libfbdevhw.a
    (II) Module fbdevhw: vendor="The XFree86 Project"
    	compiled for 4.3.0, module version = 0.0.2
    	ABI class: XFree86 Video Driver, version 0.6
    (II) LoadModule: "glx"
    (II) Loading /usr/X11R6/lib/modules/extensions/libglx.a
    (II) Module glx: vendor="The XFree86 Project"
    	compiled for 4.3.0, module version = 1.0.0
    	ABI class: XFree86 Server Extension, version 0.2
    (II) Loading sub module "GLcore"
    (II) LoadModule: "GLcore"
    (II) Loading /usr/X11R6/lib/modules/extensions/libGLcore.a
    (II) Module GLcore: vendor="The XFree86 Project"
    	compiled for 4.3.0, module version = 1.0.0
    	ABI class: XFree86 Server Extension, version 0.2
    (II) Loading extension GLX
    (II) LoadModule: "record"
    (II) Loading /usr/X11R6/lib/modules/extensions/librecord.a
    (II) Module record: vendor="The XFree86 Project"
    	compiled for 4.3.0, module version = 1.13.0
    	Module class: XFree86 Server Extension
    	ABI class: XFree86 Server Extension, version 0.2
    (II) Loading extension RECORD
    (II) LoadModule: "freetype"
    (II) Loading /usr/X11R6/lib/modules/fonts/libfreetype.a
    (II) Module freetype: vendor="The XFree86 Project"
    	compiled for 4.3.0, module version = 2.0.2
    	Module class: XFree86 Font Renderer
    	ABI class: XFree86 Font Renderer, version 0.4
    (II) Loading font FreeType
    (II) LoadModule: "type1"
    (II) Loading /usr/X11R6/lib/modules/fonts/libtype1.a
    (II) Module type1: vendor="The XFree86 Project"
    	compiled for 4.3.0, module version = 1.0.2
    	Module class: XFree86 Font Renderer
    	ABI class: XFree86 Font Renderer, version 0.4
    (II) Loading font Type1
    (II) Loading font CID
    (II) LoadModule: "dri"
    (II) Loading /usr/X11R6/lib/modules/extensions/libdri.a
    (II) Module dri: vendor="The XFree86 Project"
    	compiled for 4.3.0, module version = 1.0.0
    	ABI class: XFree86 Server Extension, version 0.2
    (II) Loading sub module "drm"
    (II) LoadModule: "drm"
    (II) Loading /usr/X11R6/lib/modules/linux/libdrm.a
    (II) Module drm: vendor="The XFree86 Project"
    	compiled for 4.3.0, module version = 1.0.0
    	ABI class: XFree86 Server Extension, version 0.2
    (II) Loading extension XFree86-DRI
    (II) LoadModule: "i810"
    (II) Loading /usr/X11R6/lib/modules/drivers/i810_drv.o
    (II) Module i810: vendor="The XFree86 Project"
    	compiled for 4.3.0, module version = 1.3.0
    	Module class: XFree86 Video Driver
    	ABI class: XFree86 Video Driver, version 0.6
    (II) LoadModule: "mouse"
    (II) Loading /usr/X11R6/lib/modules/input/mouse_drv.o
    (II) Module mouse: vendor="The XFree86 Project"
    	compiled for 4.3.0, module version = 1.0.0
    	Module class: XFree86 XInput Driver
    	ABI class: XFree86 XInput driver, version 0.4
    (II) I810: Driver for Intel Integrated Graphics Chipsets: i810, i810-dc100,
    	i810e, i815, i830M, 845G, 852GM/855GM, 865G
    (II) Primary Device is: PCI 01:00:0
    (EE) No devices detected.
    
    Fatal server error:
    no screens found
    Regards

    Andutt

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    It won't recognize your video card. Does this work, and what happens?
    Code:
    XFree86 -configure
    XFree86 -xf86config XF86Config.new
    Otherwise, does the xf86cfg program work for you?

  6. #5
    Linux Engineer
    Join Date
    Apr 2003
    Location
    Sweden
    Posts
    796
    XFree86 -confiure and booted on the new config worked...Then my mousecursor comes up graphicly and some strang terminal windows, but not real KDE....do i have do change anything to start real KDE later???

    I moved this new configfile under /etc/X11..

    Regards
    Regards

    Andutt

  7. #6
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Maybe your default session isn't KDE. What happens if you run "startx startkde" from text mode?

  8. #7
    Linux Engineer
    Join Date
    Jan 2003
    Location
    Lebanon, pa
    Posts
    994
    Atr the bottom of /etc/rc.conf, make sure its se to kde.

  9. #8
    Linux Engineer
    Join Date
    Apr 2003
    Location
    Sweden
    Posts
    796
    That was it!

    The last line in /etc/rc.conf said XSESSION="xdm" i changed that to kde-3.1.2 and then i found a utility in gentoo called xf86config that was a interactive X-setup..worked OK. So now when i started x with startx it worked fine!!!

    Thankx a lot guys for your help! case closed over and out

    Regards
    Regards

    Andutt

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •