Find the answer to your Linux question:
Results 1 to 4 of 4
Hmmmmm. So I booted slack today into XFCE as usual but now I have gnome desktop icons!! What the hell?? I did change the terminal in the XFCE panel from ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2005
    Posts
    68

    Gnome desktop icons in XFCE?? WTF??!?!?


    Hmmmmm.

    So I booted slack today into XFCE as usual but now I have gnome desktop icons!!




    What the hell??

    I did change the terminal in the XFCE panel from xterm 4 to gnome-terminal but cant see why this would make any difference.

    Thanks much.

    <edit> I cant change my wallpapers either!?!

  2. #2
    Linux Engineer
    Join Date
    Nov 2004
    Location
    home
    Posts
    796
    It would appear you are running nautilus, it likes to steal the desktop. I don't know why gnome-terminal would start it up, but killing it should get rid of it. Perhaps you started up nautilus at one point or another? Passing it the --nodesktop (or something like that) option will keep it from taking the desktop.

  3. #3
    Just Joined!
    Join Date
    Jan 2005
    Posts
    68
    Ok thanks much.

    Would I just add "-nodesktop" to the command for nautilus do the trick?

    Thanks again

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Engineer
    Join Date
    Nov 2004
    Location
    home
    Posts
    796
    You'll have to check nautilus --help for the exact parameter to use. And this only works with nautilus, won't do a thing with gnome terminal. But it is nautilus that's stealing your desktop, so whatever is calling it needs to use this option.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •