Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
I recently updated to X 4.4.0, and the installation went smoothly. However, when I rebooted into initlevel 5, I am now unable to view the X Server. When it starts ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Guru Cabhan's Avatar
    Join Date
    Jan 2005
    Location
    Seattle, WA, USA
    Posts
    3,252

    X Won't Load!


    I recently updated to X 4.4.0, and the installation went smoothly. However, when I rebooted into initlevel 5, I am now unable to view the X Server. When it starts up, all I get is a grey screen that flickers on and off until it decides to stop trying (something about having failed the past 90 seconds). When I run dmesg, I get the following message:

    Spurious ACK on isa0060/serio0. Some program, like XFree86, might be trying to access hardware directly.

    I am typing this in Lynx, so I'm kinda desperate. If anyone can help me out, please let me know. I recently updated to Perl 5.8.6, so harddrake was having some problems, but I thought I had fixed all the pointers and files that the other programs needed to run successfully.

    Thanks in advance. I'll switch to Windows now so I can see responses.


    -Alex

  2. #2
    Just Joined!
    Join Date
    Feb 2005
    Posts
    40
    sounds like your x configuration is jacked up. Reconfigure x.
    --Jeff--

  3. #3
    Linux Guru Cabhan's Avatar
    Join Date
    Jan 2005
    Location
    Seattle, WA, USA
    Posts
    3,252
    That was my guess, but I'm not exactly an XFree86 Config expert =(.

    The thing is though, that when I run
    Code:
    $ startx
    I get three terminals in an X sort of environment. But it's definitely not GNOME, which leads me to believe that GNOME is a bit farked up as well.

  4. #4
    Linux Enthusiast
    Join Date
    Jun 2004
    Location
    Windsor, CO
    Posts
    656
    So X _does_ load, it's just Gnome that won't load?
    Try running gdm, and see if you can load Gnome from that.
    Emotions are the key to the soul.
    Registered Linux User #375050

  5. #5
    Linux Guru Cabhan's Avatar
    Join Date
    Jan 2005
    Location
    Seattle, WA, USA
    Posts
    3,252
    Alrighty. I've run some more things, and here's what I can tell you:

    Code:
    $ X
    This doesn't end up doing anything. It takes me to a grey screen with a black X for a cursor. Nothing loads.

    Code:
    $ startx
    This will first take me to the grey screen I mentioned before, then take me to a semi-X environment. I say semi-X because all that appears are terminals. When I tried running firefox, it wouldn't load (it got a segmentation fault), but when it wouldn't load, the Quality Feedback Agent did. So the X Environment itself IS working.

    Code:
    # gdm
    This brought me back to the original error, with the constant flashing and the original error (which I can't repost since I'm running inittab 3 and don't want to fark up my system again, but it's in my first post).

    Thus, I am led to believe that this is more of a GNOME error than an X one. However, if this is the case, what am I supposed to do?

    If it matters, I get an error when I start my computer with running harddrake. It tells me that it gets a segmentation fault. This didn't stop me from running the old X/GNOME combo, but I find it odd that my dmesg error message relates to hardware accessibility, and my harddrake doesn't work...

    Thanks in advance, again.

  6. #6
    Linux Engineer
    Join Date
    Aug 2004
    Posts
    826
    Why not just login as regular user then
    Code:
    $ echo "exec gnome-session" > .xinitrc
    $ startx
    or would that not work on Mandrake?

  7. #7
    Linux Guru Cabhan's Avatar
    Join Date
    Jan 2005
    Location
    Seattle, WA, USA
    Posts
    3,252
    Sorry to double-post, but I just noticed this message, so I wanted to post it. This is the printout on my tty2 screen when I run startx:

    _XSERVTransSocketOpenCOTSServr: Unable to open socket for inet6
    _XSERVTransOpen: transport open failed for inet6/localhost:0
    _XSERVTransMakeAllCOTSServerListeners: failed to open listener for inet6

    XFree86 Version 4.4.0
    Release Date: 29 February 2004
    X Protocol Version 11, Revision 0, Release 6.6
    Build Operating System: Linux 2.4.18-24 i686 [ELF]
    Current Operating System: Linux localhost 2.6.10 #7 Thu Feb 3 15:21:20 EST 2005 i686

    Build Date: 27 February 2004
    Changelog Date: 29 February 2004
    Before reporting problems, check http://www.XFree86.Org/ to make sure that you have the latest version.
    Module Loader present
    Markers: (--) probed, (**) from config file, (==) default setting, (++) from command line, (!!) notice, (II) informational, (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (==) Log file: "/var/log/XFree86.0.log", Time: Sun Feb 27 22:36:01 2005
    (==) Using config file: "/etc/X11/XF86.config"
    Warning: Cannot convert string "" to type XftFont
    Hope that helps at all...

    EDIT:

    sether, I love you.

    When I did that, I got the GNOME pop-up thing (which is progress), but it then crashed and gave me the following message:

    SESSION_MANAGER=local/localhost:/tmp/.ICE-unix/5062
    No fonts found; this probably means that the fontconfig library is not correctly configured. You made need to edit the fonts.conf configuration file. More information about fontconfig can be found in the fontconfig(3) manual page and on http://fontconfig.org

    I'll take a look at that. Thanks.

  8. #8
    Linux Engineer
    Join Date
    Aug 2004
    Posts
    826
    When you startx, it's loading twm instead of Gnome because you never specified to load Gnome. Did you try to do what I said in the post before? It should work but I don't know about the whole gdm thing - I'm not really familiar with graphical login managers.

  9. #9
    Linux Guru Cabhan's Avatar
    Join Date
    Jan 2005
    Location
    Seattle, WA, USA
    Posts
    3,252
    Yeah, I did. Check the edit to my last post. That was major progress =).

    Unfortunately, I checked out "man fontconfig", and I officially have no idea what to do from here. Since Lynx is kinda annoying for the purposes of web browsing, I'm gonna hop back into Windows for a sec to check out that URL.

    Thanks again.


    EDIT:

    Okay, after reading the fontsconf man pages, I still have no idea what the hell to do with my system...

    Can anyone spare a guess?

  10. #10
    Linux Engineer
    Join Date
    Oct 2004
    Location
    Vancouver
    Posts
    1,366
    well since I gather that the problem is that gnome is not your default xwmanager, could you just try

    Code:
    xwmconfig
    this should allow to simply check gnome as your default, then startx should take you right into it, no need for a graphiclal manager
    Operating System: GNU Emacs

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •