hello,
i am attempting to use the X Window System Version 6.8.0 with Gentoo linux using the 2.4.28-gentoo-r7 kernel
the computer is a
Dell precision 610 (http://support.jp.dell.com/docs/systems/dvol/specs.htm) with the Pentium III Xeon
Diamond FireGL1 (http://support.dell.com/support/edoc...p/En/specs.htm)
Intel I440gx chipset
and finally the monitor is a Mag Innovision (http://www.maginnovision.com/Legacy/Products/786PF.asp)

now, my problem is that only generic VGA works... even tho the card seems to be based on VESA standards
also, the specs for the FireGL say it has 24 bit depth, but i have to use 8
this, however is less the issue, as my real problem with any of this is that it only gives me 320x200 res... regardless of the listing in the xorg.conf file

from the Xorg.0.log file:
(==) VGA(0): Virtual size is 320x200 (pitch 320)
(**) VGA(0): Built-in mode "Generic 320x200 default mode": 12.6 MHz (scaled from 25.2 MHz), 31.5 kHz, 70.2 Hz (VScan)
(II) VGA(0): Modeline "Generic 320x200 default mode" 12.59 320 336 384 400 200 206 207 224 vscan 2 -hsync +vsync
(==) VGA(0): DPI set to (75, 75)

i have tried the Diamond FireGL 1000 driver that comes with the xorg-x11 emerge, but it doesn't find the screen... i've also tried the generic VESA drivers and a few other "random" drivers...
i've been told that since Radeon bought Diamond, that one of the radeon drivers may work... this is what i plan on trying next, but my faith in this is well... i'm writing you aren't i!

i've gone ahead and attached both the xorg.conf file and the log file to this email as txt files
please let me know if you need any further information

thank you!