Find the answer to your Linux question:
Results 1 to 10 of 10
I want to use X-win32 to connect to my machine. Does anybody know how to set up a machine to except this....
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux User
    Join Date
    Apr 2003
    Location
    TEXAS
    Posts
    314

    getting x-win32 to work with a slack ware machine


    I want to use X-win32 to connect to my machine.

    Does anybody know how to set up a machine to except this.
    The computer made me do it!! Slackware and SUSE too Gig\'em WHOOOOP!!
    \"God put me on this earth to accomplish a certain amount of tasks, At the rate I\'m going I will never die.\" (I don\'t know)

  2. #2
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Have X-Win32 running on the Windows machine, then connect with putty to your Linux machine, using the SSH protocol and having X11 forwarding turned on. Then just launch any X program (including something like startkde or gnome-session), and they will connect to your X-Win32 server through the SSH channel.

  3. #3
    Linux User
    Join Date
    Apr 2003
    Location
    TEXAS
    Posts
    314
    I get an error saying that it cant init the X-session.

    And when i try to set the DISPLAY to the IP that im at it wont let connect.
    The computer made me do it!! Slackware and SUSE too Gig\'em WHOOOOP!!
    \"God put me on this earth to accomplish a certain amount of tasks, At the rate I\'m going I will never die.\" (I don\'t know)

  4. #4
    Linux Engineer
    Join Date
    Apr 2003
    Location
    Sweden
    Posts
    796
    Have you enabled X11 forwarding in putty??
    Regards

    Andutt

  5. #5
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Quote Originally Posted by bignester
    I get an error saying that it cant init the X-session.
    When you do what?

    And you shouldn't set the DISPLAY var to your IP. It much less secure, much more troublesome and much more error-prone than using SSH to forward the connections.

  6. #6
    Linux User
    Join Date
    Apr 2003
    Location
    TEXAS
    Posts
    314
    ok here is what im doing

    I launch X-win32 hen i go to putty and turn on x forwarding it has its setting to localhost:0

    I log into my machine and when i try to open a xterminal it gived me an error

    Cant open display
    The computer made me do it!! Slackware and SUSE too Gig\'em WHOOOOP!!
    \"God put me on this earth to accomplish a certain amount of tasks, At the rate I\'m going I will never die.\" (I don\'t know)

  7. #7
    Linux User
    Join Date
    Apr 2003
    Location
    TEXAS
    Posts
    314
    I fixed it I had to add my computer to the xhost list in the x-config in x-win32

    But I Still have to export my display to the ip address of the box that im on.

    Is there another way where i could skip the export step.
    The computer made me do it!! Slackware and SUSE too Gig\'em WHOOOOP!!
    \"God put me on this earth to accomplish a certain amount of tasks, At the rate I\'m going I will never die.\" (I don\'t know)

  8. #8
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    It might be that the SSH server has X11 forwarding disabled. When you have just connected, check "echo $DISPLAY", and see if it returns :10. If it doesn't return anything, then your SSH server has X11 forwarding disabled.
    Is the server yours or are you connecting to someone else's system?

  9. #9
    Linux User
    Join Date
    Apr 2003
    Location
    TEXAS
    Posts
    314
    Its my server.
    The computer made me do it!! Slackware and SUSE too Gig\'em WHOOOOP!!
    \"God put me on this earth to accomplish a certain amount of tasks, At the rate I\'m going I will never die.\" (I don\'t know)

  10. #10
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Did you check what "echo $DISPLAY" gives you?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •