Find the answer to your Linux question:
Results 1 to 5 of 5
I tried to update my Suse 9.1 to 9.2 using YaST and after I rebooted I cant get into KDE . I get an error when i try startx. Code: ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! wraith's Avatar
    Join Date
    Apr 2005
    Location
    Sault Ste. Marie, Canada
    Posts
    54

    X wont start: Failed to initialize core devices.


    I tried to update my Suse 9.1 to 9.2 using YaST and after I rebooted I cant get into KDE . I get an error when i try startx.

    Code:
    (==) Using config file: "/etc/X11/xorg.conf"
    (EE) Failed to load module "speedo" (module does not exist, 0)
    (EE) Failed to load module "Keyboard" (module does not exist, 0)
    (WW) NV(0): Failes to set up write-combing range (0xd8000000, 0x4000000)
    (EE) No Input driver matching 'Keyboard'
    No core keyboard
    
    Fatal server error:
    Failed to initialize core devices
    
    check log file at "/var/log/Xorg.0.log"
    
    XIO: fatal IO error 104 (Connection reset by peer) on X server "0:0"
    after 0 requests (0 known processed) with 0 events remaning
    im lost!.. any ideas

    EDIT -- Nevermind.. Worked around it..

  2. #2
    Linux Newbie
    Join Date
    Mar 2005
    Location
    California!
    Posts
    159
    mind telling us how you fixed it? i had a similar thing happen to me in fedora and had to reinstall because im a n00b
    Registered Linux User # 392752

    \"pr0n\": An anagram of \"porn,\" possibly indicating the use of pornography.

  3. #3
    Linux Enthusiast puntmuts's Avatar
    Join Date
    Dec 2004
    Location
    Republic Banana
    Posts
    562
    In xorg.conf:
    Code:
    Change 
    Section "InputDevice"
            Identifier  "Keyboard1"
            Driver      "keyboard"
    To
    Section "InputDevice"
            Identifier  "Keyboard1"
            Driver      "kbd"
    This changed in Xorg version 6.8.1 or 6.8.2.
    I\'m so tired .....
    #200472

  4. #4
    Just Joined!
    Join Date
    May 2006
    Posts
    4

    Module not found

    The following link contains my Xorg.0.log.

    I ran some updates on my Ubuntu and now X won't start. If kbd and mouse modules have been replaced, what have they been replaced with. How do I find out that.

    http://vlsi.colorado.edu/~sohail/Xorg.0.txt

    Thanks

  5. #5
    Just Joined!
    Join Date
    May 2006
    Posts
    4
    Quote Originally Posted by thirdmusketeer
    The following link contains my Xorg.0.log.

    I ran some updates on my Ubuntu and now X won't start. If kbd and mouse modules have been replaced, what have they been replaced with. How do I find out that.

    http://vlsi.colorado.edu/~sohail/Xorg.0.txt

    Thanks
    Has kbd changed to something new now??

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •