OK, finally figured it out. So for the sake of anyone else who runs across this problem here's the solution. The screen on my laptop for some reason returns an EDID that says it doesn't support 1600 horizontal resolution, even though it does.

I had to add the following to my modules.conf file:

options nvidia NVreg_SoftEDIDs=0 NVreg_Mobile=2

and then the following lines to my "Device" section in XF86Config:

Option "NoBandWidthTest"
Option "IgnoreEDID"

And now I have 1600x1200 resolution running happily!

Miscreant