Find the answer to your Linux question:
Results 1 to 10 of 10
I try to log in as my regular user and it gives me the following message: your session lasted less than 10 seconds. If you have not logged out yourself, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux User
    Join Date
    Jun 2003
    Location
    Huntington Beach, CA
    Posts
    390

    Can only log into Gnome as root user...


    I try to log in as my regular user and it gives me the following message: your session lasted less than 10 seconds. If you have not logged out yourself, this could mean there is some installation problems or that you may be out of disk space. Try logging in with one of the faila=safe sessions to see if you can fix this problem. Then when I clicked to see the error it gave me this:
    /etc/X11/gdm/PreSession//Default: Registering your session with wtmp and utmp
    /etc/X11/gdm/PreSession//Default: running: sessreg -a -w /var/log/utmp -u /var/run/utemp * "/var/lib/gdm/:0.X servers " -h "" -1:0 tyler

    I think it's telling me that it's not reading the /home directory properly but I'm not sure. I don't knnow if this has anything to do with it but earlier today I ended up copying my entire root directory onto a backup partition, deleting the current root and swap partitions so I could make the root partition larger and copied everything back over. Originally I had a 2.5gb root parition, the swap and then a 20 gb home partition. The root ran out of room so I decided just to have root and home on the same partition and made it 30gb. That's all, thanks in advance for any ideas...

  2. #2
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    When you copied everything over, did you preserve all file metadata (perms etc.) correctly?

  3. #3
    Linux User
    Join Date
    Jun 2003
    Location
    Huntington Beach, CA
    Posts
    390
    You're right, I didn't. How should I have copied them over then, cp -Rp?
    Code:
    drwxr-xr-x    2 root     root         4096 Aug  2 13:42 bin
    drwxr-xr-x    3 root     root         4096 Aug  2 13:43 boot
    drwxr-xr-x    1 root     root            0 Jan  1  1970 dev
    drwxr-xr-x   49 root     root         4096 Aug  3 13:29 etc
    drwxrwxrwx    4 root     users         4096 Aug  2 14:20 home
    drwxr-xr-x    7 root     root         4096 Aug  2 13:43 lib
    drwx------    2 root     root        16384 Aug  2 13:40 lost+found
    drwxr-xr-x    6 root     root         4096 Aug  2 13:43 mnt
    drwxr-xr-x    3 root     root         4096 Aug  2 13:44 opt
    dr-xr-xr-x   64 root     root            0 Aug  3 13:10 proc
    drwx------   17 root     root         4096 Aug  3 13:11 root
    drwxr-xr-x    2 root     root         4096 Aug  2 13:44 sbin
    drwxr-xr-t    8 root     root         4096 Aug  3 13:11 tmp
    drwxr-xr-x   14 root     root         4096 Aug  2 14:24 usr
    drwxr-xr-x   12 root     root         4096 Aug  2 13:56 var
    This is what it is now. I've tried everything, setting the chmod to 0777 on /home and /home/tyler. Since setting the chmod now it's giving me a different error saying GDM could not write to your authorization file. This could mean you are out of disk space or your home directory could not be opened for writing. Definetly not out of disk space and I have read/write access to all users and groups so I don't know what's going on.

  4. #4
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    It does seem rather mysterious. I don't really want to go to these extremes, since I don't know how good you are with programming, but could you try stracing the session processes?

  5. #5
    Linux User
    Join Date
    Jun 2003
    Location
    Huntington Beach, CA
    Posts
    390
    I emerged strace, how do I use it to do what you're asking? Just a thought would this have anything to do with the way the user is made? useradd your_user -m -G users,wheel,audio -s /bin/bash is what the Gentoo docs said to do and that's what I did.

  6. #6
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Well, I would check the PID of the gdm (you're using gdm, right?) process, and then run this:
    Code:
    strace -o gnome -ff -p <gdm pid>
    Then it will rather slow and it will create several pretty large files that will contain all the syscalls that the processes use. It allows one to see which one it is that fails, provided that one can understand them.

  7. #7
    Linux User
    Join Date
    Jun 2003
    Location
    Huntington Beach, CA
    Posts
    390
    There were two gdms, both gave the same error:
    Code:
    -bash&#58; syntax error near unexpected token `951'
    -bash&#58; syntax error near unexpected token `949'

  8. #8
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    What I meant was for you to replace <gdm pid> with the PID, like strace -o gnome -ff -p 949.

  9. #9
    Linux User
    Join Date
    Jun 2003
    Location
    Huntington Beach, CA
    Posts
    390
    Code:
    Process 951 attached - interrupt to quit
    trace&#58; ptrace&#40;PTRACE_SYSCALL, ...&#41;&#58; Operation not permitted
    detach&#58; ptrace&#40;PTRACE_DETACH, ...&#41;&#58; Operation not permitted
    Process 951 detached

  10. #10
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Yeah, sorry, you must run it as root.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •