Find the answer to your Linux question:
Results 1 to 3 of 3
I have recently moved from Mandrake to Slackware. Personally, i think it is annoyng typing user and passwords since I'm the only user using my desktop. Is there a way ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2005
    Location
    São Paulo / Brazil
    Posts
    14

    Start X automatically without typing user/password


    I have recently moved from Mandrake to Slackware.

    Personally, i think it is annoyng typing user and passwords since I'm the only user using my desktop.

    Is there a way to start X and KDE automatically when I boot Slackware ??

    Sure many people have the same problem ...

  2. #2
    Linux Engineer
    Join Date
    Oct 2004
    Location
    Vancouver
    Posts
    1,366
    make sure you set your xwm to kde with xwmconfig to default to kde

    you must change your init file to a different default runlevel. Slackware uses different settings than most other distros. The setting that you need to look for is in /etc/inittab. CHange the default runlevel to four for slack. I know that this post has been answered numerous times. However, be very careful not booting into the cli. If anything happens to your xserver it might be hard getting into a cli to fix things.
    Operating System: GNU Emacs

  3. #3
    Linux Engineer
    Join Date
    Mar 2005
    Posts
    1,431
    Quote Originally Posted by genesus
    If anything happens to your xserver it might be hard getting into a cli to fix things.
    You can press ctrl+alt+F2 or ctrl+alt+F3 etc, ctrl+alt+F(any number below 7)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •