Find the answer to your Linux question:
Results 1 to 9 of 9
I got this error, when I do glxgears Xlib: extension "GLX" missing on display "localhost:15.0". Error: couldn't get an RGB, Double-buffered visual When I do glxinfo -v Code: name of ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2005
    Posts
    6

    glx extension missing


    I got this error, when I do
    glxgears



    Xlib: extension "GLX" missing on display "localhost:15.0".
    Error: couldn't get an RGB, Double-buffered visual


    When I do
    glxinfo -v

    Code:
    name of display: localhost:15.0
    Xlib:  extension "GLX" missing on display "localhost:15.0".
    Xlib:  extension "GLX" missing on display "localhost:15.0".
    Xlib:  extension "GLX" missing on display "localhost:15.0".
    Error: couldn't find RGB GLX visual
    
    Xlib:  extension "GLX" missing on display "localhost:15.0".
    Xlib:  extension "GLX" missing on display "localhost:15.0".
    Visual ID: 21  depth=8  class=PseudoColor
        bufferSize=0 level=0 renderType=ci doubleBuffer=0 stereo=0
        rgba: redSize=0 greenSize=0 blueSize=0 alphaSize=0
        auxBuffers=0 depthSize=0 stencilSize=0
        accum: redSize=0 greenSize=0 blueSize=0 alphaSize=0
        multiSample=0  multiSampleBuffers=0
        visualCaveat=None
    Xlib:  extension "GLX" missing on display "localhost:15.0".
    Xlib:  extension "GLX" missing on display "localhost:15.0".
    Visual ID: 22  depth=8  class=StaticGray
        bufferSize=0 level=0 renderType=ci doubleBuffer=0 stereo=0
        rgba: redSize=0 greenSize=0 blueSize=0 alphaSize=0
        auxBuffers=0 depthSize=0 stencilSize=0
        accum: redSize=0 greenSize=0 blueSize=0 alphaSize=0
        multiSample=0  multiSampleBuffers=0
        visualCaveat=None
    Xlib:  extension "GLX" missing on display "localhost:15.0".
    Xlib:  extension "GLX" missing on display "localhost:15.0".
    Visual ID: 23  depth=12  class=PseudoColor
        bufferSize=0 level=0 renderType=ci doubleBuffer=0 stereo=0
        rgba: redSize=0 greenSize=0 blueSize=0 alphaSize=0
        auxBuffers=0 depthSize=0 stencilSize=0
        accum: redSize=0 greenSize=0 blueSize=0 alphaSize=0
        multiSample=0  multiSampleBuffers=0
        visualCaveat=None
    Xlib:  extension "GLX" missing on display "localhost:15.0".
    Xlib:  extension "GLX" missing on display "localhost:15.0".
    Visual ID: 24  depth=24  class=TrueColor
        bufferSize=0 level=0 renderType=ci doubleBuffer=0 stereo=0
        rgba: redSize=0 greenSize=0 blueSize=0 alphaSize=0
        auxBuffers=0 depthSize=0 stencilSize=0
        accum: redSize=0 greenSize=0 blueSize=0 alphaSize=0
        multiSample=0  multiSampleBuffers=0
        visualCaveat=None

    I know I know people have been saying I should add "Load glx" in xfconfig-4, but still doesn't work for me. Here is my config

    Code:
    Section "Files"
            FontPath        "unix/:7100"                    # local font server
            # if the local font server has problems, we can fall back on these
            FontPath        "/usr/lib/X11/fonts/misc"
            FontPath        "/usr/lib/X11/fonts/cyrillic"
            FontPath        "/usr/lib/X11/fonts/100dpi/:unscaled"
            FontPath        "/usr/lib/X11/fonts/75dpi/:unscaled"
            FontPath        "/usr/lib/X11/fonts/Type1"
            FontPath        "/usr/lib/X11/fonts/CID"
            FontPath        "/usr/lib/X11/fonts/Speedo"
            FontPath        "/usr/lib/X11/fonts/100dpi"
            FontPath        "/usr/lib/X11/fonts/75dpi"
    EndSection
    
    Section "Module"
            Load    "GLcore"
            Load    "bitmap"
            Load    "dbe"
            Load    "ddc"
            Load    "dri"
            Load    "extmod"
            Load    "freetype"
            Load    "glx"
            Load    "int10"
            Load    "record"
            Load    "speedo"
            Load    "type1"
            Load    "vbe"
            Load    "xtt"
    EndSection
    
    Section "InputDevice"
            Identifier      "Generic Keyboard"
            Driver          "keyboard"
            Option          "CoreKeyboard"
            Option          "XkbRules"      "xfree86"
            Option          "XkbModel"      "pc104"
            Option          "XkbLayout"     "us"
    EndSection
    
    Section "InputDevice"
            Identifier      "Configured Mouse"
            Driver          "mouse"
            Option          "CorePointer"
            Option          "Device"                "/dev/psaux"
            Option          "Protocol"              "PS/2"
            Option          "Emulate3Buttons"       "true"
            Option          "ZAxisMapping"          "4 5"
    EndSection
    Section "InputDevice"
            Identifier      "Generic Mouse"
            Driver          "mouse"
            Option          "SendCoreEvents"        "true"
            Option          "Device"                "/dev/input/mice"
            Option          "Protocol"              "ImPS/2"
            Option          "Emulate3Buttons"       "true"
            Option          "ZAxisMapping"          "4 5"
    EndSection
    
    Section "Device"
            Identifier      "Generic Video Card"
            Driver          "vesa"
    EndSection
    
    Section "Monitor"
            Identifier      "Generic Monitor"
            HorizSync       30-54
            VertRefresh     50-85
            Option          "DPMS"
    EndSection
    
    Section "Screen"
            Identifier      "Default Screen"
            Device          "Generic Video Card"
            Monitor         "Generic Monitor"
            DefaultDepth    24
            SubSection "Display"
                    Depth           1
                    Modes           "800x600" "640x480"
            EndSubSection
            SubSection "Display"
                    Depth           4
                    Modes           "800x600" "640x480"
            EndSubSection
            SubSection "Display"
                    Depth           8
                    Modes           "800x600" "640x480"
            EndSubSection
            SubSection "Display"
                    Depth           15
                    Modes           "800x600" "640x480"
            EndSubSection
            SubSection "Display"
                    Depth           16
                    Modes           "800x600" "640x480"
            EndSubSection
            SubSection "Display"
                    Depth           24
                    Modes           "800x600" "640x480"
            EndSubSection
    EndSection
    
    Section "ServerLayout"
            Identifier      "Default Layout"
            Screen          "Default Screen"
            InputDevice     "Generic Keyboard"
            InputDevice     "Configured Mouse"
            InputDevice     "Generic Mouse"
    EndSection
    
    Section "DRI"
            Mode    0666
    EndSection
    And here is part of my X11 log

    Code:
    XFree86 Version 4.3.0.1 (Debian 4.3.0.dfsg.1-10 20041215174925 fabbione@fabbione.net)
    Release Date: 15 August 2003
    X Protocol Version 11, Revision 0, Release 6.6
    Build Operating System: Linux 2.4.26 i686 [ELF] 
    Build Date: 15 December 2004
    
    This version of XFree86 has been extensively modified by the Debian
    Project, and is not supported by the XFree86 Project, Inc., in any
    way.  Bugs should be reported to the Debian Bug Tracking System; see
    <URL&#58; http&#58;//www.debian.org/Bugs/Reporting >.
    
    We strongly encourage the use of the "reportbug" package and command
    to ensure that bug reports contain as much useful information as
    possible.
    
    Before filing a bug report, you may want to consult the Debian X FAQ&#58;
           XHTML version&#58; file&#58;///usr/share/doc/xfree86-common/FAQ.xhtml
      plain text version&#58; file&#58;///usr/share/doc/xfree86-common/FAQ.gz
    
    Module Loader present
    OS Kernel&#58; Linux version 2.6.8-2-686 &#40;dilinger@toaster.hq.voxel.net&#41; &#40;gcc version 3.3.5 &#40;Debian 1&#58;3.3.5-6&#41;&#41; #1 Mon Jan 24 03&#58;58&#58;38 EST 2005 
    Markers&#58; &#40;--&#41; probed, &#40;**&#41; from config file, &#40;==&#41; default setting,
             &#40;++&#41; from command line, &#40;!!&#41; notice, &#40;II&#41; informational,
             &#40;WW&#41; warning, &#40;EE&#41; error, &#40;NI&#41; not implemented, &#40;??&#41; unknown.
    &#40;==&#41; Log file&#58; "/var/log/XFree86.0.log", Time&#58; Sun Feb 27 22&#58;51&#58;02 2005
    &#40;==&#41; Using config file&#58; "/etc/X11/XF86Config-4"
    &#40;==&#41; ServerLayout "Default Layout"
    &#40;**&#41; |-->Screen "Default Screen" &#40;0&#41;
    &#40;**&#41; |   |-->Monitor "Generic Monitor"
    &#40;**&#41; |   |-->Device "Generic Video Card"
    &#40;**&#41; |-->Input Device "Generic Keyboard"
    &#40;**&#41; Option "XkbRules" "xfree86"
    &#40;**&#41; XKB&#58; rules&#58; "xfree86"
    &#40;**&#41; Option "XkbModel" "pc104"
    &#40;**&#41; XKB&#58; model&#58; "pc104"
    &#40;**&#41; Option "XkbLayout" "us"
    &#40;**&#41; XKB&#58; layout&#58; "us"
    &#40;==&#41; Keyboard&#58; CustomKeycode disabled
    &#40;**&#41; |-->Input Device "Configured Mouse"
    &#40;**&#41; |-->Input Device "Generic Mouse"
    &#40;WW&#41; The directory "/usr/lib/X11/fonts/cyrillic" does not exist.
            Entry deleted from font path.
    &#40;WW&#41; The directory "/usr/lib/X11/fonts/100dpi/" does not exist.
            Entry deleted from font path.
    &#40;WW&#41; The directory "/usr/lib/X11/fonts/75dpi/" does not exist.
            Entry deleted from font path.
    &#40;WW&#41; The directory "/usr/lib/X11/fonts/CID" does not exist.
            Entry deleted from font path.
    &#40;WW&#41; The directory "/usr/lib/X11/fonts/Speedo" does not exist.
            Entry deleted from font path.
    &#40;WW&#41; The directory "/usr/lib/X11/fonts/100dpi" does not exist.
            Entry deleted from font path.
    &#40;WW&#41; The directory "/usr/lib/X11/fonts/75dpi" does not exist.
            Entry deleted from font path.
    &#40;**&#41; FontPath set to "unix/&#58;7100,/usr/lib/X11/fonts/misc,/usr/lib/X11/fonts/Type1"
    &#40;==&#41; RgbPath set to "/usr/X11R6/lib/X11/rgb"
    &#40;==&#41; ModulePath set to "/usr/X11R6/lib/modules"
    &#40;--&#41; using VT number 7
    
    &#40;WW&#41; Open APM failed &#40;/dev/apm_bios&#41; &#40;No such file or directory&#41;
    &#40;II&#41; Module ABI versions&#58;
            XFree86 ANSI C Emulation&#58; 0.2
            XFree86 Video Driver&#58; 0.6
            XFree86 XInput driver &#58; 0.4
            XFree86 Server Extension &#58; 0.2
            XFree86 Font Renderer &#58; 0.4
    &#40;II&#41; Loader running on linux
    &#40;II&#41; LoadModule&#58; "bitmap"
    &#40;II&#41; Loading /usr/X11R6/lib/modules/fonts/libbitmap.a
    &#40;II&#41; Module bitmap&#58; vendor="The XFree86 Project"
            compiled for 4.3.0.1, module version = 1.0.0
            Module class&#58; XFree86 Font Renderer
            ABI class&#58; XFree86 Font Renderer, version 0.4
    &#40;II&#41; Loading font Bitmap
    &#40;II&#41; LoadModule&#58; "pcidata"
    &#40;II&#41; Loading /usr/X11R6/lib/modules/libpcidata.a
    &#40;II&#41; Module pcidata&#58; vendor="The XFree86 Project"
            compiled for 4.3.0.1, module version = 1.0.0
            ABI class&#58; XFree86 Video Driver, version 0.6
    &#40;II&#41; PCI&#58; Probing config type using method 1
    &#40;II&#41; PCI&#58; Config type is 1
    &#40;II&#41; PCI&#58; stages = 0x03, oldVal1 = 0x00000000, mode1Res1 = 0x80000000
    &#40;II&#41; PCI&#58; PCI scan &#40;all values are in hex&#41;
    &#40;II&#41; PCI&#58; 00&#58;00&#58;0&#58; chip 1106,3148 card 1043,807b rev 00 class 06,00,00 hdr 00
    &#40;II&#41; PCI&#58; 00&#58;01&#58;0&#58; chip 1106,b091 card 0000,0000 rev 00 class 06,04,00 hdr 01
    &#40;II&#41; PCI&#58; 00&#58;10&#58;0&#58; chip 1106,3038 card 1043,80a1 rev 80 class 0c,03,00 hdr 80
    &#40;II&#41; PCI&#58; 00&#58;10&#58;1&#58; chip 1106,3038 card 1043,80a1 rev 80 class 0c,03,00 hdr 80
    &#40;II&#41; PCI&#58; 00&#58;10&#58;2&#58; chip 1106,3038 card 1043,80a1 rev 80 class 0c,03,00 hdr 80
    &#40;II&#41; PCI&#58; 00&#58;11&#58;0&#58; chip 1106,3177 card 1043,80a1 rev 00 class 06,01,00 hdr 80
    &#40;II&#41; PCI&#58; 00&#58;11&#58;1&#58; chip 1106,0571 card 1043,80a1 rev 06 class 01,01,8a hdr 00
    &#40;II&#41; PCI&#58; 00&#58;11&#58;5&#58; chip 1106,3059 card 1043,810f rev 50 class 04,01,00 hdr 00
    &#40;II&#41; PCI&#58; 00&#58;12&#58;0&#58; chip 1106,3065 card 1043,80ff rev 74 class 02,00,00 hdr 00
    &#40;II&#41; PCI&#58; 01&#58;00&#58;0&#58; chip 5333,8d04 card 1043,807b rev 00 class 03,00,00 hdr 00
    &#40;II&#41; PCI&#58; End of PCI scan
    &#40;II&#41; Host-to-PCI bridge&#58;
    &#40;II&#41; Bus 0&#58; bridge is at &#40;0&#58;0&#58;0&#41;, &#40;0,0,1&#41;, BCTRL&#58; 0x0008 &#40;VGA_EN is set&#41;
    &#40;II&#41; Bus 0 I/O range&#58;
            &#91;0&#93; -1  0       0x00000000 - 0x0000ffff &#40;0x10000&#41; IX&#91;B&#93;
    &#40;II&#41; Bus 0 non-prefetchable memory range&#58;
            &#91;0&#93; -1  0       0x00000000 - 0xffffffff &#40;0x0&#41; MX&#91;B&#93;
    &#40;II&#41; Bus 0 prefetchable memory range&#58;
            &#91;0&#93; -1  0       0x00000000 - 0xffffffff &#40;0x0&#41; MX&#91;B&#93;
    &#40;II&#41; PCI-to-PCI bridge&#58;
    &#40;II&#41; Bus 1&#58; bridge is at &#40;0&#58;1&#58;0&#41;, &#40;0,1,1&#41;, BCTRL&#58; 0x000c &#40;VGA_EN is set&#41;
    &#40;II&#41; Bus 1 non-prefetchable memory range&#58;
            &#91;0&#93; -1  0       0xff800000 - 0xff9fffff &#40;0x200000&#41; MX&#91;B&#93;
    &#40;II&#41; Bus 1 prefetchable memory range&#58;
            &#91;0&#93; -1  0       0xcff00000 - 0xdfefffff &#40;0x10000000&#41; MX&#91;B&#93;
    &#40;II&#41; PCI-to-ISA bridge&#58;
    &#40;II&#41; Bus -1&#58; bridge is at &#40;0&#58;17&#58;0&#41;, &#40;0,-1,-1&#41;, BCTRL&#58; 0x0008 &#40;VGA_EN is set&#41;
    &#40;--&#41; PCI&#58;*&#40;1&#58;0&#58;0&#41; S3 Inc. VT8375 &#91;ProSavage8 KM266/KL266&#93; rev 0, Mem @ 0xff980000/19, 0xd0000000/27, BIOS @ 0xff970000/16
    &#40;II&#41; Addressable bus resource ranges are
            &#91;0&#93; -1  0       0x00000000 - 0xffffffff &#40;0x0&#41; MX&#91;B&#93;
            &#91;1&#93; -1  0       0x00000000 - 0x0000ffff &#40;0x10000&#41; IX&#91;B&#93;
    &#40;II&#41; OS-reported resource ranges&#58;
            &#91;0&#93; -1  0       0xffe00000 - 0xffffffff &#40;0x200000&#41; MX&#91;B&#93;&#40;B&#41;
            &#91;1&#93; -1  0       0x00100000 - 0x3fffffff &#40;0x3ff00000&#41; MX&#91;B&#93;E&#40;B&#41;
            &#91;2&#93; -1  0       0x000f0000 - 0x000fffff &#40;0x10000&#41; MX&#91;B&#93;
            &#91;3&#93; -1  0       0x000c0000 - 0x000effff &#40;0x30000&#41; MX&#91;B&#93;
            &#91;4&#93; -1  0       0x00000000 - 0x0009ffff &#40;0xa0000&#41; MX&#91;B&#93;
            &#91;5&#93; -1  0       0x0000ffff - 0x0000ffff &#40;0x1&#41; IX&#91;B&#93;
            &#91;6&#93; -1  0       0x00000000 - 0x000000ff &#40;0x100&#41; IX&#91;B&#93;
    &#40;II&#41; PCI Memory resource overlap reduced 0xe0000000 from 0xe3ffffff to 0xdfffffff
    &#40;II&#41; Active PCI resource ranges&#58;
            &#91;0&#93; -1  0       0xffaffc00 - 0xffaffcff &#40;0x100&#41; MX&#91;B&#93;
            &#91;1&#93; -1  0       0xe0000000 - 0xdfffffff &#40;0x0&#41; MX&#91;B&#93;O
            &#91;2&#93; -1  0       0xff970000 - 0xff97ffff &#40;0x10000&#41; MX&#91;B&#93;&#40;B&#41;
            &#91;3&#93; -1  0       0xd0000000 - 0xd7ffffff &#40;0x8000000&#41; MX&#91;B&#93;&#40;B&#41;
            &#91;4&#93; -1  0       0xff980000 - 0xff9fffff &#40;0x80000&#41; MX&#91;B&#93;&#40;B&#41;
            &#91;5&#93; -1  0       0x0000e800 - 0x0000e8ff &#40;0x100&#41; IX&#91;B&#93;
            &#91;6&#93; -1  0       0x0000e400 - 0x0000e4ff &#40;0x100&#41; IX&#91;B&#93;
            &#91;7&#93; -1  0       0x0000fc00 - 0x0000fc0f &#40;0x10&#41; IX&#91;B&#93;
            &#91;8&#93; -1  0       0x0000ec00 - 0x0000ec1f &#40;0x20&#41; IX&#91;B&#93;
            &#91;9&#93; -1  0       0x0000e080 - 0x0000e09f &#40;0x20&#41; IX&#91;B&#93;
            &#91;10&#93; -1 0       0x0000e000 - 0x0000e01f &#40;0x20&#41; IX&#91;B&#93;
    &#40;II&#41; Active PCI resource ranges after removing overlaps&#58;
            &#91;0&#93; -1  0       0xffaffc00 - 0xffaffcff &#40;0x100&#41; MX&#91;B&#93;
            &#91;1&#93; -1  0       0xe0000000 - 0xdfffffff &#40;0x0&#41; MX&#91;B&#93;O
            &#91;2&#93; -1  0       0xff970000 - 0xff97ffff &#40;0x10000&#41; MX&#91;B&#93;&#40;B&#41;
            &#91;3&#93; -1  0       0xd0000000 - 0xd7ffffff &#40;0x8000000&#41; MX&#91;B&#93;&#40;B&#41;
            &#91;4&#93; -1  0       0xff980000 - 0xff9fffff &#40;0x80000&#41; MX&#91;B&#93;&#40;B&#41;
            &#91;5&#93; -1  0       0x0000e800 - 0x0000e8ff &#40;0x100&#41; IX&#91;B&#93;
            &#91;6&#93; -1  0       0x0000e400 - 0x0000e4ff &#40;0x100&#41; IX&#91;B&#93;
            &#91;7&#93; -1  0       0x0000fc00 - 0x0000fc0f &#40;0x10&#41; IX&#91;B&#93;
            &#91;8&#93; -1  0       0x0000ec00 - 0x0000ec1f &#40;0x20&#41; IX&#91;B&#93;
            &#91;9&#93; -1  0       0x0000e080 - 0x0000e09f &#40;0x20&#41; IX&#91;B&#93;
            &#91;10&#93; -1 0       0x0000e000 - 0x0000e01f &#40;0x20&#41; IX&#91;B&#93;
    &#40;II&#41; OS-reported resource ranges after removing overlaps with PCI&#58;
            &#91;0&#93; -1  0       0xffe00000 - 0xffffffff &#40;0x200000&#41; MX&#91;B&#93;&#40;B&#41;
            &#91;1&#93; -1  0       0x00100000 - 0x3fffffff &#40;0x3ff00000&#41; MX&#91;B&#93;E&#40;B&#41;
            &#91;2&#93; -1  0       0x000f0000 - 0x000fffff &#40;0x10000&#41; MX&#91;B&#93;
            &#91;3&#93; -1  0       0x000c0000 - 0x000effff &#40;0x30000&#41; MX&#91;B&#93;
            &#91;4&#93; -1  0       0x00000000 - 0x0009ffff &#40;0xa0000&#41; MX&#91;B&#93;
            &#91;5&#93; -1  0       0x0000ffff - 0x0000ffff &#40;0x1&#41; IX&#91;B&#93;
            &#91;6&#93; -1  0       0x00000000 - 0x000000ff &#40;0x100&#41; IX&#91;B&#93;
    &#40;II&#41; All system resource ranges&#58;
            &#91;0&#93; -1  0       0xffe00000 - 0xffffffff &#40;0x200000&#41; MX&#91;B&#93;&#40;B&#41;
            &#91;1&#93; -1  0       0x00100000 - 0x3fffffff &#40;0x3ff00000&#41; MX&#91;B&#93;E&#40;B&#41;
            &#91;2&#93; -1  0       0x000f0000 - 0x000fffff &#40;0x10000&#41; MX&#91;B&#93;
            &#91;3&#93; -1  0       0x000c0000 - 0x000effff &#40;0x30000&#41; MX&#91;B&#93;
            &#91;4&#93; -1  0       0x00000000 - 0x0009ffff &#40;0xa0000&#41; MX&#91;B&#93;
            &#91;5&#93; -1  0       0xffaffc00 - 0xffaffcff &#40;0x100&#41; MX&#91;B&#93;
            &#91;6&#93; -1  0       0xe0000000 - 0xdfffffff &#40;0x0&#41; MX&#91;B&#93;O
            &#91;7&#93; -1  0       0xff970000 - 0xff97ffff &#40;0x10000&#41; MX&#91;B&#93;&#40;B&#41;
            &#91;8&#93; -1  0       0xd0000000 - 0xd7ffffff &#40;0x8000000&#41; MX&#91;B&#93;&#40;B&#41;
            &#91;9&#93; -1  0       0xff980000 - 0xff9fffff &#40;0x80000&#41; MX&#91;B&#93;&#40;B&#41;
            &#91;10&#93; -1 0       0x0000ffff - 0x0000ffff &#40;0x1&#41; IX&#91;B&#93;
            &#91;11&#93; -1 0       0x00000000 - 0x000000ff &#40;0x100&#41; IX&#91;B&#93;
            &#91;12&#93; -1 0       0x0000e800 - 0x0000e8ff &#40;0x100&#41; IX&#91;B&#93;
            &#91;13&#93; -1 0       0x0000e400 - 0x0000e4ff &#40;0x100&#41; IX&#91;B&#93;
            &#91;14&#93; -1 0       0x0000fc00 - 0x0000fc0f &#40;0x10&#41; IX&#91;B&#93;
            &#91;15&#93; -1 0       0x0000ec00 - 0x0000ec1f &#40;0x20&#41; IX&#91;B&#93;
            &#91;16&#93; -1 0       0x0000e080 - 0x0000e09f &#40;0x20&#41; IX&#91;B&#93;
            &#91;17&#93; -1 0       0x0000e000 - 0x0000e01f &#40;0x20&#41; IX&#91;B&#93;
    &#40;II&#41; LoadModule&#58; "GLcore"
    &#40;II&#41; Loading /usr/X11R6/lib/modules/extensions/libGLcore.a
    Skipping "/usr/X11R6/lib/modules/extensions/libGLcore.a&#58;m_debug_clip.o"&#58;  No symbols found
    Skipping "/usr/X11R6/lib/modules/extensions/libGLcore.a&#58;m_debug_norm.o"&#58;  No symbols found
    Skipping "/usr/X11R6/lib/modules/extensions/libGLcore.a&#58;m_debug_xform.o"&#58;  No symbols found
    Skipping "/usr/X11R6/lib/modules/extensions/libGLcore.a&#58;m_debug_vertex.o"&#58;  No symbols found
    &#40;II&#41; Module GLcore&#58; vendor="The XFree86 Project"
            compiled for 4.3.0.1, module version = 1.0.0
            ABI class&#58; XFree86 Server Extension, version 0.2
    &#40;II&#41; LoadModule&#58; "bitmap"
    &#40;II&#41; Reloading /usr/X11R6/lib/modules/fonts/libbitmap.a
    &#40;II&#41; Loading font Bitmap
    &#40;II&#41; LoadModule&#58; "dbe"
    &#40;II&#41; Loading /usr/X11R6/lib/modules/extensions/libdbe.a
    &#40;II&#41; Module dbe&#58; vendor="The XFree86 Project"
            compiled for 4.3.0.1, module version = 1.0.0
            Module class&#58; XFree86 Server Extension
            ABI class&#58; XFree86 Server Extension, version 0.2
    &#40;II&#41; Loading extension DOUBLE-BUFFER
    &#40;II&#41; LoadModule&#58; "ddc"
    &#40;II&#41; Loading /usr/X11R6/lib/modules/libddc.a
    &#40;II&#41; Module ddc&#58; vendor="The XFree86 Project"
            compiled for 4.3.0.1, module version = 1.0.0
            ABI class&#58; XFree86 Video Driver, version 0.6
    &#40;II&#41; LoadModule&#58; "dri"
    &#40;II&#41; Loading /usr/X11R6/lib/modules/extensions/libdri.a
    &#40;II&#41; Module dri&#58; vendor="The XFree86 Project"
            compiled for 4.3.0.1, module version = 1.0.0
            ABI class&#58; XFree86 Server Extension, version 0.2
    &#40;II&#41; Loading sub module "drm"
    &#40;II&#41; LoadModule&#58; "drm"
    &#40;II&#41; Loading /usr/X11R6/lib/modules/linux/libdrm.a
    &#40;II&#41; Module drm&#58; vendor="The XFree86 Project"
            compiled for 4.3.0.1, module version = 1.0.0
            ABI class&#58; XFree86 Server Extension, version 0.2
    &#40;II&#41; Loading extension XFree86-DRI
    &#40;II&#41; LoadModule&#58; "extmod"
    &#40;II&#41; Loading /usr/X11R6/lib/modules/extensions/libextmod.a
    &#40;II&#41; Module extmod&#58; vendor="The XFree86 Project"
            compiled for 4.3.0.1, module version = 1.0.0
            Module class&#58; XFree86 Server Extension
            ABI class&#58; XFree86 Server Extension, version 0.2
    &#40;II&#41; Loading extension SHAPE
    &#40;II&#41; Loading extension MIT-SUNDRY-NONSTANDARD
    &#40;II&#41; Loading extension BIG-REQUESTS
    &#40;II&#41; Loading extension SYNC
    &#40;II&#41; Loading extension MIT-SCREEN-SAVER
    &#40;II&#41; Loading extension XC-MISC
    &#40;II&#41; Loading extension XFree86-VidModeExtension
    &#40;II&#41; Loading extension XFree86-Misc
    &#40;II&#41; Loading extension XFree86-DGA
    &#40;II&#41; Loading extension DPMS
    &#40;II&#41; Loading extension FontCache
    &#40;II&#41; Loading extension TOG-CUP
    &#40;II&#41; Loading extension Extended-Visual-Information
    &#40;II&#41; Loading extension XVideo
    &#40;II&#41; Loading extension XVideo-MotionCompensation
    &#40;II&#41; Loading extension X-Resource
    &#40;II&#41; LoadModule&#58; "freetype"
    &#40;II&#41; Loading /usr/X11R6/lib/modules/fonts/libfreetype.a
    &#40;II&#41; Module freetype&#58; vendor="The XFree86 Project"
            compiled for 4.3.0.1, module version = 2.0.2
            Module class&#58; XFree86 Font Renderer
            ABI class&#58; XFree86 Font Renderer, version 0.4
    &#40;II&#41; Loading font FreeType
    &#40;II&#41; LoadModule&#58; "glx"
    &#40;II&#41; Loading /usr/X11R6/lib/modules/extensions/libglx.a
    &#40;II&#41; Module glx&#58; vendor="The XFree86 Project"
            compiled for 4.3.0.1, module version = 1.0.0
            ABI class&#58; XFree86 Server Extension, version 0.2
    &#40;II&#41; Loading sub module "GLcore"
    &#40;II&#41; LoadModule&#58; "GLcore"
    &#40;II&#41; Reloading /usr/X11R6/lib/modules/extensions/libGLcore.a
    &#40;II&#41; Loading extension GLX
    &#40;II&#41; LoadModule&#58; "int10"
    &#40;II&#41; Loading /usr/X11R6/lib/modules/linux/libint10.a
    &#40;II&#41; Module int10&#58; vendor="The XFree86 Project"
            compiled for 4.3.0.1, module version = 1.0.0
            ABI class&#58; XFree86 Video Driver, version 0.6
    &#40;II&#41; LoadModule&#58; "record"
    &#40;II&#41; Loading /usr/X11R6/lib/modules/extensions/librecord.a
    &#40;II&#41; Module record&#58; vendor="The XFree86 Project"
            compiled for 4.3.0.1, module version = 1.13.0
            Module class&#58; XFree86 Server Extension
            ABI class&#58; XFree86 Server Extension, version 0.2
    &#40;II&#41; Loading extension RECORD
    &#40;II&#41; LoadModule&#58; "speedo"
    &#40;II&#41; Loading /usr/X11R6/lib/modules/fonts/libspeedo.a
    Skipping "/usr/X11R6/lib/modules/fonts/libspeedo.a&#58;spencode.o"&#58;  No symbols found
    &#40;II&#41; Module speedo&#58; vendor="The XFree86 Project"
            compiled for 4.3.0.1, module version = 1.0.1
            Module class&#58; XFree86 Font Renderer
            ABI class&#58; XFree86 Font Renderer, version 0.4
    &#40;II&#41; Loading font Speedo
    &#40;II&#41; LoadModule&#58; "type1"
    &#40;II&#41; Loading /usr/X11R6/lib/modules/fonts/libtype1.a
    &#40;II&#41; Module type1&#58; vendor="The XFree86 Project"
            compiled for 4.3.0.1, module version = 1.0.2
            Module class&#58; XFree86 Font Renderer
            ABI class&#58; XFree86 Font Renderer, version 0.4
    &#40;II&#41; Loading font Type1
    &#40;II&#41; Loading font CID
    &#40;II&#41; LoadModule&#58; "vbe"
    &#40;II&#41; Loading /usr/X11R6/lib/modules/libvbe.a
    &#40;II&#41; Module vbe&#58; vendor="The XFree86 Project"
            compiled for 4.3.0.1, module version = 1.1.0
            ABI class&#58; XFree86 Video Driver, version 0.6
    &#40;II&#41; LoadModule&#58; "vesa"
    &#40;II&#41; Loading /usr/X11R6/lib/modules/drivers/vesa_drv.o
    &#40;II&#41; Module vesa&#58; vendor="The XFree86 Project"
            compiled for 4.3.0.1, module version = 1.0.0
            Module class&#58; XFree86 Video Driver
            ABI class&#58; XFree86 Video Driver, version 0.6
    &#40;II&#41; LoadModule&#58; "mouse"
    &#40;II&#41; Loading /usr/X11R6/lib/modules/input/mouse_drv.o
    &#40;II&#41; Module mouse&#58; vendor="The XFree86 Project"
            compiled for 4.3.0.1, module version = 1.0.0
            Module class&#58; XFree86 XInput Driver
            ABI class&#58; XFree86 XInput driver, version 0.4
    &#40;II&#41; VESA&#58; driver for VESA chipsets&#58; vesa
    &#40;II&#41; Primary Device is&#58; PCI 01&#58;00&#58;0
    &#40;--&#41; Assigning device section with no busID to primary device
    &#40;--&#41; Chipset vesa found
    &#40;II&#41; resource ranges after xf86ClaimFixedResources&#40;&#41; call&#58;
            &#91;0&#93; -1  0       0xffe00000 - 0xffffffff &#40;0x200000&#41; MX&#91;B&#93;&#40;B&#41;
            &#91;1&#93; -1  0       0x00100000 - 0x3fffffff &#40;0x3ff00000&#41; MX&#91;B&#93;E&#40;B&#41;
    So I don't see any error when loading the glx drivers. Any ideas?


    [/code]

  2. #2
    Linux Enthusiast puntmuts's Avatar
    Join Date
    Dec 2004
    Location
    Republic Banana
    Posts
    562
    Maybe loading a driver for your videocard can help. You are using the VESA driver right now. But according to the log all should be fine.

  3. #3
    Just Joined!
    Join Date
    May 2005
    Posts
    6
    Hey,
    Yah I am using vesa right now, but what is wrong with using it?
    I have no idea, but I will try that to see what happen

    Terence

  4. #4
    Just Joined!
    Join Date
    May 2005
    Posts
    6
    So I am using VIA ProSavage8 and I load the savage driver. I get the same exact error message

    Now I have
    Code:
    Section "Files"
            FontPath        "unix/&#58;7100"                    # local font server
            # if the local font server has problems, we can fall back on these
            FontPath        "/usr/lib/X11/fonts/misc"
            FontPath        "/usr/lib/X11/fonts/cyrillic"
            FontPath        "/usr/lib/X11/fonts/100dpi/&#58;unscaled"
            FontPath        "/usr/lib/X11/fonts/75dpi/&#58;unscaled"
            FontPath        "/usr/lib/X11/fonts/Type1"
            FontPath        "/usr/lib/X11/fonts/CID"
            FontPath        "/usr/lib/X11/fonts/Speedo"
            FontPath        "/usr/lib/X11/fonts/100dpi"
            FontPath        "/usr/lib/X11/fonts/75dpi"
    EndSection
    
    Section "Module"
            Load    "GLcore"
            Load    "bitmap"
            Load    "dbe"
            Load    "ddc"
            Load    "dri"
            Load    "extmod"
            Load    "freetype"
            Load    "glx"
            Load    "int10"
            Load    "record"
            Load    "speedo"
            Load    "type1"
            Load    "vbe"
            Load    "xtt"
    EndSection
    
    Section "InputDevice"
            Identifier      "Generic Keyboard"
            Driver          "keyboard"
            Option          "CoreKeyboard"
            Option          "XkbRules"      "xfree86"
            Option          "XkbModel"      "pc104"
            Option          "XkbLayout"     "us"
    EndSection
    
    Section "InputDevice"
            Identifier      "Configured Mouse"
            Driver          "mouse"
            Option          "CorePointer"
            Option          "Device"                "/dev/psaux"
            Option          "Protocol"              "PS/2"
            Option          "Emulate3Buttons"       "true"
            Option          "ZAxisMapping"          "4 5"
    EndSection
    Section "InputDevice"
            Identifier      "Generic Mouse"
            Driver          "mouse"
            Option          "SendCoreEvents"        "true"
            Option          "Device"                "/dev/input/mice"
            Option          "Protocol"              "ImPS/2"
            Option          "Emulate3Buttons"       "true"
            Option          "ZAxisMapping"          "4 5"
    EndSection
    
    Section "Device"
            Identifier      "Generic Video Card"
            Driver          "savage"
    EndSection
    
    Section "Monitor"
            Identifier      "Generic Monitor"
            HorizSync       30-54
            VertRefresh     50-85
            Option          "DPMS"
    EndSection
    
    Section "Screen"
            Identifier      "Default Screen"
            Device          "Generic Video Card"
            Monitor         "Generic Monitor"
            DefaultDepth    24
            SubSection "Display"
                    Depth           1
                    Modes           "800x600" "640x480"
            EndSubSection
            SubSection "Display"
                    Depth           4
                    Modes           "800x600" "640x480"
            EndSubSection
            SubSection "Display"
                    Depth           8
                    Modes           "800x600" "640x480"
            EndSubSection
            SubSection "Display"
                    Depth           15
                    Modes           "800x600" "640x480"
            EndSubSection
            SubSection "Display"
                    Depth           16
                    Modes           "800x600" "640x480"
            EndSubSection
            SubSection "Display"
                    Depth           24
                    Modes           "800x600" "640x480"
            EndSubSection
    EndSection
    
    Section "ServerLayout"
            Identifier      "Default Layout"
            Screen          "Default Screen"
            InputDevice     "Generic Keyboard"
            InputDevice     "Configured Mouse"
            InputDevice     "Generic Mouse"
    EndSection
    
    Section "DRI"
            Mode    0666
    EndSection
    Terence

  5. #5
    Just Joined!
    Join Date
    May 2005
    Posts
    6
    By the way, the hardware is asus 400 MX with integrate Savage 3d, lastest debian testing (just did apt upgrade), 2.6.8 kernel, xfree 4.3.0

    Not sure if this will help
    Terence

  6. #6
    Linux Enthusiast puntmuts's Avatar
    Join Date
    Dec 2004
    Location
    Republic Banana
    Posts
    562
    Could it be your X version is too old to support your video chipset ?

  7. #7
    Just Joined!
    Join Date
    May 2005
    Posts
    6
    Hmmm... what is the newest xfree?
    I have 4.3.0 and also it is not like I cannot use X at all

  8. #8
    Linux Enthusiast puntmuts's Avatar
    Join Date
    Dec 2004
    Location
    Republic Banana
    Posts
    562
    The latest is 4.5.0 or something. But Debian seems to be one of the few distributions who have Xfree86 in their install. That will probably disappear in a few years when Debian notices everyone else has gone to X.org.

    But I'm guessing, as your config and your logs don't give a clue what is going wrong.

  9. #9
    Just Joined!
    Join Date
    May 2005
    Posts
    6
    I know what is wrong now. After searching the internet exhaustively, it can be
    1) Some people say the permission is not set right. (so try glxgears as root)
    2) Didn't enable 3d accleration.
    3) You are running from a xclient that doesn't support glx.

    For me, it is 3, I am using exceed. There is another version called exceed 3d

    Anyways

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •