Find the answer to your Linux question:
Results 1 to 7 of 7
I've been experiencing a weird emacs related problem and I was wondering if anyone could help. The weird picture is located at http://rplaca.cs.qc.edu/~bpark/weird.jpg The normal picture is located at http://rplaca.cs.qc.edu/~bpark/normal.jpg ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Engineer
    Join Date
    Nov 2002
    Location
    Queens, NY
    Posts
    1,319

    weird X problem


    I've been experiencing a weird emacs related problem and I was wondering if anyone could help.
    The weird picture is located at http://rplaca.cs.qc.edu/~bpark/weird.jpg

    The normal picture is located at http://rplaca.cs.qc.edu/~bpark/normal.jpg

    This happens from time to time. There is no consistency. From what I can tell, the weird picture looks like the cursor(on 'W') has double height. Somehow, it's double spaced on its own. If anyone has any suggestions, please post something.

    bp
    The best things in life are free.

  2. #2
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    It seems strange that it happens randomly. Could it be some font problem?

  3. #3
    Linux Engineer
    Join Date
    Nov 2002
    Location
    Queens, NY
    Posts
    1,319

    some clues

    OK,

    After trying out some tests, it seems that the emacs window will become weird when another X-window application is launched. For example, when I visit certain web sites that have java applets, a new window will pop up and display if I want to grant permission for this session or not. Once this window pops up, the emacs fonts become all weird.
    Did I mention that the problem goes away when I log back in to the system?

    bp
    The best things in life are free.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    That seems like a bug in the X server. Which version are you using?

  6. #5
    Linux Engineer
    Join Date
    Nov 2002
    Location
    Queens, NY
    Posts
    1,319
    I believe I'm using v 4.1.0-16. For some reason. The only thing I did to tweak this was add a .Xresources file and .Xdefaults file in my home directory. They contain nothing else other than setting up that emacs font. Another thing I did was removing xfonts-100dpi. I manually deleted the lines that contained the path to these directories since I deleted them.

    bp
    The best things in life are free.

  7. #6
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    I don't think that it's a config error since it's caused by another program, something that should never happen. Maybe you should report this to one of the mailing lists at www.xfree86.org.

  8. #7
    Linux Engineer
    Join Date
    Nov 2002
    Location
    Queens, NY
    Posts
    1,319

    still no solution

    I'd like to add that running gkrellm also causes this problem. Again, gkrellm uses X so I guess it's nothing new but I was hoping that someone may have solution to this.

    bp
    The best things in life are free.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •