Find the answer to your Linux question:
Results 1 to 7 of 7
I admin lots of Unix servers (mostly Solaris) and need to export my display back to my Suse workstation using KDE. Let me start with SSH is not an option. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2005
    Posts
    3

    Can't export display to linux box


    I admin lots of Unix servers (mostly Solaris) and need to export my display back to my Suse workstation using KDE.

    Let me start with SSH is not an option.

    Here what I've tried...

    -> xhost + (duuuh)

    -> Edited startx. Removed the line;

    test "$DISPLAYMANAGER_XSERVER_TCP_PORT_6000_OPEN" != "yes" && serverargs="$serverargs -nolisten tcp"

    -> Uncommeted the following line in /etc/services

    x11 6000-6063/tcp X Window System

    -> Edited /etc/X11/xdm/Xservers
    from; :0 local /usr/X11R6/bin/X -nolisten tcp -br vt7
    to: :0 local /usr/X11R6/bin/X -br vt7

    -> Maked sure the link, /etc/opt/kde3/share/config/kdm/Xservers exists

    -> Changed ServerArgsLocal=-nolisten tcp, to, ServerArgsLocal="" in /etc/opt/kde3/share/config/kdm/kdmrc

    -> Restarted X

    I'm going nuts. I've was able to get this working under Suse 9.2, but have upgraded to 9.3 and can't get it to work.

    TIA,

    Mike

  2. #2
    Just Joined!
    Join Date
    Jun 2005
    Posts
    3
    I've also tried setting;

    DISPLAYMANAGER_XSERVER_TCP_PORT_6000_OPEN="yes"

    in /etc/sysconfig/displaymanager without any luck.

  3. #3
    Just Joined!
    Join Date
    Jun 2005
    Posts
    3

    Fixed it!

    Forget all the above. Just be sure the following is set. in etc/sysconfig/displaymanager

    DISPLAYMANAGER_REMOTE_ACCESS="yes"
    DISPLAYMANAGER_ROOT_LOGIN_REMOTE="yes"
    DISPLAYMANAGER_XSERVER_TCP_PORT_6000_OPEN="yes"

    Uncommeted the following line in /etc/services
    x11 6000-6063/tcp X Window System

    Then reset X.

    Mike

  4. #4
    Just Joined!
    Join Date
    Jul 2006
    Posts
    1

    Smile Minimal changes necessary to export display to SuSE 9.3

    I was having the same problem, and thanks to your advice I fixed it right away after hours of beating my head on this!

    For further reference for anyone interested, I found after further investigation
    that at the minimum, there were only 2 changes necessary to make this work for my SuSE 9.3 box:

    (1) DISPLAYMANAGER_XSERVER_TCP_PORT_6000_OPEN="yes" in /etc/sysconfig/displaymanager

    (2) remove (comment-out) the "ServerArgsLocal= -nolisten tcp" line in /etc/opt/kde3/share/config/kdm/kdmrc

    I also un-commented the two "x11" lines in /etc/services just for form's sake (if I'm using the X service, these lines may as well be uncommented). But to my surprise, this didn't seem to affect my ability to connect to the X server one way or the other.

    I also found the following files or parameters to be of interest, although not necessary to make any changes to these for things to work on my box:

    in /etc/sysconfig/displaymanager:

    DISPLAYMANAGER_ROOT_LOGIN_REMOTE
    - this was necessary to connect to the X server, only if I had telnet-ed to the application machine (X client machine) from a root shell on the X server machine (the SuSE 9.3 box) (I didn't try exporting display from a root shell on the X client machine so I don't know if it affects this)

    DISPLAYMANAGER_REMOTE_ACCESS
    - this didn't seem to affect ability to connect to the X server, maybe it's for accessing the actual display manager (not the X server itself) remotely?

    /opt/kde/share/config/kdm/kdmrc
    - same file as /etc/opt/kde/share/config/kdm/kdmrc, but changes in this file didn't seem to affect anything. It must be just an installation copy for reference or re-configuration to defaults, not an actively-used config file.

    /etc/X11/xdm/Xservers
    - contains "-nolisten tcp" arguments, but didn't seem to matter, presumably becuase I am using kdm, not xdm. Perhaps it matters if using xdm.

    /etc/X11/xinit/xserverrc
    - consults the variable DISPLAYMANAGER_XSERVER_TCP_PORT_6000_OPEN in /etc/sysconfig/displaymanager and sets "-nolisten tcp" if "no". I would say one should never need to modify this file, but it's something useful to know about.

    T.R.

  5. #5
    Just Joined!
    Join Date
    Aug 2006
    Posts
    1

    For SuSE Linux 10.0

    Hi all,

    I have exactly the same problem in SuSe 10.0. I tried the actions that solved the problem for 9.3 but it didn't work.

    Has anyone any idea about that??

    Thanks

  6. #6
    Just Joined!
    Join Date
    Apr 2007
    Posts
    1
    subagon, thanks SOOOO MUCH for the recipe - it almost worked on my SUSE 10.3.
    And I wasted so many hours trying to figure this out....

    The only thing that is missing in your post is the Firewall:
    YaST -> Security -> Firewall
    Allowed Services -> Remote Access to Display Manager -> Add
    Advanced -> TCP Ports -> 6000

    And voila! It is working now.

  7. #7
    Just Joined!
    Join Date
    Feb 2008
    Posts
    4

    Look in /var/log/messages

    Always look in /var/log/messages. You will find usefull hints for this problems. In my case it was the firewall. My network card was defined as external.


    Thomas

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •