I'm posting this answer to a problem as it took me a while to find the answer, and so I'm trying to make it easier for others to solve this problem.

Not only did I receive the
Code:
Could not start process 
Unable to create io-slave
klauncher said:Unknown protocol 'file'
pop-up message when I tried to login to KDE, but I also found that any application written to run under KDE (such as Konqueror and Quanta plus), gave error messages when I ran them under Gnome or XFCE.

Quanta plus gave a raft of error messages such as :-
Code:
Could not find mime type
application/octet-stream
and
Code:
No mime type installed
and
Code:
Cannot load toolbars from archive
Solution
The way passed this is as follows :-

1. Login to KDE
2. Right-click on the desktop/background and open a console
3. enter -> rm -vf ~/.kde/share/config/ksycoca
4. enter -> kbuildsycoca
5. Logout and then log back in again to KDE.


If you get any permissions error messages, then enter the following between steps 3 and 4 (above) -
rm /var/tmp/kdecache-nerderello/ksycoca

Obviously you would put your own username in place of the "nerderello" in the above remove command (rm).

have fun

Nerderello