Find the answer to your Linux question:
Results 1 to 9 of 9
I have reinstalled SuSE over Red Hat because of connectivity issues. The display in RedHat worked, although I could not get 3d acceleration, which is fine for what I plan ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2003
    Posts
    82

    Help with configuring x-windows display


    I have reinstalled SuSE over Red Hat because of connectivity issues. The display in RedHat worked, although I could not get 3d acceleration, which is fine for what I plan to use Linux for (almost everything but games). The internet connection works in SuSE.

    However, now when I try to use Sax2 to set up X Windows display settings, I can't get it to work at all. My display is a Nec Multisync 1760v. There are no specific Linux drivers online. I have the frequency settings etc and know how to put them in manually. I think the problem is with the video card itself

    It is a ATI Radeon 9800 pro. Of course this does not show up at all on the options screen; next best thing =? I tried Vesa, as well as the generic (can't recall what the name listed was atm).

    When I test the monitor/vid card choices, all I get is
    /dev/fb0: no such device
    no devices detected

    The GRUB loader pops up with
    kernel (hd1,0)/boot/vmlinuz
    root=/dev/hdb1
    vga=nil
    hdc=ide-scsi
    hdclun=0
    splash=silent
    [linux-bzimage,setup 0x1400 size 0x13391f]
    Error 23: error while parsing number


    Any ideas how to configure this so that I can at least get SOME display? I am trunning to run KDE.

    Failing this, how do I remove GRUB from the MBR of hda so I can forget about linux until these issues get better?

  2. #2
    Linux Engineer
    Join Date
    Jul 2003
    Location
    Stockholm, Sweden
    Posts
    1,296
    cant help with card problem but rather than uninstalling grub why not just use it to boot windows?

  3. #3
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    What did GRUB have with this to do? You were able to boot, right?

    Anyway, what program is this that you're using and why is it trying to use the framebuffer device? If you run "XFree86 -configure", does that yield a useful configuration?

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Aug 2003
    Posts
    82
    The only reason I would want to remove GRUB is if/when I give up on using Linux, I would prefer to not bother with boot loader options that don't mean anything.

    If I load into safe mode ('failsafe'), I can indeed load xf86config and find a configuration that will let me load KDE with some services dimished.

    When I exit from it, though, and reboot, I still cannot boot right into KDE. It has to be after reconfiguring each and every time.

    WHen I run Sax2, the problem becomes clear: I can't even pick a generic card to run, it seems. The fb0 error comes when I test a generic card setting (either unclassified or VESA).

    Someone in another forum noted that the new Firegl drivers will work with the 9800 pro as r350.

    I installed a package, and it seemed to all work, but nothing shows up on the sax2 screen under ATI (no r350 at least...there is r300). Checking the date on the readme, I think there is a newer version that would actually work. I will try tomorrow (getting late for me) and report back.

  6. #5
    Linux Engineer
    Join Date
    Dec 2002
    Location
    New Zealand
    Posts
    766
    thats not how u configure those drivers..

    i think the isntall into /lib/firegl or /lib/fglrx go into whereever it installed to and run the make scipts in ./build (i think thats where they are)

    once its all compiled run fglrxconfig from a terminal.

  7. #6
    Just Joined!
    Join Date
    Aug 2003
    Posts
    82
    Success.

    Thanks for all your help guys.

    I used to Firegl drivers (newest ones), compiled this, compiled the other thing, type in all kinds of RPM commands, and still I couldn't figure it out.

    The last post clued me into how to run the correct configure program. This stuff does NOT show up on Sax2 or xf86config. THe config program you pointed me to also got my mouse working again (scroll wheel).

    I also have sound working even with the Audigy 2!

    I got rid of the error message at bootup by editing GRUB to remove the no vga part, and the errors went away.

    I am now a happy fiddler of Linux!

    Thanks for all your help guys!

  8. #7
    Just Joined!
    Join Date
    Sep 2003
    Location
    southern california
    Posts
    66

    my new laptop

    i got a new laptop, dumped winblos xp and installed redhat 9 although 800x600 dows not bother me i would like to expand my res and ideas on how to do this

  9. #8
    Linux Engineer
    Join Date
    Dec 2002
    Location
    New Zealand
    Posts
    766
    if u got mdk, run the display config thing in mcc.

    try pressing ctrl+alt+num_plus a few times although its supposed to default to the highest availble res.

    check that /etc/X11/XF86config-4 (or just XF86Config in RH) has the higher diplay modes listed in the screen section i think.

  10. #9
    Just Joined!
    Join Date
    Jul 2005
    Posts
    1
    I have a 20GB hard disk with two partitions. On the first partition it is installed Windows 98 and the second partition it is installed Conectiva Linux.
    I putted other hard disk as secondary and installed debian on it and the conectiva is not working anymore, i don't understand because the debian is installed on other hard disk. When i remove the hard disk that i installed debian the hard disk that remains on the machine don't work anymore.
    It returns a message "grub error" or something like this.
    If i remove the grub maybe it will stop this error message, but i need to access the conectiva, how can i do this???

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •