Find the answer to your Linux question:
Results 1 to 6 of 6
I was loging in the other night and the power went out. When I finallly got logged in the login screen had changed. I can not open the gui. There ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2005
    Posts
    3

    Fedora gui gone


    I was loging in the other night and the power went out. When I finallly got logged in the login screen had changed. I can not open the gui. There are no options to start it. I just get a login for localhost.... Are there special key stroke to get me back to the gui??? Thank you for any help....

  2. #2
    Linux Guru dylunio's Avatar
    Join Date
    Aug 2004
    Location
    Cymru
    Posts
    4,157
    Tell us what happens when you type
    Code:
    startx
    Registered Linux User #371543!
    Get force-get May The Source Be With You
    /dev/null
    /dev/null2

  3. #3
    Just Joined!
    Join Date
    Jul 2005
    Posts
    3

    gui gone

    When I type startx I get an error stating that it is already runing. I change consoles and can not find the gui. The login is on screen 7 but console 1 will open.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru dylunio's Avatar
    Join Date
    Aug 2004
    Location
    Cymru
    Posts
    4,157
    Rather strange, so ctrl+alt+F7 will not take you to a gui, and startx says that X is started.

    Erm, have you run
    Code:
    ps aux | grep x
    to see if X is running, if so maybe you should try and kill it?
    Registered Linux User #371543!
    Get force-get May The Source Be With You
    /dev/null
    /dev/null2

  6. #5
    Just Joined!
    Join Date
    Jul 2005
    Posts
    3
    I can try that when I get home, at work now. Still I should get a login screen that gives me an option to log in.

  7. #6
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    It could be that some lockfiles or X sockets are lingering. That normally shouldn't be a problem, but try to run the following command and see if it helps (you may need to reboot after running it).
    Code:
    rm -rf /tmp/.X*-lock /tmp/.X11-unix/*

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •