Find the answer to your Linux question:
Results 1 to 10 of 10
I am having a problem with X on a FreeBSD installation in VMware. Although it's not Linux, I am sure someone might know First problem, I have KDE 3.1 installed ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux User Allblack's Avatar
    Join Date
    May 2003
    Location
    Godzone
    Posts
    416

    A few X questions


    I am having a problem with X on a FreeBSD installation in VMware.
    Although it's not Linux, I am sure someone might know

    First problem, I have KDE 3.1 installed and my mouse does not function. It does not appear. I have "Moused_enabled=yes" in /etc/rc.conf.
    The mouse works when I move it in the shell but it did not appear in the standard windows manager before I installed KDE

    Second problem, This one seems to happen every time I configure X.
    My screen is bigger than my monitor. In FreeBSD you use xf86config to configure your x settings( is this the same in Linux?) and one of the questions is that you want your screen bigger than your physical screen. I always answer no but it is still bigger. How can I fix this?

    I have a Linux in VMware question as well but will post it seperate.

    Cheers
    I am on a journey to mastering Linux and I got a bloody long way to go!!!

  2. #2
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    What mouse device have you set in /etc/X11/XF86Config?
    You know, in both BSD and in Linux, you set your X settings in /etc/X11/XF86Config; that's where the X server reads it from. xf86config is just a front-end to write that file. How do you mean that your screen is bigger than your monitor? Do you get a scrolling desktop?

  3. #3
    Linux User Allblack's Avatar
    Join Date
    May 2003
    Location
    Godzone
    Posts
    416
    Thanks,

    I have set it to PS2 for the mouse settings.
    About the screen size, I do get scrollbars because I am in vmware but I had this problem before when I installed it. Usually you can drag your entire screen by clicking it.

    Hope this make sense.
    I am on a journey to mastering Linux and I got a bloody long way to go!!!

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    VMware... I don't really know much about this, but what does your mode line in XF86Config look like?
    Can you post the entire InputDevice section for the mouse?

  6. #5
    Linux User Allblack's Avatar
    Join Date
    May 2003
    Location
    Godzone
    Posts
    416
    Looks like my BSD install in vmware has fallen over all together so it is not an issue anymore.
    Is the xf86config tool included on Red Hat 9? I can't find it anywhere.
    Is X -configure serving the same purpose as xf86config?

    Cheers
    I am on a journey to mastering Linux and I got a bloody long way to go!!!

  7. #6
    Linux Engineer
    Join Date
    Dec 2002
    Location
    New Zealand
    Posts
    766
    they both serve the same purpose.
    yes xf86config is in redhat. and its might just be mdk but i have xf86cfg which is the same but graphical.

  8. #7
    Just Joined!
    Join Date
    Oct 2002
    Posts
    45
    The problem you are having with your "screen" being bigger than your monitor, is a called a virtual desktop. If you are using xf86config, when it asks you if the resolutions and color-depths are ok, edit them, and then it will ask you if you want to use a virtual desktop; you don't. I think it is an extremely annoying option, but it's always nice to have a choice!

  9. #8
    Linux User Allblack's Avatar
    Join Date
    May 2003
    Location
    Godzone
    Posts
    416
    I know about the virtual desktop. Definitly answered no but the screen was still too big after that. I will try it again as I am reinstalling it. Seems that installing Linux/FreeBSD in VMware is not as straightforward as installing windows in it.

    Still can't find xf86config on my Red Hat box .

    Cheers
    I am on a journey to mastering Linux and I got a bloody long way to go!!!

  10. #9
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    It's not a matter of finding it, just run it, ie. type it in the shell. If you really don't have it, then run xf86cfg instead.

  11. #10
    Linux User Allblack's Avatar
    Join Date
    May 2003
    Location
    Godzone
    Posts
    416
    Obviously I tried to run it before I started to search for it. When it said the command could not be found I tried "locate xf86config" but no luck.
    I will try the other command you suggested
    I am on a journey to mastering Linux and I got a bloody long way to go!!!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •