Find the answer to your Linux question:
Results 1 to 2 of 2
Hi, I'm running RH 8.0 and and would like to add some snazzy new fonts for my desktop, and applicatons. I downloaded the freefonts and sharefonts packages, untarred them into ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2003
    Location
    U.S.
    Posts
    1

    Adding fonts in GNOME 2


    Hi,

    I'm running RH 8.0 and and would like to add some snazzy new fonts for my desktop, and applicatons. I downloaded the freefonts and sharefonts packages, untarred them into usr/share/fonts and added them to my X11 config with /usr/sbin/chkfontpath --add /usr/share/font/freefont and sharefont. I then resarted my xsession by logging out and then back in. I checked my font paths with /usr/sbin/chkfontpath --list and the paths are there.

    I should be able to see these fonts in "font preferences" dialogue correct? But I don't. What else needs to be done, what am I not doing?

    Any help would greatly be appreciated

  2. #2
    Linux Enthusiast
    Join Date
    Jun 2002
    Location
    San Antonio
    Posts
    621
    I don't know how up to date RedHat is on their fontconfig/Xft/Freetype type stuff. Type `fc-list` see if that gives you anything. If it does, try running fc-cache to update the font list.

    Here is what I did to install those fonts that you speak of.
    download freefont.tar.gz
    extract it
    mv all the files it extracted to /home/sams/.fonts/
    xset fp+ /home/sams/.fonts
    xset fp rehash
    fc-cache
    now they all show up in my font dialog
    I respectfully decline the invitation to join your delusion.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •