Find the answer to your Linux question:
Results 1 to 3 of 3
I'm having problems compiling any KDE-dependent software right now (Superkaramba and KDE themes, mostly). The error I'm getting is: /opt/kde/lib/libkdecore.so: undefined reference to `KStyle::defaultStyle()' /opt/kde/lib/libkdeui.so: undefined reference to `KPixmap::~KPixmap [not-in-charge]()' ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2005
    Posts
    2

    KDE-dependent apps won't compile


    I'm having problems compiling any KDE-dependent software right now (Superkaramba and KDE themes, mostly). The error I'm getting is:

    /opt/kde/lib/libkdecore.so: undefined reference to `KStyle::defaultStyle()'
    /opt/kde/lib/libkdeui.so: undefined reference to `KPixmap::~KPixmap [not-in-charge]()'
    collect2: ld returned 1 exit status
    make[3]: *** [superkaramba] Error 1
    make[3]: Leaving directory `/var/tmp/portage/superkaramba-0.36/work/superkaramba-0.36/src'
    make[2]: *** [all-recursive] Error 1
    make[2]: Leaving directory `/var/tmp/portage/superkaramba-0.36/work/superkaramba-0.36/src'
    make[1]: *** [all-recursive] Error 1
    make[1]: Leaving directory `/var/tmp/portage/superkaramba-0.36/work/superkaramba-0.36'
    make: *** [all] Error 2

    I Googled the problem, and the Arch Linux forums had a suggestion to reinstall kdelibs. I did that, even updating from KDE 3.3.2 to 3.4.1, and it's still the same error message.

    Any suggestions?

    Possibly relevent information:
    Celeron 1009MHz
    20GB HD
    320MB RAM
    nVidia GeForce something or other
    Slackware 10.1
    have tried superkaramba 0.35, 0.36, 0.37-RC1...all fail. KDE themes (keramik with transparent kicker and liquid) are other attempts that fail with the same error.

  2. #2
    Linux User Muser's Avatar
    Join Date
    May 2004
    Location
    Maryland
    Posts
    363
    Try updating Qt. I had similar issues before doing that.

  3. #3
    Linux Engineer
    Join Date
    Jan 2005
    Location
    Chicago (USA)
    Posts
    1,028
    What compiler are you using? GCC4 has issues with a lot of older code.

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •