Find the answer to your Linux question:
Results 1 to 5 of 5
When I boot, X-Windows doesn't start. Everything else seems to be OK as far as I can tell. When I try startx, I get the following message: Cannot open log ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2005
    Posts
    3

    Debian/Xandros lost X-Windows


    When I boot, X-Windows doesn't start. Everything else seems to be OK as far as I can tell. When I try startx, I get the following message:
    Cannot open log file "/var/log/XFree86.0.log".

    I attempted to find the log file, ls -l XFree86.0.log, gives the message "Permission denied" even when using su.

    When I attempted to boot in "safe video mode", I got lots of permission denied errors, including directories /var/log/boot, boot.0, boottime.

    I had been running Xandros for about a year, but have recently been exploring other distros in mult-boot mode. I have Slackware and Debian (non-Xandros) installed, although I haven't gotten them working totally yet, and I wonder if something I was doing with LILO may have caused the problem.

    I thought "root" was all-powerful. Under what situation would root get a permission denied to list a file?

    I've been using Linux for about a year now on an occasional basis, but am new to trouble-shooting problems. I appreciate any help you can provide.

  2. #2
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    For Debian... have you run xf86config yet?

    BTW: here's the man page in case there's anything there that you might need:

    http://www.xfree86.org/4.3.0/XF86Config.5.html

  3. #3
    Just Joined!
    Join Date
    Jul 2005
    Posts
    3
    I have an XF86Config file under /etc/X11, but how do I know that's the one that would be used?

    With Xandros, a lot of installation stuff happens under the covers, so I did not run xf86config explicitly, but I think it must have been part of the install sequence.

    BTW, I do have a "/var/log/XFree86.1.log" that is accessible, but that doesn't seem to be the one that the Xandros boot sequence or startx wants to use.

    Thanks for the man page ref.

  4. $spacer_open
    $spacer_close
  5. #4
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    From the console as root, you can type in the command: xf86config

    This will start a small program to setup your X configuration, but you will need to know a bit about your hardware, such as proper monitor settings, video card driver & memory, mouse type, keyboard type, etc.

  6. #5
    Just Joined!
    Join Date
    Jul 2005
    Posts
    3
    After reading about configuring XFree86 in the O'Reilly "Running Linux" book, I found a reference to a config program used by Xandros named "buildxconf". I removed the existing XF86Config-4 in /etc/X11. buildxconf built a new one. When I ran startx, I got the same result, "Fatal Server Error Cannot open log file "/var/log/XFree86.0.log".

    I removed the XF86Config-4 again and ran the xf86config program, as suggested by Ozar in this thread. This wrote an XF86Config file (without the "-4"). startx yielded the same result. I tried renaming the file to XF86Config-4, but the result of startx remained the same.

    I'm still curious about the message when I try to "ls" XFree86.0.log. My experience is that if the file isn't there, I get a message saying "no such file or directory." In this case, however, running as root, I get the message "ls: XFree86.0.log: Permission denied" I tried booting Knoppix to look for the file, but XFree86.0.log did not appear in the /var/log directory on my Xandros partition (hda2).

    Maybe this is all irrelevant. Either way, I'm open to further suggestions.

    Thanks.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •