Find the answer to your Linux question:
Results 1 to 5 of 5
Linux Ubuntu 5.4 After accepting an update today (think it was xpdf stuff) I rebooted because I wanted to boot-up XP. I left the PC to reboot and came back ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2005
    Posts
    3

    I can not start the X server


    Linux Ubuntu 5.4

    After accepting an update today (think it was xpdf stuff) I rebooted because I wanted to boot-up XP. I left the PC to reboot and came back 30mins later to find the monitor off. Thinking it was on power save I tired to wake it but no joy and the green light was on. Manually rebooted and worked in XP and updated that rebooted back in to XP and then later on rebooted to launch Ubuntu. First off it did a force check claiming HD not umounted properly but could not finish HD check and I maually did that with lots of Y clicking. Rebooted and once it had started Ubuntu it ran through like normal and just as I was expecting the login prompt I got:
    I can not start the X server. It is likely that it is not setup correctly. Would you like to view the X server output to diagnose the problem. Y or N

    X Window System Version 6.8.2
    X Protocol Version 11, revsion 0, release 6.8.2
    Linux 2.6.10, 686 [ELF]

    X10 fatal I/O error 104

    The upshot it that I have no GUI which to me renders the whole thing useless.
    Does anyone know how I can fix this? I'm assuming that I can re-install/repair X server (from the command line) with-out touching Ubuntu, if so how?

    I have posted over at Ubuntu forums and the only advice so far was to re-install Ubuntu from scratch, I dont want to do this it was working fine until today.

  2. #2
    Linux Guru budman7's Avatar
    Join Date
    Oct 2004
    Location
    Knee deep in Grand Rapids, Michigan
    Posts
    3,242
    Do the sudo thing, or whatever you do to get root access.
    Then do "xorgconfig"
    That command will allow you to configure X.
    you will need info on
    Monitor refresh rates, vertical and horizontal. they can be found on the back of the monitor.
    Video card, and how much memory it has. There is a list to choose from.
    Mouse and keyboard.
    How to know if you are a geek.
    when you respond to "get a life!" with "what's the URL?"
    - Birger

    New users read The FAQ

  3. #3
    Linux Guru bryansmith's Avatar
    Join Date
    Nov 2004
    Location
    /Ontario/Canada
    Posts
    2,619
    You could try to reinstall xorg. Do the following:
    Code:
    sudo apt-get remove x-window-system
    sudo apt-get install x-window-system
    If it worked before, then a reinstall should work.

    Bryan
    Looking for a distro? Look here.
    "There can be no doubt that all our knowledge begins with experience." - Immanuel Kant (Critique of Pure Reason)
    Queen's University - Arts and Science 2008 (Sociology)
    Registered Linux User #386147.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Aug 2005
    Posts
    3
    Thanks for the replies set me in the right direction.
    I did the xorgconfig but startx would still not work then I reinstalled xserver-xorg and after reinstalling xfonts-base I got the Ubuntu login screen.
    Yippie, or so I thought until the desktop came up like this.


    So now I'm at a loss as to what needs installing. I had a look at Gnome under Synaptic but it wasn't installed and the description for it was a package of utils including some office stuff, so I guess there is something else that needs installing.
    What next, any ideas?

    PS Firefox would not operate just brought up a blank window and I had the standard Gnome desktop but I'd moved the panels around.

  6. #5
    Just Joined!
    Join Date
    Aug 2005
    Posts
    3
    Given up.

    Now doing complete re-install

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •