Find the answer to your Linux question:
Results 1 to 3 of 3
Hi For some strange reason both right and left shift keys have stopped working in GNOME. I would normally blame a kepmap problem, but they work fine in a console ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2005
    Posts
    1

    Shift keys not working properly under GNOME 2.10.2


    Hi

    For some strange reason both right and left shift keys have stopped working in GNOME. I would normally blame a kepmap problem, but they work fine in a console and when some program overrides GNOME input such as gksu.

    When the shift key is held down, no key combination will work when typing into an xterm for example. However, if CAPS Lock is on, then the shift key will work but in reverse, of course.

    Weird? Or have you seen this before or can suggest a solution?


    Many thanks.

  2. #2
    Just Joined!
    Join Date
    Sep 2006
    Posts
    2
    I am experiencing the same problem on a fresh install of SLED10, which I think is using GNOME 2.12. Cap lock gives access to upper-case letters but no : | or ~. Makes it hard to get around. I'm still surfing about for an answer.

    I did notice that the shift key will turn my cursor from an I-beam to an arrow when pressed. So it is actually doing something.

  3. #3
    Just Joined!
    Join Date
    Sep 2006
    Posts
    2
    Arghh! I just fixed it but I don't know exactly what I did. Pretty sure it has to do with some of the key combination features of the XGL desktop. Many let you pick CTRL, SHIFT, ALT & SUPER. I was mucking about with these when the problem went away. I tried changing them some more to find the magic combination that breaks the SHIFT key but no luck.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •