Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
Is there anyway to change the IceWM desktop background? Bryan...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Guru bryansmith's Avatar
    Join Date
    Nov 2004
    Location
    /Ontario/Canada
    Posts
    2,619

    IceWM Background


    Is there anyway to change the IceWM desktop background?

    Bryan
    Looking for a distro? Look here.
    "There can be no doubt that all our knowledge begins with experience." - Immanuel Kant (Critique of Pure Reason)
    Queen's University - Arts and Science 2008 (Sociology)
    Registered Linux User #386147.

  2. #2
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    Very easy:
    Code:
    icewmgb /path/to/your/background.jpg
    Open ~/.icewm/preferences and look toward the bottom of the file. There is a place there where you can enter the background and it will boot to it until you change it. Here's mine as a reference...
    Code:
    #  Desktop background image
       DesktopBackgroundImage="/home/dapper/Pictures/greerwestontruck/photo0119.jpeg"
    
    #  Color to announce for semi-transparent windows
    # DesktopTransparencyColor=""
    
    #  Image to announce for semi-transparent windows
    # DesktopTransparencyImage=""
    
    #
    Also, be sure to un-comment the line.
    Linux Mint + IceWM Registered: #371367 New Members: click here

  3. #3
    Linux Guru bryansmith's Avatar
    Join Date
    Nov 2004
    Location
    /Ontario/Canada
    Posts
    2,619
    Quote Originally Posted by Dapper Dan
    Very easy:
    Code:
    icewmgb /path/to/your/background.jpg
    Should that not be icewmbg? :P

    Also, my background is still the default VectorLinux one. Here is the bottom of my preferences file:
    Code:
    #
    # icewmbg preferences
    #
    # IMPORTANT: You MUST run icewmbg (probably before icewm)
    #            to set the background!
    #
    
    #  Display desktop background centered and not tiled
    DesktopBackgroundCenter=1 # 0/1
    
    ###  Support for semitransparent terminals like Eterm or gnome-terminal
    SupportSemitransparency=1 # 0/1
    
    ###  Desktop background scaled to full screen
    DesktopBackgroundScaled=1 # 0/1
    
    ###  Desktop background color
    DesktopBackgroundColor = "midnightBlue"
    
    ###  Desktop background image
    DesktopBackgroundImage = /home/bryan/pictures/ccr.jpg
    
    ###  Color to announce for semi-transparent windows
    DesktopTransparencyColor="darkblue"
    
    #  Image to announce for semi-transparent windows
    # DesktopTransparencyImage=""
    My preferences seem to be in order.

    Also, at the top it says to run icewmbg probably before icewm, should I be concerned with this?

    Bryan
    Looking for a distro? Look here.
    "There can be no doubt that all our knowledge begins with experience." - Immanuel Kant (Critique of Pure Reason)
    Queen's University - Arts and Science 2008 (Sociology)
    Registered Linux User #386147.

  4. $spacer_open
    $spacer_close
  5. #4
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    Quote Originally Posted by bryansmith
    Should that not be icewmbg? :P
    Yes, sorry. I was bleary eyed tired when I posted. When IceWM loads, it runs icewmbg in the process. Also, make sure your DesktopBackgroundImage is in quotes...
    Code:
    ##  Desktop background image
    DesktopBackgroundImage ="/home/bryan/pictures/ccr.jpg"
    Also, at the top [of the preference file] it says to run icewmbg probably before icewm, should I be concerned with this?
    It's not going to hurt anything to run it after icewm is up and running. I do it all the time to check out new backgrounds. I think they have that there in case you want the bg up when IceWM comes up. Just in case, it took me a while to figure out the command to invoke IceWM correctly is:
    Code:
    icewm-session
    instead of just "icewm." If you prefer, Vadim Khohlov has made a neat IceWM configurator called Icecc.
    Linux Mint + IceWM Registered: #371367 New Members: click here

  6. #5
    Linux Guru bryansmith's Avatar
    Join Date
    Nov 2004
    Location
    /Ontario/Canada
    Posts
    2,619
    Okay, it still isn't working. I put the picture in quotes in my preferences file. I ran icewmbg but it just comes up saying:
    Code:
    icewmbg: using /home/bryan/.icewm for private configuration files
    It says this with no sign of the computer actually doing anything.

    Any more ideas?

    Bryan
    Looking for a distro? Look here.
    "There can be no doubt that all our knowledge begins with experience." - Immanuel Kant (Critique of Pure Reason)
    Queen's University - Arts and Science 2008 (Sociology)
    Registered Linux User #386147.

  7. #6
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    Any time I run icewm, I start it and the background tool "icewmbg" in the .xinitrc file, like this:

    Code:
    #!/bin/sh
    #
    # ~/.xinitrc
    #
    icewmbg &
    exec icewm

  8. #7
    Linux Guru bryansmith's Avatar
    Join Date
    Nov 2004
    Location
    /Ontario/Canada
    Posts
    2,619
    Quote Originally Posted by Ozar
    Any time I run icewm, I start it and the background tool "icewmbg" in the .xinitrc file, like this:

    Code:
    #!/bin/sh
    #
    # ~/.xinitrc
    #
    icewmbg &
    exec icewm
    That sort of worked . This time, the wallpaper started as the one I wanted then quickly changed back to the default VectorLinux one. Any ideas?

    Bryan
    Looking for a distro? Look here.
    "There can be no doubt that all our knowledge begins with experience." - Immanuel Kant (Critique of Pure Reason)
    Queen's University - Arts and Science 2008 (Sociology)
    Registered Linux User #386147.

  9. #8
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    Maybe you can try commenting out any background entry in the vector theme, if that's where it's coming from. Otherwise, check your preferences file to see if it's listed there. Once you find it, comment it out.

    That should allow your personal background to work.

  10. #9
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    At any rate, When you edit your preference file as mentioned above, and give the path to your prefered background, it should come up when you re-start IceWM. I just tested it on Slackware, Debian and Mepis, and it worked all three times I tried it.

    I found with SuSE 9.1, that the command used to start IceWM is, "icewm." If that is used, it won't put up the desktop. Can you get to a failsafe terminal? If so, use,
    Code:
    icewm-session
    and that should get your prefered desktop picture up, provided you have it listed correctly in the .icewm/preference file.

    Where is the "sessions" folder in Vector? On Slackware it's at /opt/kde/share/apps/kdm/sessions. There should be a file there - icewm.desktop. Edit this and change the command within the file from "icewm" to "icewm-session" if it isn't that already. Here's mine as a reference...
    Code:
    [Desktop Entry]
    Encoding=UTF-8
    Type=XSession
    Exec=icewm-session
    TryExec=icewm-session
    Name=IceWM
    Name[af]=Icewm
    Name[eo]=GlaciFA
    {etc...}
    Linux Mint + IceWM Registered: #371367 New Members: click here

  11. #10
    Linux Guru bryansmith's Avatar
    Join Date
    Nov 2004
    Location
    /Ontario/Canada
    Posts
    2,619
    I have since removed VectorLinux from my HD. It proved pointless to have it along side Suse which I use most of the time. Thanks anyway guys for your help. I appreciate it.

    Bryan
    Looking for a distro? Look here.
    "There can be no doubt that all our knowledge begins with experience." - Immanuel Kant (Critique of Pure Reason)
    Queen's University - Arts and Science 2008 (Sociology)
    Registered Linux User #386147.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •