Find the answer to your Linux question:
Results 1 to 3 of 3
i'm trying to use the Nvidia AGP driver instead of Agpgart. i've added: Code: Option "NvAgp" "1" ...to my xorg.conf. However, in order to get it to work i need ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux User PsypherPunk's Avatar
    Join Date
    Jan 2005
    Location
    Leeds, UK
    Posts
    257

    Nvidia AGP


    i'm trying to use the Nvidia AGP driver instead of Agpgart. i've added:

    Code:
    Option "NvAgp" "1"
    ...to my xorg.conf. However, in order to get it to work i need to do the following:

    Code:
    rmmod via_agp nvidia
    rmmod agpgart
    ...and then restart X. i've tried adding the above entries to /etc/hotplug/blacklist but they're still loaded at bootup. Is there some other way to unload agpgart at startup?
    Registered Linux User #379728

    SuSE 10.3 :: Athlon XP 3000+ :: AsRock K7VT4A Pro :: Nvidia Geforce 6600GT :: C-Media 8738

    www.psypherpunk.org.uk

  2. #2
    Linux User
    Join Date
    Aug 2005
    Location
    Italy
    Posts
    401
    Remove hotplug?
    When using Windows, have you ever told "Ehi... do your business?"
    Linux user #396597 (http://counter.li.org)

  3. #3
    Linux Engineer
    Join Date
    Mar 2005
    Posts
    1,431
    I know some kernels enable loading modules when thei're needed... In that case, I dont think hotplug is involved at all. About other ways of preventing the loading:

    1) I belive you can change this in /etc/modprobe.conf or /etc/modules.conf

    2) Make a rc-script, I belive in /etc/rc.d on slack, and make it automaticly execute. The script should be created to automaticly unload the modules.

    3) Roll your own kernel, don't compile agp support as either module _OR_ built-in.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •