Find the answer to your Linux question:
Results 1 to 2 of 2
I'm trying to get the dual-head working on my GeForce4 ti4400 on Mandrake 9.2. I don't think i totally understand what they're trying to say with configuring the XF86Config-4 file. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2003
    Location
    Milwaukee, WI
    Posts
    19

    Nvidia TwinView XF86Config-4 problems


    I'm trying to get the dual-head working on my GeForce4 ti4400 on Mandrake 9.2. I don't think i totally understand what they're trying to say with configuring the XF86Config-4 file. I get an error when trying to start X with the other screen enabled. I know the driver itself is working because when I startx i see the nvidia logo. Here i a copy of my XF86Config-4 and below that is what error I get. Some stuff is cut out that didn't really have anything to do with it, but I think this is all the information I have that you could use to help me.
    Code:
    # File generated by XFdrake.
    
    # **********************************************************************
    # Refer To The XF86Config man page for details about the format of
    # this file.
    # **********************************************************************
    
    Section "Files"
        # Multiple FontPath entries are allowed (they are concatenated together)
        # By default, Mandrake 6.0 and later now use a font server independent of
        # the X server to render fonts.
        FontPath "unix/:-1"
    EndSection
    
    Section "ServerFlags"
        #DontZap # disable <Crtl><Alt><BS> &#40;server abort&#41;
        AllowMouseOpenFail # allows the server to start up even if the mouse doesn't work
        #DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> &#40;resolution switching&#41;
    EndSection
    
    Section "Module"
        Load "dbe" # Double-Buffering Extension
        Load "v4l" # Video for Linux
        Load "extmod"
        Load "type1"
        Load "freetype"
        Load "glx" # 3D layer
    EndSection
    
    Section "InputDevice"
        Identifier "Keyboard1"
        Driver "Keyboard"
        Option "XkbModel" "pc105"
        Option "XkbLayout" "en_US"
        Option "XkbOptions" ""
    EndSection
    
    Section "InputDevice"
        Identifier "Mouse1"
        Driver "mouse"
        Option "Protocol" "IMPS/2"
        Option "Device" "/dev/usbmouse"
        Option "ZAxisMapping" "4 5"
    EndSection
    
    Section "Monitor"
        Identifier "monitor1"
        VendorName "Generic"
        ModelName "Flat Panel 1280x1024"
        HorizSync 31.5-67
        VertRefresh 50-75
        
        # Sony Vaio C1&#40;X,XS,VE,VN&#41;?
        # 1024x480 @ 85.6 Hz, 48 kHz hsync
        ModeLine "1024x480"    65.00 1024 1032 1176 1344   480  488  494  563 -hsync -vsync
        
        # TV fullscreen mode or DVD fullscreen output.
        # 768x576 @ 79 Hz, 50 kHz hsync
        ModeLine "768x576"     50.00  768  832  846 1000   576  590  595  630
        
        # 768x576 @ 100 Hz, 61.6 kHz hsync
        ModeLine "768x576"     63.07  768  800  960 1024   576  578  590  616
    EndSection
    
    Section "Device"
        Identifier "device1"
        VendorName "NVidia"
        BoardName "NVIDIA GeForce4 &#40;generic&#41;"
        Driver "nvidia"
        Option "DPMS"
        #Option "TwinView" "on"
        #Option "SecondMonitorHorizSync" "31.5-67"
        #Option "SecondMonitorVertRefesh" "50-60"
        #Option "MetaModes" "1024x768, 1024x768"
    EndSection
    
    Section "Screen"
        Identifier "screen1"
        Device "device1"
        Monitor "monitor1"
        DefaultColorDepth 24
        
        Subsection "Display"
            Depth 8
            Virtual 1280 1024
        EndSubsection
        
        Subsection "Display"
            Depth 15
            Virtual 1280 1024
        EndSubsection
        
        Subsection "Display"
            Depth 16
            Virtual 1280 1024
        EndSubsection
        
        Subsection "Display"
            Depth 24
            Virtual 1280 1024
        EndSubsection
    EndSection
    
    Section "ServerLayout"
        Identifier "layout1"
        InputDevice "Keyboard1" "CoreKeyboard"
        InputDevice "Mouse1" "CorePointer"
        Screen "screen1"
    EndSection
    And here is basically what it says when I startx.

    [code[
    (EE) NVIDIA(0): Failure to construct a valid mode list: no modes remaining.
    (EE) NVIDIA(0): ************** Aborting **************
    (EE) Screen(s) found, but none have a useable configuration.

    Fatal Server Error:
    no screens found
    [/code]

    Thanks a lot for any help.

  2. #2
    Just Joined!
    Join Date
    Jul 2003
    Location
    Milwaukee, WI
    Posts
    19
    Is there no one that uses twinview? What does your XF86Config-4 look like? Can someone at least post that to see if there's something I'm doing wrong? Posted on 3 board and no replies.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •