Find the answer to your Linux question:
Results 1 to 5 of 5
[I posted this originally in the Fedora Core forum, but was directed to the X Window forum for the reason that my problems here are not specific to Fedora.] These ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Enthusiast
    Join Date
    Aug 2005
    Posts
    542

    Numerous GNOME Issues


    [I posted this originally in the Fedora Core forum, but was directed to the X Window forum for the reason that my problems here are not specific to Fedora.]
    These are just some small, but very annoying, problems I am having with Fedora Core 4.
    1.) Whenever I log in, I get an error message saying that the system could not look up the address for localhost and that I should edit the file /etc/hosts and add localhost.localdomain to it. Then it says that without doing this GNOME may not work correctly -- but then I just press "log in anyway" and all is well. Any ideas?
    2.) When I am logged in to GNOME, sometimes the desktop icon for my USB memory stick appears, and sometimes it doesn't. Then at times it appears after five minutes. It's automounted all the time so I don't know what the problem is.
    3.) Sometimes when I log in the desktop icons are strewn all over the place. Is there a way to automatically clean up the desktop every time I log on?

  2. #2
    Linux Engineer
    Join Date
    Mar 2005
    Posts
    1,431
    1) Edit the file /etc/hosts as root, and look for the 127.0.0.1 line. Add localhost.localdomain to it, and you'll be fine. This is how my line in the file looks like:
    Code:
    127.0.0.1       gentoo.lan gentoo localhost
    2) Can you post your /etc/fstab? Did you remember to unmount the pendrive before unplugging it (right-click --> umount drive or something like that). Is the pendrive icon available in My Computer?

    3) This often happens if you switch between kde and gnome... Isn't there an "align to grid" option or something like that in gnome too?

  3. #3
    Linux Enthusiast
    Join Date
    Aug 2005
    Posts
    542
    1) Edit the file /etc/hosts as root, and look for the 127.0.0.1 line. Add localhost.localdomain to it, and you'll be fine. This is how my line in the file looks like:
    Code:
    127.0.0.1       gentoo.lan gentoo localhost
    Thanks... no problem with that now
    2) Can you post your /etc/fstab? Did you remember to unmount the pendrive before unplugging it (right-click --> umount drive or something like that). Is the pendrive icon available in My Computer?
    Here's my fstab:
    Code:
    # This file is edited by fstab-sync - see 'man fstab-sync' for details
    /dev/VolGroup00/LogVol00 /                       ext3    defaults        1 1
    LABEL=/boot             /boot                   ext3    defaults        1 2
    /dev/devpts             /dev/pts                devpts  gid=5,mode=620  0 0
    /dev/shm                /dev/shm                tmpfs   defaults        0 0
    /dev/proc               /proc                   proc    defaults        0 0
    /dev/sys                /sys                    sysfs   defaults        0 0
    /dev/VolGroup00/LogVol01 swap                    swap    defaults        0 0
    /dev/sda1               /media/UDISK_20X        vfat    pamconsole,exec,noauto,managed 0 0
    /dev/fd0                /media/floppy           auto    pamconsole,exec,noauto,managed 0 0
    /dev/hdd4               /media/zip              auto    pamconsole,exec,noauto,managed 0 0
    /dev/hdc                /media/cdrecorder       auto    pamconsole,exec,noauto,managed 0 0
    I never unplug the memory key (it's really just my backup drive). And it is always visible in my computer. (If you need to know, in the fstab file, my memory key is "/dev/sda1")
    3) This often happens if you switch between kde and gnome... Isn't there an "align to grid" option or something like that in gnome too?
    Ahh... thanks.
    So the only problem left now is my memory key icon

  4. #4
    Linux Engineer
    Join Date
    Mar 2005
    Posts
    1,431
    Can you try changing this:
    Code:
    /dev/sda1               /media/UDISK_20X        vfat    pamconsole,exec,noauto,managed 0 0
    to this:
    Code:
    /dev/sda1               /media/UDISK_20X        vfat    pamconsole,exec,noauto,managed,users 0 0

  5. #5
    Linux Enthusiast
    Join Date
    Aug 2005
    Posts
    542
    Done. I can't really tell you if that worked since the problem is spontanious but if you don't hear back from me you'll know it did.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •