Find the answer to your Linux question:
Results 1 to 4 of 4
I'm using Fluxbox 0.9.11 with Debian 3.1. The problem is that I use a very high resolution display, and so I want to use large 18 point fonts. I've tried ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux User IsaacKuo's Avatar
    Join Date
    Feb 2005
    Location
    Baton Rouge, LA, USA
    Posts
    406

    How to change Fluxbox fonts?


    I'm using Fluxbox 0.9.11 with Debian 3.1. The problem is that I use a very high resolution display, and so I want to use large 18 point fonts.

    I've tried copying/modifying the "Clean" theme as a starting point (as root). I can successfully modify many things, but nothing I do to change the fonts works one bit. I've tried using xfontsel to come up with a fontname, but it doesn't work at all.

    Any ideas? Has anyone here successfully changed the fonts used? Thanks!

    [edit: added:]
    I have found that by turning "anti-aliasing" off, that I can get some fonts to work, like Courier and Helvetica. I still haven't gotten any anti-aliased fonts to work.
    Isaac Kuo, ICQ 29055726 or Yahoo mechdan

  2. #2
    Linux Guru fingal's Avatar
    Join Date
    Jul 2003
    Location
    Birmingham - UK
    Posts
    1,539
    I saw that you didn't get a reply to your question, so I tried my Google skills and found this link.

    It mentions that you can open up your theme in a text editor and change the font size in there. This may help ... On the other hand
    I am always doing that which I can not do, in order that I may learn how to do it. - Pablo Picasso

  3. #3
    Linux User IsaacKuo's Avatar
    Join Date
    Feb 2005
    Location
    Baton Rouge, LA, USA
    Posts
    406
    Thanks! That worked perfectly!

    The relevant part was:
    Look for a line like this:

    *font: somefont-bold-12

    and change it to

    *font: Luxi Sans:size=9
    Unfortunately, the font setting syntax for anti-aliased and non-anti-aliased fonts are completely different. If the setting works with anti-aliasing turned on, it won't work with anti-aliasing turned off (and vice-versa).

    Oh well, I'll just leave anti-aliasing turned on. This lets me match fonts with my applications.

    Thanks again!
    Isaac Kuo, ICQ 29055726 or Yahoo mechdan

  4. #4
    Linux Guru fingal's Avatar
    Join Date
    Jul 2003
    Location
    Birmingham - UK
    Posts
    1,539
    Hello - Pleased that worked. Anti-aliasing generally makes your fonts look smoother (as you will know) ...

    Great stuff
    I am always doing that which I can not do, in order that I may learn how to do it. - Pablo Picasso

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •