Find the answer to your Linux question:
Results 1 to 4 of 4
I don't think it would be an exaggeration to say that I've spent 30 hours of my life trying to get the drivers for my Radeon 9800 Pro to work ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    May 2004
    Location
    Boston, MA
    Posts
    246

    ATI Radeon drivers for Xorg


    I don't think it would be an exaggeration to say that I've spent 30 hours of my life trying to get the drivers for my Radeon 9800 Pro to work out. I've read every howto I could find on the subject over and over, tried every different permutation I could think of; I've really just done everything I could do.

    All I really want is to expand my screen resolution to 1200x1024. However, despite that being listed as a mode in /etc/xorg.conf, X still loads up in 1024x768, and 1200x1024 is not listed as an option in the KDE Control Center. I've made sure that the correct monitor resolution is selected in my kernel.

    The closest I've come to success was a few hours ago. Here's a summary of the process:

    I successfully built the fglrx.ko module from ATI's website and installed it in /lib/modules/fglrx. However, when I attempted to load it,
    Code:
    # modprobe fglrx
    FATAL: Module fglrx not found.
    and
    Code:
    # insmod /lib/modules/fglrx/fglrx.ko
    insmod: error inserting '/lib/modules/fglrx/fglrx.ko': -1 Operation not permitted
    I assumed this was happening because I already had the Radeon driver from the kernel loaded. But imagine my surprise when this happened!
    Code:
    # lsmod | grep radeon
    #
    Wait a minute... is fglrx even getting looked at?
    Code:
    # depmod -av | grep fglrx
    #
    At this point I passed out from frustration, and when I regained conscious a few minutes ago I decided to ask this question on Linux Forums Dot Org. I'm not going to give up this time! I'm going to make this work, damn it!

    Here's some information about my system, to help you understand the situation:
    • Distro: Slackware 10
    • Kernel: 2.6.14.2
    • CPU: Athlon 64
    • Video card: ATI Radeon 9800 Pro
    I'll be thankful for anything you can think of.

  2. #2
    Linux Engineer
    Join Date
    Jan 2005
    Location
    Chicago (USA)
    Posts
    1,028
    Make sure you're root when doing those.

  3. #3
    Linux Newbie
    Join Date
    May 2004
    Location
    Boston, MA
    Posts
    246
    Oh, yeah, I was root the whole time.

    Thanks, though.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Oct 2005
    Location
    Mesquite TX USA
    Posts
    6

    Did you ever get it?

    As of you last post where you got an operation not permitted error. Be sure that SELinux is disabled. Otherwise there are things even root can't do.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •