Find the answer to your Linux question:
Results 1 to 10 of 10
So, I've just switched to linux again, now that I finally have enough time on my hands to actually dig in and figure out how things work, and most all ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2005
    Location
    Seattle, WA
    Posts
    6

    Gnome crash...where to start?


    So, I've just switched to linux again, now that I finally have enough time on my hands to actually dig in and figure out how things work, and most all is well except for one problem.

    I can't run openoffice or winecfg without gnome crashing. (I've also just found that Neverputt crashes it too). It looks like it's loading them for a few seconds, then goes back to the terminal (showing whatever is on it last, but no errors) and then takes me back to the gui login screen.

    I've tried running winecfg on the command line and I get a long line of errors that repeat on forever. They seem to be related to object drawing errors. One of them is
    Code:
    err:imagelist:ImageList_ReplaceIcon no color!
    The others have to do with stretchbit and getbitmapbits.

    I've searched all over, but I can't figure out where I need to start to trackdown the source of this error. I tried to install gnomecrash thinking that might help, but it gives me the error:
    Code:
    checking for gnome_window_icon_set_default_from_file in -lgnomeui... no
    configure: error: gnome-libs 1.0.60 or higher is required.
    But I know gnome-libs (and gnome-libs-dev) are installed and are much more recent versions than that.

    Can anyone point me in the right direction here?

  2. #2
    Linux Enthusiast Weedman's Avatar
    Join Date
    May 2005
    Location
    Tasmania, Australia
    Posts
    640
    what distro are you using?
    "Time has more than one meaning, and is more than one dimension" - /.unknown
    --Registered Linux user #396583--

  3. #3
    Just Joined!
    Join Date
    Dec 2005
    Location
    Seattle, WA
    Posts
    6
    Oh right... the important details... sorry.

    I'm using Suse 10.0 OSS. Gnome 2.12.0.

  4. #4
    Linux Enthusiast Weedman's Avatar
    Join Date
    May 2005
    Location
    Tasmania, Australia
    Posts
    640
    Quote Originally Posted by TVSeaOtter
    Oh right... the important details... sorry.
    thats alright.

    i, have had no experience with suse, so i cannot be 100% certain if the below will work.

    the error seams to say to me that it looks like there is something wrong with the x server OR a lib that is used for drwing textures.

    to be certian, see if you can get a quick lite WM installed (fluxbox etc.) and see if it works. If i doesnt, its the x server. If it does, than it is ore than likely gnome.

    my quick 2 cents

    edit: when you said you ran winecfg in the command line, did you mean with gnome in the background or did you mean the command line where gnome is not running?
    /weedinux
    "Time has more than one meaning, and is more than one dimension" - /.unknown
    --Registered Linux user #396583--

  5. #5
    Just Joined!
    Join Date
    Dec 2005
    Location
    Seattle, WA
    Posts
    6
    winecfg does the looping errors when run without gnome in the background. When run with gnome in the background it does the crashing stuff. I'm assuming from your question that it has to be run with x and therefor those errors are standard and no help at all in getting closer to the problem.

    I tried running these programs in a VM and I get the exact same thing, except sometimes instead of the blank screen before the login manager comes back up, there is a bit of text at the top, some double arrows, some z's with accents, a couple of reversed question marks, stuff like that.

  6. #6
    Linux Enthusiast Weedman's Avatar
    Join Date
    May 2005
    Location
    Tasmania, Australia
    Posts
    640
    i would say that you need to reconfigure x.

    try typing
    Code:
    xorgconfig
    from the command line (without x running).

    and answer all the questions that come up. From what you are saying x is giving you errors before you start it. reconfiguring it should help.

    just make sure you backup your xorg.conf file first
    Code:
    su
    password:
    cd /etc/X11
    cp xorg.conf xorg.conf.backup
    xorgconfig
    "Time has more than one meaning, and is more than one dimension" - /.unknown
    --Registered Linux user #396583--

  7. #7
    Just Joined!
    Join Date
    Dec 2005
    Location
    Seattle, WA
    Posts
    6
    Well, I'm making progress, but I'm still lost.

    I tried to run xorgconfig, but that made it so that x couldn't start at all. However, it also stopped gdm from starting, which let me start x from the command line and I was thus able to see the errors it's giving when I start open office.

    Here's the output from x:
    Code:
    xauth:  creating new authority file /root/.serverauth.4448
    
    
    X Window System Version 6.8.2
    Release Date: 9 February 2005
    X Protocol Version 11, Revision 0, Release 6.8.2
    Build Operating System: SuSE Linux [ELF] SuSE
    Current Operating System: Linux scofie-x01 2.6.13-15.7-smp #1 SMP Tue Nov 29 14:32:29 UTC 2005 i686
    Build Date: 07 October 2005
    	Before reporting problems, check http://wiki.X.Org
    	to make sure that you have the latest version.
    Module Loader present
    Markers: (--) probed, (**) from config file, (==) default setting,
    	(++) from command line, (!!) notice, (II) informational,
    	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (==) Log file: "/var/log/Xorg.0.log", Time: Wed Dec 21 23:16:45 2005
    (==) Using config file: "/etc/X11/xorg.conf"
    Could not init font path element /usr/X11R6/lib/X11/fonts/local, removing from list!
    Could not init font path element /usr/X11R6/lib/X11/fonts/CID, removing from list!
    /etc/X11/xim: Checking wether an input method should be started.
    INPUT_METHOD is not set or empty (no user selected input method).
    Trying to start a default input method for the locale en_US.UTF-8 ...
    There is no default input method for the current locale.
    You can not run beagle as root.
    Beagle is designed to be run from your own user account.
    Beagle Daemon exited with errors.  See ~/.beagle/Log/current-Beagle for more details.
    SESSION_MANAGER=local/scofie-x01:/tmp/.ICE-unix/4481
    esd: Esound sound daemon already running or stale UNIX socket
    /tmp/.esd/socket
    This socket already exists indicating esd is already running.
    Exiting...
    
    ** (gnome-session:4481): WARNING **: Esound failed to start.
    
    
    Unhandled Exception: System.DllNotFoundException: libgeckoglue.so
    in (wrapper managed-to-native) Beagle.Util.GeckoUtils:blam_gecko_utils_init_services ()
    in <0x00007> Beagle.Util.GeckoUtils:Init ()
    in <0x000a2> Best.Best:Main (System.String[] args)
    manager.c/558: setting[0]: bool: autobrowse = 1
    manager.c/558: setting[1]: bool: autoburn = 1
    manager.c/553: setting[2]: string: autoburn_audio_cd_command = banshee
    manager.c/553: setting[3]: string: autoburn_data_cd_command = nautilus --no-desktop burn:
    manager.c/558: setting[4]: bool: autoipod = 1
    manager.c/553: setting[5]: string: autoipod_command = banshee
    manager.c/558: setting[6]: bool: automount_drives = 1
    manager.c/558: setting[7]: bool: automount_media = 1
    manager.c/558: setting[8]: bool: autopalmsync = 0
    manager.c/553: setting[9]: string: autopalmsync_command = 
    manager.c/558: setting[10]: bool: autophoto = 1
    manager.c/553: setting[11]: string: autophoto_command = f-spot-import %h
    manager.c/558: setting[12]: bool: autoplay_cda = 1
    manager.c/553: setting[13]: string: autoplay_cda_command = banshee
    manager.c/558: setting[14]: bool: autoplay_dvd = 1
    manager.c/553: setting[15]: string: autoplay_dvd_command = totem %d
    manager.c/558: setting[16]: bool: autoplay_vcd = 1
    manager.c/553: setting[17]: string: autoplay_vcd_command = totem %d
    manager.c/558: setting[18]: bool: autoprinter = 1
    manager.c/553: setting[19]: string: autoprinter_command = gnome-printer-add hal://%h
    manager.c/558: setting[20]: bool: autorun = 0
    manager.c/553: setting[21]: string: autorun_path = .autorun:autorun:autorun.sh
    manager.c/553: setting[22]: string: eject_command = /bin/eject %d
    Initializing nautilus-open-terminal extension
    kbuildsycoca running...
    This is the point where I try to start openoffice.
    Code:
    DCOP Cleaning up dead connections.
    
       *** If unresolved symbols were reported above, they might not
       *** be the reason for the server aborting.
    
    Fatal server error:
    Caught signal 11.  Server aborting
    
    
    Please consult the The X.Org Foundation support 
    	 at http://wiki.X.Org
     for help. 
    Please also check the log file at "/var/log/Xorg.0.log" for additional information.
    
    The application 'gnome-session' lost its connection to the display :0.0;
    most likely the X server was shut down or you killed/destroyed
    the application.
    The application 'netapplet' lost its connection to the display :0.0;
    most likely the X server was shut down or you killed/destroyed
    the application.
    Window manager warning: Lost connection to the display ':0.0';
    most likely the X server was shut down or you killed/destroyed
    the window manager.
    The application 'gnome-panel' lost its connection to the display :0.0;
    most likely the X server was shut down or you killed/destroyed
    the application.
    The application 'nautilus' lost its connection to the display :0.0;
    most likely the X server was shut down or you killed/destroyed
    the application.
    susewatcher: Fatal IO error: client killed
    The application 'gnome-volume-manager' lost its connection to the display :0.0;
    most likely the X server was shut down or you killed/destroyed
    the application.
    The application 'resapplet' lost its connection to the display :0.0;
    most likely the X server was shut down or you killed/destroyed
    the application.
    The application 'soffice.bin' lost its connection to the display :0.0;
    most likely the X server was shut down or you killed/destroyed
    the application.
    kded: Fatal IO error: client killed
    kdeinit: Fatal IO error: client killed
    xinit:  connection to X server lost.
    
    klauncher: Exiting on signal 15
    I've tried searching wiki.X.org and google, but none of the signal 11 problems seem to be quit the same as mine. I can't see anything in the Xorg.0.conf log, but I'm not sure what I'm looking for.

    To clarify where I am right now: when suse boots, it takes me to gdm which puts me into gnome (or the wm of my choosing) which runs normally. I can run most programs without issue. When I try to run openoffice, winecfg or Neverputt, x crashes with a signal 11 error. I have two video cards currently in use, an ati rage 128 using r128 drivers and a geforce4 mx 4000 using nvidia drivers.

  8. #8
    Linux Enthusiast Weedman's Avatar
    Join Date
    May 2005
    Location
    Tasmania, Australia
    Posts
    640
    Quote Originally Posted by TVSeaOtter
    To clarify where I am right now: when suse boots, it takes me to gdm which puts me into gnome (or the wm of my choosing) which runs normally. I can run most programs without issue. When I try to run openoffice, winecfg or Neverputt, x crashes with a signal 11 error. I have two video cards currently in use, an ati rage 128 using r128 drivers and a geforce4 mx 4000 using nvidia drivers.
    Thats it then. The drivers are conflicting when you start certain apps. i would remove one of the gpu's or use 2 that are the same brand.

    take one of them out and try running a app that usually crashes. if the error doesnt come up, then you need to get rid of one of the cards.

    if it still gives you the error, then we are back to square 1.

    but why would you be using a ati and nvidia graphics card in the same system?
    "Time has more than one meaning, and is more than one dimension" - /.unknown
    --Registered Linux user #396583--

  9. #9
    Just Joined!
    Join Date
    Dec 2005
    Location
    Seattle, WA
    Posts
    6
    Quote Originally Posted by Weedman
    but why would you be using a ati and nvidia graphics card in the same system?
    Well, the main reason is that I really like having three (the geforce has two outputs) monitors for space (in windows anyway, I haven't investigated whether the same is possible in linux yet), the second reason is that the ati card has tv input for watching tv, but the geforce card has much better graphics for playing games and watching movies. I haven't even bothered to turn on any but the main center monitor since I installed linux though... I should try that.

    Now that I have I see that the ati card is displaying another gnome desktop which I don't seem to have access to... and the second port on the geforce is displaying an exact replica of the first port. Interesting.

    Anyway, I'll try disabling both of them one at a time and see where that gets me... thanks for the idea though, it didn't occur to me to even try that. There's so much to learn.

  10. #10
    Just Joined!
    Join Date
    Dec 2005
    Location
    Seattle, WA
    Posts
    6
    Yeah... that took care of it. Don't I feel silly now. I'm just so used to taking it for granted that windows is back there taking care of that sort of thing, that it never occured to me it would be causing trouble in linux. I've got so much to learn. Thanks so much for the help!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •