Find the answer to your Linux question:
Results 1 to 6 of 6
Whatever I try artwiz fonts will not work. I have googled and googled but still have not come up with a solution. This is what I have done so far: ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2005
    Posts
    9

    frustrating artwiz font problems


    Whatever I try artwiz fonts will not work. I have googled and googled but still have not come up with a solution.

    This is what I have done so far:
    unpacked tar archine into /usr/lib/X11/fonts
    ran fc-cache -fv in artwiz font dir
    added font path to xorg.conf
    added entry in /etc/fonts/local.conf
    added export LC=C to .bashrc
    added explort LC_ALL=C to .bashrc

    all artwiz fonts show up in xfontsel but are not availible to the system.

    sytem: latest realese of Debian Sarge
    window manager: fluxbox

    Any ideas would be greatly appreciated.

  2. #2
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    I've never used the artwiz fonts so can't say for sure, but you might want to take a look at this wiki. It's really for Gentoo, but there might be something in it that will give you a clue to the problem:

    http://gentoo-wiki.com/HOWTO_Xorg_and_Fonts

    Hope it helps.

  3. #3
    Just Joined!
    Join Date
    Jun 2005
    Posts
    9
    Thanks for the reply.

    I will have a read of that article. Perhaps if i research X font support a bit more a solution may be found.

  4. #4
    Just Joined!
    Join Date
    Jun 2005
    Posts
    9
    Finally. I have got them to work

    Apparently the Debian binary of fontconfig does not support bitmap fonts by default. To enable bitmap fonts on a Debian system simply:
    dpkg-reconfigure fontconfig

    and answer all the questions

  5. #5
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    Hey, glad you got it working and thanks for reporting back with the fix. Lots of users fail to do that.

  6. #6
    Just Joined!
    Join Date
    Apr 2006
    Posts
    1
    I just found this thread with google, and tried setting up xfonts-artwiz on Debian Etch.
    Unfortunately the suggested method (running `dpkg-reconfigure fontconfig`) didn't work.
    So I looked around for a while and noticed that I also had fontconfig-config installed.
    So I tried to reconfigure that, and it worked! I could enable bitmap support yada-yada.
    Hopefully this'll help people solve any future problems >.<

    Btw; I signed up just for this
    Btw; Thanks for this thread in the first place!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •