Find the answer to your Linux question:
Results 1 to 5 of 5
i have a server running suse 10 that i would like to control from a windows laptop (or a mac, but i'd prefer the laptop). I've done everything i can ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2006
    Posts
    9

    Suse VNC windows issues...


    i have a server running suse 10 that i would like to control from a windows laptop (or a mac, but i'd prefer the laptop). I've done everything i can find to try to get it to work but at this point I get 'no response' errors from any VNC viewer program (real, tight, ultr@), or in a few cases the dialog box from tightvnc etc. just disappears when i hit ok, and the program continues running according to the task manager, however there is no evidence of it elsewhere. I thought this strange, and then after restarting the linux machine there was a message stating that thte connection to linux:1 was dropped.

    I've set up everything in linux i can find, including temporarily turning off the firewalls (on both machines), configuring vncpasswd, the whole -24 1024x768 etc. commands, which all seemed to work, as well as setting up the remote desktop all over the place, in yast, regular control center, etc. The firewall has exceptions for remote desktop, and i ran the command that gives you the correct input for the viewing vnc program (linux:2 should have worked). anyway, this was actually just an experimental installation of linux instead of windows, but i can't keep dragging a monitor mouse and keyboard around.

    the computers see eachother just fine, they ping and actually i have network drives working well and sharing nicely on the linux machine. It's just that when i type in linux:2 or whatever it told me its address was, i get nothing. I tried linux::5900 and even setting the port to be static on the linux machine, but nothing, not any response at all.

    thanks for any help, and if you think i just screwed this installation up too much and should start over, that's possible, this is just an experimental old drive. a nice step by step guide meant for suse 10 would be handy, i figured out a bunch of complications with samba thanks to great tutorials, but can't find anything to help with windows control via VNC of suse10.

  2. #2
    Just Joined!
    Join Date
    Jan 2006
    Posts
    9
    well, i just happened to have a work computer tonight and decided to abuse my privileges and see if i can get it to work, and howdy-doodie, it worked, so the problem isn't with linux at all, must be windows *holds head in hands and sobs*, so i'll be having fun figuring out that problem...i might try turnin goff remote assistance and fast user switching, i read somewhere those might be related?

  3. #3
    Super Moderator Roxoff's Avatar
    Join Date
    Aug 2005
    Location
    Nottingham, England
    Posts
    3,882
    Cant you just uninstall windows and do the whole thing (client and server) on separate Linux machines?
    Linux user #126863 - see http://linuxcounter.net/

  4. #4
    Linux User DThor's Avatar
    Join Date
    Jan 2006
    Location
    Ca..na...daaa....
    Posts
    319
    Trying to stay inside your parameters of using an existing windows system, yes, this sort of stuff has some serious mojo working for it. From what I've been told, once you do it a few times, it's fine, but getting over that initial hump is a bugger. I've struggled with exactly this, through our outside firewall tunneling X through ssh...whee! Only limited success. Haven't found the time to get this going all the way, yet.

    Apart from blowing your brains out googling and sifting through dated distro references, if this is something you really want a handhold through from someone experienced, you might want to look into OReilly's Linux Server Hacks Vol 2. It's got chapters specifically targetting this topic, with walkthroughs. It's a great book, too...

    When I have the time, I was going to follow their guide on this topic.

    DT

  5. #5
    Just Joined!
    Join Date
    May 2006
    Posts
    1

    VNC on already installed SLES 9

    Hello guys,

    I have already installed SLES 9 on remote server. Before I controlled it through SSH. But now I need to reinstall Oracle so it will be cool if somebody suggests any solution to get Desktop access from my Windows operating system. I tryed XWin32 but I couldn't do with it. Do someone have workable instructions?
    Or do someone know how to integrate VNC with my SLES? Note that I can't install SLES with parameter vnc=1 etc. I need to do it on already installed SLES 9.

    Thanks for any suggestions,
    KS.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •