Find the answer to your Linux question:
Results 1 to 3 of 3
i decided to try out windowmkaer 0.92.9, after downloaded the tar and extracted, i ./configure, and after when i type "make" or "make install" from the root or the user, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2006
    Posts
    19

    window maker "make" / "make install" problem


    i decided to try out windowmkaer 0.92.9, after downloaded the tar and extracted, i ./configure, and after when i type
    "make" or "make install" from the root or the user, it always ends up with the a few of the same error lines.
    ************************************************** ************************************************** **
    x86_specific.c: In function 'x86_mmx_TrueColor_32_to_16':
    x86_specific.c:107: error: can't find a register in class 'GENERAL_REGS' while reloading 'asm'
    make[2]: *** [x86_specific.lo] Error 1
    make[2]: Leaving directory `/home/max/WindowMaker-0.92.0/wrlib'
    make[1]: *** [all-recursive] Error 1
    make[1]: Leaving directory `/home/max/WindowMaker-0.92.0/wrlib'
    make: *** [all-recursive] Error 1
    ************************************************** ************************************************** **
    i am sure someone you have seen this before, so what do i do?

  2. #2
    Banned
    Join Date
    Aug 2004
    Posts
    15
    what I would do is try an older version
    most of the time an error like this comes from a syntax error in the source
    that the compiler can't make sence out of
    it could be that your not useing the right version of gcc
    it could also be that a libaray is missing ( most of the time .configure will catch this and tell you what is missing )
    reread the README file to make sure you have evering thing and the right version of gcc or you could install a prebuilt package for your distro

  3. #3
    Just Joined!
    Join Date
    May 2006
    Posts
    1
    This issue is a problem with GCC. I just tried to compile it with version 4 and got the same error as you did. By using

    export CC=gcc-3.4

    before running configure, I was able to force configure to use the 3.4 version of GCC I also have installed on my box. I would suggest you do the same.

    Joey

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •