Find the answer to your Linux question:
Results 1 to 5 of 5
I was using a Debian install with GNOME (I installed it three days ago). Occasionally it was acting up, and I'd have to restart (things like 99% CPU usage when ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2006
    Posts
    6

    My desktop is not going


    I was using a Debian install with GNOME (I installed it three days ago). Occasionally it was acting up, and I'd have to restart (things like 99% CPU usage when I had no programs running), or the terminal or gedit wouldn't open, and things as such.
    Well, one such time it froze, after having done nothing really (I mean that I hadn't done anything to really alter anything) that session, and I rebooted.
    Upon this reboot, I was greeted with the console. GDM was running, but I couldn't get the desktop. I was left to wallow at the command line.
    I tried apt getting KDE, and I set that to default. I got the KDE login screen, after which I get the error message "Xsession: warning: unable to write to /tmp; X session may exit w/ an error", and a prompt return to the login screen.
    Any help?

    Thanks.

  2. #2
    Banned
    Join Date
    Jul 2004
    Posts
    947
    make sure /tmp is mounted as read write.
    how are you starting kdm or gdm and as what user?

    Also debian is quite old, and something might be going wrong somewhere, maybe it isnt liking your hardware setup. Maybe its an old bug in something you have installed, hence the crashing. Have you had these problems with any other distro?

  3. #3
    Just Joined!
    Join Date
    Feb 2006
    Posts
    6
    This is my first Linux install, so I guess I haven't had these problems before on another distro. I've tried starting gdm with the simple 'gdm' command, as root or a regular user, or these would start before the login. I think I'm just going to reinstall. The troubles are probably part of something I did, without knowing it. Thanks, though.

    Edit: I did a search of the error message, and tried "apt-get clean". Which solved my problem. I don't know what it did, but it seems to work now.

  4. #4
    Just Joined!
    Join Date
    Feb 2006
    Posts
    5

    Similar problem

    I've been having a similar problem. I installed debian sarge (the most current stable) recently, and by default gdm was installed. Since I don't like Gnome, I've been using KDE, and tried installing KDM as the manager.

    If I login at the KDM login screen, the screen goes black, then the login screen appears again. No error message is given.

    At the moment, I go to console login, and start GDM, but I have to do this using su, meaning I'm presumably running the window manager as root (which doesn't sound like a good idea).

    (/tmp is listed by ls -l as "drwxrwxrwt")

    Can anyone suggest a solution please?
    Edit: I'd prefer to use kdm and kde together, but gdm will probably work if i just reconfigure that.

  5. #5
    Just Joined!
    Join Date
    Aug 2006
    Posts
    1

    Debian is Mature

    [QUOTE=
    Also debian is quite old, [/QUOTE]

    ?!?!?!

    Debain is an excellent distro of Linux with a large and active community. You should be looking for a mature distro if you are using Linux for anything relevant. 'Old' implies obsolete, which Debian is far from.

    To answer the question try logging in under 'failsafe' and run 'apt-get clean' from your terminal

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •