Find the answer to your Linux question:
Results 1 to 5 of 5
Hey guys, i figured out my problem with XMMS and kde, i've been logging in under another name and not root to get into kde, so when i start up ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2004
    Location
    Chicago,IL
    Posts
    16

    Sound Server problem.... Probably a really easy fix..


    Hey guys, i figured out my problem with XMMS and kde, i've been logging in under another name and not root to get into kde, so when i start up as my other regular username i've been using for weeks now, i get this error from KDE, when it gets to initializing desktop.


    Sound Server Warning Message.
    Can't set real time scheduling priority. Yo need to run artswrapper as root or setuid root. This means you will likely not be able to produce acceptable sound.


    Now, how would i go about fixing this so my other username can use xmms? I'm assuming it's a permissions problem. When i login to kde as root as i am right now, xmms works and plays like a champ! how can i get it to work under my other login name? Anyone can help me?

  2. #2
    Linux Engineer kriss's Avatar
    Join Date
    Jun 2003
    Posts
    1,113
    As root, try to do this:

    ps aux | grep artsd

    And if the process belongs to root, its clogging up the soundcard, so you just kill it and it should be freed.

    But its also not recomended to use soundservers, (or atleast it wasn't, I'm shure it has made some progress) because it will/used to produce lesser sound than without a soundserver.

    IIRC Alan Cox has made some quite andry comments about soundservers.

    Good luck

  3. #3
    Linux Engineer
    Join Date
    Dec 2002
    Location
    New Zealand
    Posts
    766
    u could pick another xmms output plugin (instead of artsd) or u could set artswrapper to suid liek the message says, this is probably the better of the 2 options as it will fix the rest of KDE as well.

    Code:
    su
    **enter root password
    whereis artswrapper
    **output will be somethign like /usr/bin/artswrapper, use ur output in next line
    chmod +s /usr/bin/artswrapper
    and thats it. artswrapper is now suid, so it can run realtime priority.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Jan 2004
    Location
    Chicago,IL
    Posts
    16
    Hey Hellmasker, i ran the command, and when i login to kde, it doesn't give me the error it was giving me previously.........

    But now, when i try to run xmms it still doesn't let me play any kind of sound. it's the same ole' problem, it still locks up and doesn't do anything.

    Now, How could i run this without a sound server? What is my alternative to this, how would i implement that? Please i would love to get this problem fixed sometime soon, this is giving me hell! i just want some ******* sound!

    Thanks for the help guys! I dont know where i'd be without all your guys's help!

  6. #5
    Just Joined!
    Join Date
    Jan 2004
    Location
    Chicago,IL
    Posts
    16
    well, when i logged in as my other user, (non-root) i used k sysguard and killed the artsd process, and voila, sound works! Thanks folks!

    greatly appreciated.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •