Find the answer to your Linux question:
Results 1 to 5 of 5
Hi all, After installing the latest nVidia drivers from nVidia itself (NVIDIA-Linux-x86-1.0-8756-pkg1.run), my X crashes everytime I want to do something in GL (I guess). For example I want to ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2004
    Posts
    7

    [X] after latest nVidia drivers: X crashes


    Hi all,


    After installing the latest nVidia drivers from nVidia itself (NVIDIA-Linux-x86-1.0-8756-pkg1.run), my X crashes everytime I want to do something in GL (I guess).

    For example I want to start EVE Online in Cedega... I get booted back to the login screen. Which afaik means X crashed...
    When I try to do the "test" in Cedega, X crashes at the first test (= gl test). So that's why I am thinking something in my config is not right.

    If I am not at my computer for a time - like most people - there pops up a screensaver... Which is mostly in GL I guess... So X crashes...


    I would be very happy if someone could tell me what to do . Hereby included you will find the X-config.

    Code:
    # nvidia-xconfig: X configuration file generated by nvidia-xconfig
    # nvidia-xconfig:  version 1.0  (buildmeister@builder3)  Wed Mar 29 14:43:26 PST 2006
    
    # /etc/X11/xorg.conf (xorg X Window System server configuration file)
    #
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    #
    # Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
    # (Type "man /etc/X11/xorg.conf" at the shell prompt.)
    #
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    #
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    #   sudo dpkg-reconfigure -phigh xserver-xorg
    
    Section "ServerLayout"
        Identifier     "Default Layout"
        Screen         "Default Screen" 0 0
        InputDevice    "Generic Keyboard"
        InputDevice    "Configured Mouse"
    EndSection
    
    Section "Files"
    
            # paths to defoma fonts
        FontPath        "/usr/share/X11/fonts/misc"
        FontPath        "/usr/share/X11/fonts/cyrillic"
        FontPath        "/usr/share/X11/fonts/100dpi/:unscaled"
        FontPath        "/usr/share/X11/fonts/75dpi/:unscaled"
        FontPath        "/usr/share/X11/fonts/Type1"
        FontPath        "/usr/share/X11/fonts/CID"
        FontPath        "/usr/share/X11/fonts/100dpi"
        FontPath        "/usr/share/X11/fonts/75dpi"
        FontPath        "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
        FontPath        "/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID"
    EndSection
    
    Section "Module"
        Load           "GLcore"
        Load           "i2c"
        Load           "bitmap"
        Load           "ddc"
        Load           "extmod"
        Load           "freetype"
        Load           "glx"
        Load           "int10"
        Load           "type1"
        Load           "vbe"
    EndSection
    
    Section "InputDevice"
        Identifier     "Generic Keyboard"
        Driver         "kbd"
        Option         "CoreKeyboard"
        Option         "XkbRules" "xorg"
        Option         "XkbModel" "pc105"
        Option         "XkbLayout" "be"
    EndSection
    
    Section "InputDevice"
        Identifier     "Configured Mouse"
        Driver         "mouse"
        Option         "CorePointer"
        Option         "Device" "/dev/ttyS0"
        Option         "Protocol" "microsoft"
        Option         "Emulate3Buttons" "true"
        Option         "ZAxisMapping" "4 5"
    EndSection
    
    Section "Monitor"
        Identifier     "Hercules Pro"
        Option         "DPMS"
    EndSection
    
    Section "Device"
        Identifier     "NVIDIA Corporation NV25 [GeForce4 Ti 4200]"
        Driver         "nvidia"
        BusID          "PCI:5:0:0"
    EndSection
    
    Section "Screen"
        Identifier     "Default Screen"
        Device         "NVIDIA Corporation NV25 [GeForce4 Ti 4200]"
        Monitor        "Hercules Pro"
        DefaultDepth    24
        SubSection     "Display"
            Depth       1
            Modes      "1280x1024" "1280x960" "1024x768" "832x624" "800x600" "720x400" "640x480"
        EndSubSection
        SubSection     "Display"
            Depth       4
            Modes      "1280x1024" "1280x960" "1024x768" "832x624" "800x600" "720x400" "640x480"
        EndSubSection
        SubSection     "Display"
            Depth       8
            Modes      "1280x1024" "1280x960" "1024x768" "832x624" "800x600" "720x400" "640x480"
        EndSubSection
        SubSection     "Display"
            Depth       15
            Modes      "1280x1024" "1280x960" "1024x768" "832x624" "800x600" "720x400" "640x480"
        EndSubSection
        SubSection     "Display"
            Depth       16
            Modes      "1280x1024" "1280x960" "1024x768" "832x624" "800x600" "720x400" "640x480"
        EndSubSection
        SubSection     "Display"
            Depth       24
            Modes      "1280x1024" "1280x960" "1024x768" "832x624" "800x600" "720x400" "640x480"
        EndSubSection
    EndSection

    Oh, distro = Ubuntu 5.10 with all the latest updates and stuff...


    Thanks a lot!

  2. #2
    Just Joined! Sykotik's Avatar
    Join Date
    Mar 2002
    Location
    Cape Town, South Africa
    Posts
    54
    Quote Originally Posted by NVIDIA Drivers Readme
    Remove the following lines:

    Load "dri"
    Load "GLCore"
    You still have GLCore loaded in your configuration. Mayhap that's contributing to the error?

  3. #3
    Just Joined!
    Join Date
    Dec 2004
    Posts
    7
    I will try this immediatly Hopefully it works... Although I wish it wouldn't because then I should start blaming myself for not reading the README.

    *edit*
    Sorry, it didn't work out. Still crashing all around... I will check the nVidia fora later today...

    The command "diff -u Xorg.0.log Xorg.0.log.old" reports this:
    Code:
    +
    +   *** If unresolved symbols were reported above, they might not
    +   *** be the reason for the server aborting.
    +
    +Fatal server error:
    +Caught signal 11.  Server aborting
    +
    +
    +Please consult the The X.Org Foundation support
    +        at http://wiki.X.Org
    + for help.
    +Please also check the log file at "/var/log/Xorg.0.log" for additional information.
    +

  4. #4
    Just Joined! LinuxBox420's Avatar
    Join Date
    Jan 2005
    Posts
    32
    A lot of people seem to have a problem with the new Nvidia driver on Linux. Run glxgears and see what kind of frames you're getting. When I udated mine I was only getting 200+, I re-installed the driver and now I'm getting 6000+. Try installing an older driver if that doesn't work.

  5. #5
    Just Joined!
    Join Date
    Dec 2004
    Posts
    7
    It's not that my framerate is low - hell I would be happy to have a low framerate! It's just that it crashes X everytime something about GL is started.

    You can follow this thread here: http://www.linuxquestions.org/questi...d.php?t=446816

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •