Find the answer to your Linux question:
Results 1 to 4 of 4
Hi, I'm using a Debian GNU/Linux testing and xorg with fluxbox (my desktop is meant to be lightweight). I like Num Lock on, so I set it up for both ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2006
    Location
    Czech Republic
    Posts
    36

    Question Num Lock turns off when entering X


    Hi, I'm using a Debian GNU/Linux testing and xorg with fluxbox (my desktop is meant to be lightweight). I like Num Lock on, so I set it up for both console and X (using numlockx there). It works fine, but when I switch from console to X, the LED turns off. Note that this problem is only cosmetical, as the Num Lock function remains on, it is just not shown. I wonder if anyone had this minor problem and knows how to deal with it.

  2. #2
    Linux Enthusiast scientica's Avatar
    Join Date
    Sep 2003
    Location
    South- or "Mid-" Sweden
    Posts
    742
    It seems to be some "default" thing, for some reason it seems standard to turn off numlock (or at least the led) all the time (boot, login, X start, switching vt, etc, etc) - I've never understood why it's not default to keep numlock on, but I'd guess it's some legacy from a time when (I think) not all keyboards had a numpad.
    Regards Scienitca (registered user #335819 - http://counter.li.org )
    --
    A master is nothing more than a student who knows something of which he can teach to other students.

  3. #3
    Linux Engineer Javasnob's Avatar
    Join Date
    Jul 2005
    Location
    Wisconsin
    Posts
    942
    This might not work, by try running numlockx on X startup (add it to your .xinitrc file before fluxbox).
    Flies of a particular kind, i.e. time-flies, are fond of an arrow.

    Registered Linux User #408794

  4. #4
    Just Joined!
    Join Date
    Jul 2006
    Location
    Czech Republic
    Posts
    36
    Quote Originally Posted by Javasnob
    This might not work, by try running numlockx on X startup (add it to your .xinitrc file before fluxbox).
    I tried this as well as adding the numlockx line into /etc/X11/xdm/Xsetup, but the LED keeps switching off.
    I forgot to add that when switching into a console (from X or another console), the LED state changes appropriately.
    Another thing to add is that this is not a bug in xdm, as the same behavior can be expected when X is started via startx.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •