Find the answer to your Linux question:
Results 1 to 6 of 6
I'm new to Linux, so go easy on me I'm using Redhat 9.0, and have just upgraded XFree86 to version 4.4.0. The installation went fine, but now KDE refuses to ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2004
    Posts
    1

    KDE won't start


    I'm new to Linux, so go easy on me

    I'm using Redhat 9.0, and have just upgraded XFree86 to version 4.4.0. The installation went fine, but now KDE refuses to start in level 5. I get to the logon screen, but when I try to log into KDE (or gnome for that matter) I get a popup with "choosesessionlistwidget" in it, with the options "failsafe" and "cancel" - failsafe results in it hanging and cancel takes me back to the logon screen. Typing "startx" or startkde" doesnt work either when I ctrl + alt + F2 into a command line. The best I can do at the moment is run in level 3, and start KDE from the Xserver.

    Please can you fix it for me Jim

  2. #2
    Linux Newbie
    Join Date
    Feb 2003
    Location
    Swansea (UK)
    Posts
    221
    ummmm i got an idea..... on boot of redhat select to use interactive startup.... and select the run level as 4 wehn your prompted.... this MAY work, never tried it.

  3. #3
    Just Joined!
    Join Date
    Mar 2004
    Posts
    3
    Yeah I have the same problem. Installed 4.4.0, next time I booted up it brought up the graphical login. I logged in as usual and it brought me to the TWN interface (an xterm with a small menu with a couple options).

    The 4 option didn't work, it just brings up the command line

    The only way I can get KDE to start up is with the TWN's xterm window, to do a startkde command and this only brings the desktop up within a window.

    How do I get back to having the graphical login go to KDE or Gnome?

    I don't get any errors when I run XFree86 -configure, so I copy the new configure file to the /etc/X11 directory. The problem is still there.

    There has to be some config file for startup that got overwritten during the install of 4.4.0. Any ideas?


    -Thanks all

  4. #4
    Just Joined!
    Join Date
    Mar 2004
    Posts
    3
    Ok so I struggle with this for like 3 hours, decide to post the question in this forum and then 10 mins later I figure it out....DOH!

    I fixed it by editing my /etc/X11/xinit/xinitrc

    at the bottom it read

    # start some nice programs
    twn
    xclock -geometry 50x50-1+1 &
    xterm -geometry 80x50+494+51 &
    xterm -geometry 80x20+494-0 &
    exec xterm -geometry 80x66+0+0 -name login


    which I replaced with

    # start some nice programs
    gnome-session


    although instead you could probably put startkde or one of the windows managers (xdm,kdm,gdm,...).

    The file must have been overwriiten in the upgrade

    Oh well atleast it is fixed now.

    -Nic

  5. #5
    Linux Engineer
    Join Date
    Dec 2002
    Location
    New Zealand
    Posts
    766
    umm... kidna OT but isnt 4.4 gettign ditched

    i know debian and mandrake are both stickign with 4.3 coz of license issues and fedora is switchign to a fork of the X11 project called Xorg (i think) in their next release.

    i wouldnt bother with xfree 4.4

  6. #6
    Just Joined!
    Join Date
    Mar 2004
    Posts
    3
    well I did it because I needed the support for the ati 9600 mobility pro. I have a new dell inspiron 8600 and it was the only way to get the video to work.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •