Find the answer to your Linux question:
Results 1 to 5 of 5
Hello, I am using KDE as my GUI shell. I had no problems since, everything was fine, but this night the power went off and the computer shutted down. This ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2006
    Posts
    7

    Unhappy Can't start KDE


    Hello, I am using KDE as my GUI shell. I had no problems since, everything was fine, but this night the power went off and the computer shutted down. This morning, when I tried to run X as the same user I was since now, it failed. I am using Slackware 10.1 with it's built-in version of KDE. Here is what I got:
    $ startx
    Code:
    _XSERVTransSocketOpenCOTSServer: Unable to open socket for inet6
    _XSERVTransOpen: transport open failed for inet6/stefys:0
    _XSERVTransMakeAllCOTSServerListeners: failed to open listener for inet6
    
    X Window System Version 6.8.2
    Release Date: 9 February 2005
    X Protocol Version 11, Revision 0, Release 6.8.2
    Build Operating System: Linux 2.6.13 i686 [ELF] 
    Current Operating System: Linux stefys 2.4.31 #6 Sun Jun 5 19:04:47 PDT 2005 i686
    Build Date: 11 September 2005
    	Before reporting problems, check http://wiki.X.Org
    	to make sure that you have the latest version.
    Module Loader present
    Markers: (--) probed, (**) from config file, (==) default setting,
    	(++) from command line, (!!) notice, (II) informational,
    	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (==) Log file: "/var/log/Xorg.0.log", Time: Fri Sep  8 14:21:52 2006
    (==) Using config file: "/etc/X11/xorg.conf"
    (EE) Failed to initialize GLX extension (NVIDIA XFree86 driver not found)
    Could not init font path element /usr/X11R6/lib/X11/fonts/CID/, removing from list!
    
    waiting for X server to shut down
    Running 'startx' as another user (I tried root) works fine, but only the X server running as stefys is configured. As I can see, they are giving some font errors. Like a week ago, I read on some site that I can use windows fonts on linux. I used them and it all worked fine so I doubt that this is the reason that KDE fails to start.
    I doubt KDE breaks just when a computer is unproperly shutdown. There is probably a X command or something that would remove files left on the harddisk when X was not properly shutdown. I can also show you the Xorg.0.log, but it's a pretty long file and I doubt there is any need to use it. The last line in Xorg.0.log is:
    Code:
    Could not init font path element /usr/X11R6/lib/X11/fonts/CID/, removing from list!
    If you need to see Xorg.0.log just tell me and I will post it somewhere.
    Thanks for everyone helping.

  2. #2
    Linux Engineer Zelmo's Avatar
    Join Date
    Jan 2006
    Location
    Riverton, UT, USA
    Posts
    1,001
    The Xorg log would be helpful. At this point, the only indication of what is wrong is the line about the GLX extension. It could be that X isn't finding the nvidia driver, or the path to the nvidia GLX libraries might be wrong. One of these could happen if, for example, you updated your Linux kernel or Nvidia drivers sometime between the previous successful boot and the time when the power went out. The Xorg log will tell which part of loading the driver didn't work, and we can go from there.

    Don't worry about font warnings. They're very common, and never hurt anything. They pop up because either fonts got removed and their old path is still in the X config file, or a font path was put into the config file but the font was never actually installed. You can remove the offending lined from the X config if they really annoy you, but like I said, they don't hurt anything.
    Stand up and be counted as a Linux user!

  3. #3
    Just Joined!
    Join Date
    Sep 2006
    Posts
    7
    Ok, I put xorg.conf as an attachment, but Xorg.0.log was too big to be put as an attachment here so I added it as a pastebin link here
    Attached Files Attached Files

  4. #4
    Linux Engineer Zelmo's Avatar
    Join Date
    Jan 2006
    Location
    Riverton, UT, USA
    Posts
    1,001
    All right, in your Xorg.conf, the driver being loaded is vesa. Nothing wrong with that per sei, but the glx module is being loaded, and according to the log file, that glx module is Nvidia's libglx version 5336 (found in /usr/X11R6/lib/modules/extensions/libglx.so, as indicated on line 276 of the log). It looks like what's happening is Nvidia's glx doesn't work with the vesa driver, so you get an error that glx can't be initialized, with the explanation that the nvidia driver isn't found.

    There are three ways around this, that I can see:
    1. Don't load glx. You can comment out the line in the Xorg.conf that says Load glx, thus eliminating the conflict. The drawback is that you won't get any 3D support.

    2. Remove the Nvidia glx library, and replace it with mesa. How you do that depends on your distro, and maybe even on how you installed Nvidia's glx library (if you did it manually). But just selecting the mesa packages from your package manager should do the trick.

    3. If you're using an Nvidia graphics card, you'll probably want to keep the Nvidia glx library and also use Nvidia's binary driver. Again, if your package manager has packages for the nvidia driver, install it that way. Or you can grab the driver installer from Nvidia's Web site. If you already have it, you might just need to change your Xorg.conf to use the nvidia driver instead of vesa.
    Stand up and be counted as a Linux user!

  5. #5
    Just Joined!
    Join Date
    Sep 2006
    Posts
    7
    I fixed it without messing with xorg.conf. First, I tried moving /tmp to /tmp2 so I can see if anything is wrong in that /tmp directory. After I moved it, X was still not starting. I decided to move my home directory (/home/stefys) to /home/stefys2 and create a new empty home directory with write permissions. After I did this new home directory, X loaded fine so I decided there must be some config file in my home that is wrong. I started moving from /home/stefys2 to /home/stefys files starting with . one by one. I moved all the directories that X could possibly use, but I couldn't reproduce the error with the new home directory. Later, I decided to move any file starting with '.' from my old home to my new home and the error was reproduced. My error was in one of those files starting with '.'. I tried moving a few back, and finally I realised that X was not starting because of .xinitrc
    This is very weird, .xinitrc is an empty file and it has nothing to do with any NVIDIA driver.
    I did install the NVIDIA driver in past but I did not configure XF86Config as they told me to.
    Anyways, it's working now, thanks for your help.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •