Find the answer to your Linux question:
Results 1 to 10 of 10
Hi... I log onto KDE using startx everytime .. And When I log out I only get End Session option no reboot or shutdown option? I have to su and ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! Twinkle's Avatar
    Join Date
    Aug 2006
    Posts
    61

    Shutdown/reboot option in KDE


    Hi...

    I log onto KDE using startx everytime ..
    And When I log out I only get End Session option no reboot or shutdown option?

    I have to su and run reboot or poweroff everytime..

    Was wondering how can I log into graphical insterface striaght away and how can I enable the poweroff/reboot button option and allow the current user to excute it ..

    Thanks in advance

  2. #2
    Banned jan1024188's Avatar
    Join Date
    Jul 2006
    Location
    EU, SLOVENIA
    Posts
    1,549
    what distro do you have....i think you should make runlevel5 as default....i hope that helps

  3. #3
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Hi !!

    control center ---> KDE components ---> Session Manager

    check "confirm logout" and "offer shutdown options" check boxes



    .... casper ....
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined! Twinkle's Avatar
    Join Date
    Aug 2006
    Posts
    61
    I am running Debian with KDE 3.5 ...

    I checked the session manager .. both those options are already checked!!! I also did it from root and they are checked in root to ...

    Any ideas!

  6. #5
    Blackfooted Penguin daark.child's Avatar
    Join Date
    Apr 2006
    Location
    West Yorks
    Posts
    4,393
    If you want the shutdown and reboot options in KDE, then you will have to use KDM. On Debian, you would do "apt-get install kdm" and then do "update-rc.d kdm defaults" or "dpkg-reconfigure kdm" to make sure that kdm is run at boot up.

    Alternatively you could add the Lock Screen / Logout applet to your kicker.

  7. #6
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Hi !

    Quote Originally Posted by Twinkle
    I am running Debian with KDE 3.5 ...

    I checked the session manager .. both those options are already checked!!! I also did it from root and they are checked in root to ...

    Any ideas!
    on terminal type this command.....

    $ sudo dpkg-reconfigure kdm




    .... casper ....
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  8. #7
    Just Joined! Twinkle's Avatar
    Join Date
    Aug 2006
    Posts
    61
    Quote Originally Posted by devils_casper
    Hi !



    on terminal type this command.....

    $ sudo dpkg-reconfigure kdm




    .... casper ....
    I just checked synaptic .. KDM isn't installed .. I will need to install it first before running dpkg ...

  9. #8
    Just Joined! Twinkle's Avatar
    Join Date
    Aug 2006
    Posts
    61
    Hi,,

    I have installed KDM ..
    How can I configure it now?

    I log onto KDE using "startx"

  10. #9
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Hi !!


    $ sudo dpkg-reconfigure kdm



    .... casper ....
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  11. #10
    Just Joined! Twinkle's Avatar
    Join Date
    Aug 2006
    Posts
    61
    I get this error:

    HTML Code:
    home:/home/devil# dpkg-reconfigure kdm
    Xlib: connection to ":0.0" refused by server
    Xlib: Invalid MIT-MAGIC-COOKIE-1 key
    dpkg-reconfigure: cannot connect to X server :0.0
    debconf: unable to initialize frontend: Kde
    debconf: (DISPLAY problem?)
    debconf: falling back to frontend: Dialog

    After I installed it I rebooted and now I have the graphical login and shutdown/reboot menu but all of my NON-KDE menues fonts are super SMALL .. I have to squint to read them?!!
    I tried changing the font size from the KDE control center,, it worked only for KDE apps..

    Need Help!!!

    By the way when I run dpkg-reconfigure kdm I get an option of KDM and XDM !!! I always click on KDM and then I get the error...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •