Find the answer to your Linux question:
Results 1 to 5 of 5
Hi all, I'm trying to install kahakai 0.6.2 under RedHat 9. I've successfully done the ./configure, make, and make install, but how do I actually use the window manager? There ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2004
    Location
    Toronto,ON,Canada
    Posts
    5

    installing kahakai under RedHat 9


    Hi all,

    I'm trying to install kahakai 0.6.2 under RedHat 9. I've successfully done the ./configure, make, and make install, but how do I actually use the window manager? There is no option under Sessions in my log in screen for this window manager. I've tried a million different things, but I can't seem to figure out how to start the WM. Can anyone out there help? thanks!

  2. #2
    Linux Engineer big_k105's Avatar
    Join Date
    May 2003
    Location
    Fargo, ND
    Posts
    901
    create a file in your home directory called .xinitrc and if its already there open it and put
    Code:
    exec kahakai
    in that file then restart your xwindows and it should start out in the new kahakai. i believe this will work but im not sure cause i am using slackware and this is what i use to get on kahakai
    BIG K aka Kyle
    Programming Forums
    www.kylekonline.com
    Please don\'t PM me for help-- ask in the forums instead!

  3. #3
    Just Joined!
    Join Date
    Mar 2004
    Location
    Toronto,ON,Canada
    Posts
    5
    hmmm... it still doesn't work. if i go to system tools --> more system tools --> Desktop switching tool I only have options for GNOME, KDE or TWM. I don't get an error from running exec kahakai though.. it just doesn't do anything.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Mar 2004
    Location
    Toronto,ON,Canada
    Posts
    5
    I've tried to add the kahakai option to my session options when RedHat boots (It boots directly to a GUI) by adding a file called kahakai to /etc/X11/gdm/Sessions with the contents:

    Code:
    #!/bin/bash -login
    /etc/X11/xdm/Xsession kahakai
    and adding the following code to /etc/X11/xdm/Xsession under the case statement

    Code:
    kahakai)
    exec kahakai
    ;;
    but it still hasn't worked....

    thanks for any more help you can give!

  6. #5
    Just Joined!
    Join Date
    Mar 2004
    Location
    Toronto,ON,Canada
    Posts
    5
    never mind. I had misspelled Xsession in one file.

    Fixed it, and now it works.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •