Find the answer to your Linux question:
Results 1 to 4 of 4
I'm running RedHat 8.0 on a laptop, and before the login screen, I get a message saying that the X-Server cannot be started because it is not set up properly. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2004
    Posts
    10

    Cant start X-Window


    I'm running RedHat 8.0 on a laptop, and before the login screen, I get a message saying that the X-Server cannot be started because it is not set up properly. It then shows me the log file and this is the error that I see:

    Could not init font path element unix/:7100,removing from list!

    Fatal server error:
    could not open default font 'fixed'

    I have no idea what this means, and running the x configuration program does not fix the problem. It was running fine at one point, so I'm not sure what I did to cause this

  2. #2
    Linux Engineer kriss's Avatar
    Join Date
    Jun 2003
    Posts
    1,113
    try to run this command: service xfs start
    and startx

    Good luck

  3. #3
    Just Joined!
    Join Date
    Apr 2004
    Posts
    10
    k, i tried service xfs start, and it came up with
    Starting xfs [OK]

    then when i tried startx, i got the same error as before, but now it also reports:

    XIO: fatal IO error 104 (Connection reset by peer) on X server ":0.0"
    after 0 requests(0 known processed) with 0 events remaining

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Apr 2004
    Posts
    6
    Are you sure to have some font installed?
    The X server will try to open at least one of them through the xfs (X Font Server)... Bye!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •