Find the answer to your Linux question:
Results 1 to 1 of 1
When trying to start my X server I get the following error message in Xorg.log.0: (EE) No devices detected. Fatal server error: no screens found I have a Dell Dimension ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2007
    Posts
    1

    Xorg.log : no screens found


    When trying to start my X server I get the following error message in Xorg.log.0:

    (EE) No devices detected.

    Fatal server error:
    no screens found

    I have a Dell Dimension 4700 that is running a Redhat WS 4.0 based version of Linux. I purchased an ATI Radeon X1300 graphics card (PCI express) to drive a new Gateway FPD2485W TFT Monitor.

    I tried installing the rpm from ATI (fglrx_6_8_0-8.33.6-1.i386.rpm) but it would not complete because of wanting libexpat.so.1.x when I only have libexpat.so.0.x. I tried the mirror site for CentOS but could not find an rpm for libexpat.so.1.x. They did have an rpm for the fglrx drivers (ati-fglrx-8.22.5-2.slc4.cern.i686.rpm). I installed this rpm without any problems. I also worked with an xorg.conf file from a friend that has a similar setup and modified it. I loaded fglrx with modprobe.

    I can get the display up using a default vesa driver, but would like to be up and running using the fglrx drivers for the video card. Attached are the log files and some additional information:

    Xorg_0_log.txt (Xorg.0.log)
    xorg_conf.txt (xorg.conf)
    lspci.txt (output of lspci)
    lsmod.txt (output of lsmod)

    Thanks for any help that can be provided. I have been a linux user, but am new to administration. Hopefully I have just made a simple error.
    Attached Files Attached Files

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •