Find the answer to your Linux question:
Results 1 to 6 of 6
I have a fairly old GeForce 2 MX (64MB) installed with the nividia legacy drivers. I'm wondering if it will be at all possible to install Beryl. The drivers don't ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux User Oxygen's Avatar
    Join Date
    Jul 2004
    Location
    Hartlepool, England
    Posts
    392

    Beryl - Possible?


    I have a fairly old GeForce 2 MX (64MB) installed with the nividia legacy drivers. I'm wondering if it will be at all possible to install Beryl. The drivers don't work with openGL if option Composite is Enabled, but Beryl requires it. I beleive Xgl is installed, this is what Beryl says:

    Code:
    **************************************************************
    * Beryl system compatiblity check                            *
    **************************************************************
    
    Detected xserver                                : NVIDIA
    
    Checking Display :0.0 ...
    
    Checking for XComposite extension               : passed (v0.3)
    Checking for XDamage extension                  : passed
    Checking for RandR extension                    : passed
    Checking for XSync extension                    : passed
    
    Checking Screen 0 ...
    
    Xlib:  extension "GLX" missing on display ":0.0".
    Root visual is not a GL visual
    Are there some beta drivers or something that may support it?
    Graham - You'd better Use Linux!

    I'm registerd Linux user #397030. What about you?

  2. #2
    Linux Guru
    Join Date
    Nov 2004
    Posts
    6,110
    Have you tried AIGLX rather than XGL? It is a little lighter I find and doesn't require the composite extension iirc. What I would say however is that there are some GL functions that your card probably won't support so you won't have all of the effects. For example my old GeForce 4400 couldn't run the rain/water plugins.

  3. #3
    Linux User Oxygen's Avatar
    Join Date
    Jul 2004
    Location
    Hartlepool, England
    Posts
    392
    I did, I get the exact same error.

    EDIT: 3D Desktop doesn't work anymore, I think it's a related problem. I'm going to undo the chnages and see what happens.

    EDIT 2: Unless someone has a guide on getting the nVidia legacy drivers working with beryl, I'll have to leave it. it seems what it wants is going to screw over my system because it's just too damn old.

    I'm going to restart my "Help Graham Armstrong buy a better computer fund".
    Graham - You'd better Use Linux!

    I'm registerd Linux user #397030. What about you?

  4. #4
    Linux Guru Juan Pablo's Avatar
    Join Date
    Mar 2006
    Location
    /home/south_america/ecuador/quito
    Posts
    2,064
    Well, the only way to use Beryl on old cards is through XGL, not AIGLX, no Nvidia rendering platform. The legacy drivers don't support the extension needed by Xorg to use AIGLX
    Put your hand in an oven for a minute and it will be like an hour, sit beside a beautiful woman for an hour and it will be like a minute, that is relativity. --Albert Einstein
    Linux User #425940

    Don't PM me with questions, instead post in the forums

  5. #5
    Just Joined!
    Join Date
    Mar 2007
    Location
    INDIA
    Posts
    7

    Check..

    Quote Originally Posted by Oxygen
    I have a fairly old GeForce 2 MX (64MB) installed with the nividia legacy drivers. I'm wondering if it will be at all possible to install Beryl. The drivers don't work with openGL if option Composite is Enabled, but Beryl requires it. I beleive Xgl is installed, this is what Beryl says:

    Code:
    **************************************************************
    * Beryl system compatiblity check                            *
    **************************************************************
    
    Detected xserver                                : NVIDIA
    
    Checking Display :0.0 ...
    
    Checking for XComposite extension               : passed (v0.3)
    Checking for XDamage extension                  : passed
    Checking for RandR extension                    : passed
    Checking for XSync extension                    : passed
    
    Checking Screen 0 ...
    
    Xlib:  extension "GLX" missing on display ":0.0".
    Root visual is not a GL visual
    Are there some beta drivers or something that may support it?

    You can check with rpm.livna.org . I think they have necessary drivers. Try it

  6. #6
    Linux User Oxygen's Avatar
    Join Date
    Jul 2004
    Location
    Hartlepool, England
    Posts
    392
    I'm gona derail my topic here, but since I started messing with this, my capslock key has stopped working. Any ideas why or how I can reset my keyboard settings?
    Graham - You'd better Use Linux!

    I'm registerd Linux user #397030. What about you?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •