Find the answer to your Linux question:
Results 1 to 5 of 5
OS: SUSE Enterprise 10 Desktop: GNOME I can't login into GUI(KDE, GNOME), when I ran "startx", I got the following erors/messages, and got the prompt back(remains in cli ). #startx ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Feb 2007
    Posts
    248

    startx doesnt work.. plz help asap


    OS: SUSE Enterprise 10
    Desktop: GNOME

    I can't login into GUI(KDE, GNOME), when I ran "startx", I got the following erors/messages, and got the prompt back(remains in cli ).

    #startx
    xauth: creating new authority file /root/.serverauth.8516

    X Window System Version 6.9.0
    Release Date: 21 December 2005
    X Protocol Version 11, Revision 0, Release 6.9
    Build Operating System: SuSE Linux [ELF] SuSE
    Current Operating System: Linux pc1 2.6.16.21-0.8-smp #1 SMP Mon Jul 3 18:25:39 UTC 2006 i686
    Build Date: 16 June 2006
    Before reporting problems, check http://wiki.X.Org
    to make sure that you have the latest version.
    Module Loader present
    Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (==) Log file: "/var/log/Xorg.0.log", Time: Sun Dec 31 22:27:24 2006
    (==) Using config file: "/etc/X11/xorg.conf"
    Could not init font path element /usr/X11R6/lib/X11/fonts/local, removing from list!
    Could not init font path element /usr/X11R6/lib/X11/fonts/CID, removing from list!
    /etc/X11/xim: Checking wether an input method should be started.
    INPUT_METHOD is not set or empty (no user selected input method).
    Trying to start a default input method for the locale en_US.UTF-8 ...
    There is no default input method for the current locale.
    /usr/X11R6/bin/gnome: line 216: /opt/gnome/bin/gnome-session: No such file or directory
    /usr/X11R6/bin/gnome: line 216: exec: /opt/gnome/bin/gnome-session: cannot execute: No such file or directory


    waiting for X server to shut down FreeFontPath: FPE "/usr/X11R6/lib/X11/fonts/misc:unscaled" refcount is 2, should be 1; fixing.

    I can run " /usr/X11R6/bin/X " successfuly.
    I can run "/usr/sbin/sax2" successfuly.

  2. #2
    Just Joined! royper's Avatar
    Join Date
    Jan 2007
    Location
    Berlin, Germany
    Posts
    32
    Try to reconfigure your x-server settings:

    Code:
    dpkg-reconfigure xserver-xorg
    (you need to be root to do that)

  3. #3
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Quote Originally Posted by royper
    Try to reconfigure your x-server settings:

    Code:
    dpkg-reconfigure xserver-xorg
    (you need to be root to do that)
    thats for Debian based distros. for SuSe, its 'sax2'.

    Quote Originally Posted by needee
    There is no default input method for the current locale.
    /usr/X11R6/bin/gnome: line 216: /opt/gnome/bin/gnome-session: No such file or directory
    /usr/X11R6/bin/gnome: line 216: exec: /opt/gnome/bin/gnome-session: cannot execute: No such file or directory
    whats the output of 'startkde'?
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined! royper's Avatar
    Join Date
    Jan 2007
    Location
    Berlin, Germany
    Posts
    32
    Quote Originally Posted by devils_casper
    thats for Debian based distros. for SuSe, its 'sax2'.
    my fault. Didn't know that

  6. #5
    Linux Newbie
    Join Date
    Feb 2007
    Posts
    248
    thanks for help/replies
    startkde, is not available on this system, because on this machine only GNOME is installed.

    one more thing when I ran "yast", I got the following error
    #yast
    warning: the ncurses frontend is installed but does not work
    You need to install yast2-ncurses to use the YaST2 text mode interface
    I have yast2-ncurses installed
    # rpm -q yast2-ncurses
    yast2-ncurses-2.13.40-1.2

    Plz help

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •